[PTS][BT][HFP] In-call screen can't dismiss even call connection is terminated. (TC_AG_TWC_BV_01_I )

VERIFIED FIXED

Status

Firefox OS
Bluetooth
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: hlu, Assigned: arthurcc)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:leo+, firefox26 fixed, b2g18 verified, b2g-v1.1hd fixed)

Details

Attachments

(3 attachments)

(Reporter)

Description

4 years ago
Created attachment 792735 [details]
logcat.txt

[Version Info]
    Gaia:     0f1f1ab0ab31a1df8a780baa048b5e7b2854205d
      B-D     2013-08-15 06:32:03
    Gecko:    http://hg.mozilla.org/releases/mozilla-b2g18/rev/692d3414bb12
    BuildID   20130815041201
    Version   18.0

Test case : TC_AG_TWC_BV_01_I started
- Verifying dongle settings, disabling eSCO
- Dongle verification complete
- SDP Service record for PTS: 'Handsfree HF' successfully registered
- The IUT claims support for the following eSCO LMP packet types: EV3, 2-EV3, 
- The IUT claims support for the following eSCO LMP packet types: EV3, 2-EV3, 
- AT: SPP connect succeeded
- AT: Service Level Connection established
- AT: post SLC command sequence complete
- AT: RING
- AT: Received +CLIP: "0958028209",129
- AT: Incoming call established
- HCI: Audio Connection enabled
- AT: Received +CCWA: "0939808982",129
- AT: Call terminated
- MTC: Call disabled by IUT
- HCI: Audio Connection disabled
- AT: Service Level Connection disabled
- MTC: Test case ended
(Reporter)

Comment 1

4 years ago
Created attachment 792737 [details]
VID_20130820_180504.3gp
(Reporter)

Updated

4 years ago
QA Contact: hlu

Comment 2

4 years ago
The test case runs as following:
1) Connect 1st call <- active call.
2) Receive 2nd call <- incoming call.
3) Send 'CHLD=0' to dialer to inform 2nd call of busy state.
4) Hang up 1st call.

Expected result: in-call screen dismisses after step 4).

Comment 3

4 years ago
Arthur, this bug seems to be dialer UI problem when running CHLD=0 command. Can you help check it?

Updated

4 years ago
Blocks: 905079
status-b2g18: --- → affected
status-b2g-v1.1hd: --- → affected
status-firefox26: --- → unaffected
Created attachment 795331 [details]
link to https://github.com/mozilla-b2g/gaia/pull/11753

The bug can only be reproduced on v1-train. In `exitCallScreen` it checks `busyNotificationLock` and the lock should be set to false in the timeout function in all conditions.

Anthony, could you help review the change? Thanks!
Attachment #795331 - Flags: review?(anthony)

Updated

4 years ago
Assignee: nobody → arthur.chen
Nominate for leo+ since this fails BT certification.
blocking-b2g: --- → leo?
leo+ for cert issue
blocking-b2g: leo? → leo+
Comment on attachment 795331 [details]
link to https://github.com/mozilla-b2g/gaia/pull/11753

I'll redirect to Etienne as I'm not familiar with that part yet.
Attachment #795331 - Flags: review?(anthony) → review?(etienne)
Comment on attachment 795331 [details]
link to https://github.com/mozilla-b2g/gaia/pull/11753

It does indeed make much more sense.
Thanks Arthur!
Attachment #795331 - Flags: review?(etienne) → review+
Thanks for reviewing!

master: https://github.com/mozilla-b2g/gaia/commit/e1a725f4c975be6cefaf5c04c7faabbae498d175
Status: NEW → RESOLVED
Last Resolved: 4 years ago
status-firefox26: unaffected → fixed
Resolution: --- → FIXED
v1.1.0hd: e1a725f4c975be6cefaf5c04c7faabbae498d175
v1.1.0hd: f26b39f85db811a130245320ac50894b4a88400a
status-b2g-v1.1hd: affected → fixed
status-b2g18: affected → fixed
(Reporter)

Comment 11

4 years ago
This issue was verified in below vesion of Unagi, and the result is passed.

Gaia:     9fb5802df60a9081846d704def01df814ed8fbd4
  B-D     2013-09-01 02:12:02
Gecko:   
BuildID   20130902060051
Version   26.0a1
Status: RESOLVED → VERIFIED

Comment 12

4 years ago
The issue no longer reproduces on Leo COM RIL 1.1
When the calling device terminates the call, the call is dismissed from the DUT

Environmental  Variables:
Build ID: 20130904041204
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/307824edadd7
Gaia: d0a415bbf23e5d01c2b287d9fca708e167cfe70d
Platform Version: 18.1
RIL Version: 01.01.00.019.212
Firmware revision: D300f10a
status-b2g18: fixed → verified
You need to log in before you can comment on or make changes to this bug.