Last Comment Bug 907167 - Bugzilla Sandstone Skin: The moz_login dropdown collapses when I move over its entries
: Bugzilla Sandstone Skin: The moz_login dropdown collapses when I move over it...
Status: RESOLVED FIXED
:
Product: bugzilla.mozilla.org
Classification: Other
Component: Sandstone/Mozilla Skin (show other bugs)
: Production
: x86_64 Linux
: -- normal (vote)
: ---
Assigned To: Byron Jones ‹:glob› [PTO until 2016-10-10]
:
:
Mentors:
https://bugzilla.mozilla.org/show_bug...
: 916579 (view as bug list)
Depends on:
Blocks: 882548
  Show dependency treegraph
 
Reported: 2013-08-20 06:33 PDT by Frederik Braun [:freddyb]
Modified: 2013-09-16 06:50 PDT (History)
2 users (show)
See Also:
Due Date:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Frederik Braun [:freddyb] 2013-08-20 06:33:05 PDT
I am logged in to bugzilla and getting to my preferences requires me to move over my email address and then click on Preferences in the drop down list.
Sad thing is, the drop down already collapsed when I move may mouse away from my email address down to the items (My Bugs, Preferences, ...).

This doesn't appear to happen on all pages though, but on show_bug and enter_bug.
Comment 1 Frederik Braun [:freddyb] 2013-08-20 06:48:37 PDT
NoScript disabled downloading the Open Sans woff that the CSS includes. Once I whitelisted it, the dropdown worked as intended.

My assumption: if I block the font, the calculated sizes are probably wrong and I will shortly highlight something between email address and the dropdown, which makes it collapse again.

I would love the theme to work without the font. There's a reason NoScript blocks them by default.
Comment 2 Byron Jones ‹:glob› [PTO until 2016-10-10] 2013-08-20 07:36:01 PDT
i'm unable to reproduce this issue, even with noscript blocking fonts on aurora.  the menu appears in the correct location, and i can easily select an item.
Comment 3 Frederik Braun [:freddyb] 2013-08-21 00:32:01 PDT
I noticed that it heavily depends on my mouse cursor speed. The slower I move my cursor from the email address to the dropdown list, the longer the time I am in between those two and the more likely it is for the dropdown to disappear.
Comment 4 Frederik Braun [:freddyb] 2013-08-26 04:57:53 PDT
This issue is causedby the style for ".links .dropdown ul" in global.css line 194 following.
If it was "top: 24px" instead of 26px it would work regardless of the font.

I understand that there's little point in supporting every users's setup with this theme and it might look like an edge case here. Maybe there's a way to make the dropdown appear below the username regardless of the font used?
Comment 5 Byron Jones ‹:glob› [PTO until 2016-10-10] 2013-09-16 00:51:03 PDT
i can reproduce the problem now, will investigate.
Comment 6 Byron Jones ‹:glob› [PTO until 2016-10-10] 2013-09-16 00:51:17 PDT
*** Bug 916579 has been marked as a duplicate of this bug. ***
Comment 7 Byron Jones ‹:glob› [PTO until 2016-10-10] 2013-09-16 01:03:59 PDT
ok, this should do it:

Committing to: bzr+ssh://bjones%40mozilla.com@bzr.mozilla.org/bmo/4.2/
modified skins/contrib/Mozilla/global.css
Committed revision 9004.
Comment 8 Frederik Braun [:freddyb] 2013-09-16 01:52:11 PDT
Thanks for looking into this again!
Has this already been pushed to production? It's still affecting me
Comment 9 Byron Jones ‹:glob› [PTO until 2016-10-10] 2013-09-16 06:50:55 PDT
(In reply to Frederik Braun [:freddyb] from comment #8)
> Thanks for looking into this again!
> Has this already been pushed to production? It's still affecting me

no; we push updates weekly. follow blog.glob.com.au if you want to keep abreast of bmo updates :)

Note You need to log in before you can comment on or make changes to this bug.