Closed Bug 907318 Opened 7 years ago Closed 7 years ago

"Acid Defender" WebAudio game has much more reverb compared to Chrome

Categories

(Core :: Web Audio, defect)

x86
macOS
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 908669
Tracking Status
firefox25 --- unaffected
firefox26 --- affected

People

(Reporter: cpeterson, Assigned: rillian)

References

()

Details

STR:
1. Load http://www.cappel-nord.de/webaudio/acid-defender/
2. Play "Jam Mode"
3. Switch focus to a different application

RESULT:
Compared to Chrome, Firefox's audio has a LOT more reverb and "crunchy" sound artifacts. 

The game stops playing audio when you switch focus to a different application, but Firefox keeps playing the crunchy sound artifacts until the page is unloaded.

This game relies on WebAudio's OscillatorNode, so the game was not playable in Firefox until OscillatorNode bug 865253 landed today.
Ralph, can you please take a look?  Thanks!
Assignee: nobody → giles
This might be a dupe of bug 908669.
Whiteboard: [dupe?]
Depends on: 908669
So it sounds like they're leaving the pipeline running, including reverb, but switch off the instruments when the tab loses focus so you get a nice fade-out effect.

Most of the crunch is the same glitching I described in the oscillatornode bug. I guess it happens even when the nodes aren't playing anything.
Yeah, Paul's guess was that it is the glitches that are being amplified under reverb.
Confirmed. Now that bug 908669 has landed, I don't hear a difference in the crunchiness of the sounds or in reverb when switching away from the tab.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Whiteboard: [dupe?]
Duplicate of bug: 908669
The reverb issue was bug 924286.
You need to log in before you can comment on or make changes to this bug.