Handle AudioChunk::mVolume (from GainNode) in BiquadFilterNodeEngine

RESOLVED FIXED in Firefox 26

Status

()

defect
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: karlt, Assigned: karlt)

Tracking

Trunk
mozilla27
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox26 fixed, firefox27 fixed, b2g-v1.2 fixed)

Details

(Whiteboard: [qa-])

Attachments

(1 attachment)

Assignee

Description

6 years ago
No description provided.
Assignee

Comment 1

6 years ago
Attachment #814651 - Flags: review?(ehsan)
Assignee

Comment 2

6 years ago
Will include testcase in bug 924288.
Flags: in-testsuite?
Comment on attachment 814651 [details] [diff] [review]
handle non-unit mVolume

Review of attachment 814651 [details] [diff] [review]:
-----------------------------------------------------------------

Sorry that I forgot about this.  I think I forgot to handle mVolume in about every single engine that I implemented.  And I did audit them all at some point but perhaps it was before BiquadFilterNode.
Attachment #814651 - Flags: review?(ehsan) → review+
Assignee

Comment 4

6 years ago
:) I'm bit surprised it took us so long to notice.  I've checked all the nodes that use the blink subdir, and Bug 924290 is the only remaining.
Assignee

Comment 5

6 years ago
Er, I mean bug 924289.
(In reply to comment #5)
> Er, I mean bug 924289.

\o/
Assignee

Comment 7

6 years ago
Oh, sorry.  Good news:  blink/DynamicsCompressor.cpp already handles that (since bug 864613).
https://hg.mozilla.org/mozilla-central/rev/d53c32505943
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla27
Assignee

Comment 10

6 years ago
Test landed in bug 924288
https://hg.mozilla.org/integration/mozilla-inbound/rev/d8fe38e7b4f7
Flags: in-testsuite? → in-testsuite+
Assignee

Comment 11

6 years ago
Comment on attachment 814651 [details] [diff] [review]
handle non-unit mVolume

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Web Audio BiquadFilterNode bug 865246
User impact if declined: 
There are some situations (single non-null input BiquadFilterNode) where an author's gain control will be completely ineffective.  For example, attempts to silence a stream will fail.

Testing completed (on m-c, etc.): on m-c, aurora; in testsuite
Risk to taking this patch (and alternatives if risky): 
small patch, small influence, low risk
String or IDL/UUID changes made by this patch: none
Attachment #814651 - Flags: approval-mozilla-beta?
Attachment #814651 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Whiteboard: [qa-]
You need to log in before you can comment on or make changes to this bug.