Closed Bug 907415 Opened 7 years ago Closed 7 years ago

Use BrowserID assertions to authenticate currently logged in user to Sync 2.0 token server

Categories

(Firefox :: Sync, defect)

defect
Not set

Tracking

()

VERIFIED DUPLICATE of bug 912188

People

(Reporter: ckarlof, Assigned: spenrose)

References

Details

(Whiteboard: [qa+])

After a user logs in to her Firefox Account, the browser obtains a sessionToken and signed public key from the Firefox Account Server. The browser uses the signed public key to generate BrowserID assertions for authenticating itself to the Sync 2.0. For our Milestone 1, this signed public key might have a long validity period, but it is intended to be shortish and periodically re-signed using the sessionToken.
Ryan Kelly has stood up a Sync 2.0 token server that accepts BrowserID assertions for dev purposes at http://auth.oldsync.dev.lcip.org/ Details: https://mail.mozilla.org/pipermail/sync-dev/2013-August/000392.html
Summary: Generate BrowserID assertions to authenticate currently logged in user to Sync 2.0 token server → Use BrowserID assertions to authenticate currently logged in user to Sync 2.0 token server
Next steps:

  1) Get an account on rkelly's Sync 2.0 token server
  2) Create a static assertion blob for that account.
  3) Add an xpcshell test file to services/services/sync/tests/unit/ that:
    i. Passes the assertion to the token server and receives the token
    ii. Passes the token to the storage server at http://db1.oldsync.dev.lcip.org/
Assignee: nobody → spenrose
Depends on: 909967
Depends on: 910479
Bug #912188 is a more specific bug for this.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 912188
Yep. Makes sense.
Status: RESOLVED → VERIFIED
No longer blocks: 905997
No longer depends on: 910479
Component: Firefox Sync: Backend → Sync
Product: Cloud Services → Firefox
You need to log in before you can comment on or make changes to this bug.