Intermittent social/browser_blocklist.js | Test timed out

RESOLVED FIXED in Firefox 27

Status

defect
RESOLVED FIXED
6 years ago
5 months ago

People

(Reporter: emorley, Assigned: markh)

Tracking

({intermittent-failure})

Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox27 fixed, firefox28 fixed, firefox29 fixed, firefox-esr24 fixed, b2g-v1.2 fixed, b2g-v1.3 fixed)

Details

Attachments

(1 attachment)

Rev5 MacOSX Mountain Lion 10.8 fx-team debug test mochitest-browser-chrome on 2013-08-20 17:05:27 PDT for push fa35146109b6

slave: talos-mtnlion-r5-086

https://tbpl.mozilla.org/php/getParsedLog.php?id=26796501&tree=Fx-Team

{
...
17:17:22     INFO -  --DOMWINDOW == 52 (0x1555ad738) [serial = 2373] [outer = 0x157009ef8] [url = about:blank]
17:17:22     INFO -  --DOMWINDOW == 51 (0x133a0dad8) [serial = 2358] [outer = 0x0] [url = https://test1.example.com/browser/browser/base/content/test/social/social_activate.html]
17:17:22     INFO -  --DOMWINDOW == 50 (0x1295cbc38) [serial = 2349] [outer = 0x0] [url = https://test1.example.com/browser/browser/base/content/test/social/social_activate.html]
17:17:22     INFO -  --DOMWINDOW == 49 (0x12a4e3618) [serial = 2352] [outer = 0x0] [url = https://example.com/browser/browser/base/content/test/social/social_activate.html]
17:17:22     INFO -  --DOMWINDOW == 48 (0x133ad3668) [serial = 2355] [outer = 0x0] [url = https://example.com/browser/browser/base/content/test/social/social_activate.html]
17:17:22     INFO -  --DOMWINDOW == 47 (0x154c5f268) [serial = 2263] [outer = 0x0] [url = about:newtab]
17:17:22     INFO -  --DOMWINDOW == 46 (0x154d19398) [serial = 2361] [outer = 0x0] [url = https://test1.example.com/browser/browser/base/content/test/social/social_activate.html]
17:17:22     INFO -  --DOMWINDOW == 45 (0x12a455618) [serial = 2283] [outer = 0x0] [url = chrome://browser/content/browser.xul]
17:17:22     INFO -  --DOMWINDOW == 44 (0x157009ef8) [serial = 2372] [outer = 0x0] [url = https://test1.example.com/browser/browser/base/content/test/social/social_activate.html]
17:17:22     INFO -  --DOMWINDOW == 43 (0x133a9d178) [serial = 2364] [outer = 0x0] [url = https://test1.example.com/browser/browser/base/content/test/social/social_activate.html]
17:17:22     INFO -  --DOMWINDOW == 42 (0x15ff44148) [serial = 2375] [outer = 0x0] [url = chrome://mozapps/content/extensions/blocklist.xul]
17:17:22     INFO -  --DOMWINDOW == 41 (0x1189eb908) [serial = 10] [outer = 0x0] [url = about:blank]
17:17:28     INFO -  --DOMWINDOW == 40 (0x133a2e418) [serial = 2369] [outer = 0x0] [url = https://test1.example.com/browser/browser/base/content/test/social/social_sidebar.html]
17:17:28     INFO -  --DOMWINDOW == 39 (0x13268c648) [serial = 2360] [outer = 0x0] [url = https://test1.example.com/browser/browser/base/content/test/social/social_activate.html]
17:17:28     INFO -  --DOMWINDOW == 38 (0x1554c5e98) [serial = 2351] [outer = 0x0] [url = https://test1.example.com/browser/browser/base/content/test/social/social_activate.html]
17:17:28     INFO -  --DOMWINDOW == 37 (0x1295b5ef8) [serial = 2354] [outer = 0x0] [url = https://example.com/browser/browser/base/content/test/social/social_activate.html]
17:17:28     INFO -  --DOMWINDOW == 36 (0x1295003c8) [serial = 2357] [outer = 0x0] [url = https://example.com/browser/browser/base/content/test/social/social_activate.html]
17:17:28     INFO -  --DOMWINDOW == 35 (0x132e09e48) [serial = 2265] [outer = 0x0] [url = about:newtab]
17:17:28     INFO -  --DOMWINDOW == 34 (0x15abb5428) [serial = 2363] [outer = 0x0] [url = https://test1.example.com/browser/browser/base/content/test/social/social_activate.html]
17:17:28     INFO -  --DOMWINDOW == 33 (0x12a4584e8) [serial = 2284] [outer = 0x0] [url = about:blank]
17:17:28     INFO -  --DOMWINDOW == 32 (0x15de18478) [serial = 2374] [outer = 0x0] [url = https://test1.example.com/browser/browser/base/content/test/social/social_activate.html]
17:17:28     INFO -  --DOMWINDOW == 31 (0x1295a2ae8) [serial = 2366] [outer = 0x0] [url = https://test1.example.com/browser/browser/base/content/test/social/social_activate.html]
17:17:28     INFO -  --DOMWINDOW == 30 (0x15ffbebd8) [serial = 2376] [outer = 0x0] [url = about:blank]
17:17:28     INFO -  --DOMWINDOW == 29 (0x13fa893c8) [serial = 2370] [outer = 0x133a68578] [url = https://test1.example.com/browser/browser/base/content/test/social/social_worker.js]
17:17:28     INFO -  --DOMWINDOW == 28 (0x133a68578) [serial = 2367] [outer = 0x0] [url = https://test1.example.com/browser/browser/base/content/test/social/social_worker.js]
17:17:31     INFO -  NOTE: child process received `Goodbye', closing down
17:17:31     INFO -  WARNING: NS_ENSURE_TRUE(compMgr) failed: file nsComponentManagerUtils.cpp, line 49
17:17:31     INFO -  nsStringStats
17:17:31     INFO -   => mAllocCount:            128
17:17:31     INFO -   => mReallocCount:            1
17:17:31     INFO -   => mFreeCount:             128
17:17:31     INFO -   => mShareCount:            155
17:17:31     INFO -   => mAdoptCount:              0
17:17:31     INFO -   => mAdoptFreeCount:          0
17:17:43  WARNING -  TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/base/content/test/social/browser_blocklist.js | Test timed out
}
Any ideas about this one? :-)
Flags: needinfo?(mixedpuppy)
The last successful line was http://mxr.mozilla.org/mozilla-central/source/browser/base/content/test/social/browser_blocklist.js#40

It then appears to time out during the resetBlocklist() call (http://mxr.mozilla.org/mozilla-central/source/browser/base/content/test/social/head.js#334).

This seems to be confirmed by the failures later on in the test run:
{
11:29:24     INFO -  TEST-PASS | chrome://mochitests/content/browser/browser/base/content/test/social/browser_social_activation.js | all providers removed
11:29:24     INFO -  TEST-INFO | chrome://mochitests/content/browser/browser/base/content/test/social/browser_social_activation.js | pre-test: starting with 0 providers
11:29:24     INFO -  TEST-INFO | chrome://mochitests/content/browser/browser/base/content/test/social/browser_social_activation.js | sub-test testActivationMultipleProvider starting
11:29:24     INFO -  ************************************************************
11:29:24     INFO -  * Call to xpconnect wrapped JSObject produced this error:  *
11:29:24     INFO -  [Exception... "'Error: SocialProvider: provider with origin [https://test1.example.com] is blocklisted' when calling method: [nsIRunnable::run]"  nsresult: "0x8057001c (NS_ERROR_XPC_JS_THREW_JS_OBJECT)"  location: "native frame :: <unknown filename> :: <TOP_LEVEL> :: line 0"  data: no]
11:29:24     INFO -  ************************************************************
11:29:24     INFO -  TEST-INFO | chrome://mochitests/content/browser/browser/base/content/test/social/browser_social_activation.js | Console message: [JavaScript Error: "[Exception... "'Error: SocialProvider: provider with origin [https://test1.example.com] is blocklisted' when calling method: [nsIRunnable::run]"  nsresult: "0x8057001c (NS_ERROR_XPC_JS_THREW_JS_OBJECT)"  location: "native frame :: <unknown filename> :: <TOP_LEVEL> :: line 0"  data: no]"]
}
On IRC, philor noticed these failures seem to correlate with the network being down, and we guess that the use of http://test:80 *might* be a problem.  This patch instead uses example.org as the blocklist URL, and the test passes locally for me - so it's worth a try!
Attachment #8347831 - Flags: review?(mixedpuppy)
Comment on attachment 8347831 [details] [diff] [review]
0001-Bug-907689-use-example.org-as-the-blocklist-URL.-r-m.patch

There are a couple other tests (non socialapi) that use test:80, just wondering if they may be causing other issues elsewhere.
Attachment #8347831 - Flags: review?(mixedpuppy) → review+
Flags: needinfo?(mixedpuppy)
https://hg.mozilla.org/integration/fx-team/rev/5e784d8a55f8
Assignee: nobody → mhammond
Status: NEW → ASSIGNED
https://hg.mozilla.org/mozilla-central/rev/5e784d8a55f8
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → Firefox 29
(In reply to Shane Caraveo (:mixedpuppy) from comment #78)
> Comment on attachment 8347831 [details] [diff] [review]
> 0001-Bug-907689-use-example.org-as-the-blocklist-URL.-r-m.patch
> 
> There are a couple other tests (non socialapi) that use test:80, just
> wondering if they may be causing other issues elsewhere.

Can't help but notice that browser_aboutHome.js is one of them. Gavin, maybe that's relevant? Those failures also have appeared to be network-related.
Flags: needinfo?(gavin.sharp)
(In reply to Mark Hammond [:markh] from comment #75)
> On IRC, philor noticed these failures seem to correlate with the network
> being down, and we guess that the use of http://test:80 *might* be a
> problem.

Any ideas about why there would be a difference? Both "test" and "example.org" are in server-locations.txt...

http://mxr.mozilla.org/mozilla-central/source/build/pgo/server-locations.txt#61
Flags: needinfo?(gavin.sharp)
It seems unlikely that would be the cause of bug 945667, FWIW.
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.