If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[B2G][Helix][everthing search][yangshiqi]The thumbnails and text of the app in everthing search are overlapping and imperfect

VERIFIED FIXED

Status

Firefox OS
Gaia::Everything.me
P2
normal
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: lecky, Assigned: Evyatar 'Tron' Amitay (everything.me))

Tracking

unspecified

Firefox Tracking Flags

(blocking-b2g:hd+, b2g18 fixed, b2g-v1.1hd fixed, b2g-v1.2 fixed)

Details

(Whiteboard: [perf-reviewed])

Attachments

(8 attachments)

(Reporter)

Description

4 years ago
User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; .NET4.0C; .NET4.0E)

Steps to reproduce:

The thumbnails and text of the app in everthing search are overlapping and imperfect
1.Press everthing search to enter in ,
2.check the app thumbnails and text in it
3.press any thumbnails of the app to enter in
4.check the app thumbnails and text in it



Actual results:

The thumbnails and text of the app in everthing search are overlapping and imperfect


Expected results:

The thumbnails and text of the app display normally
(Reporter)

Updated

4 years ago
blocking-b2g: --- → hd?
(Reporter)

Updated

4 years ago
Component: General → Gaia::Everything.me
Product: Core → Boot2Gecko
(Reporter)

Updated

4 years ago
Severity: normal → blocker
Priority: -- → P2
(Reporter)

Updated

4 years ago
OS: Windows 7 → All
Hardware: x86 → All

Updated

4 years ago
Whiteboard: [perf-reviewed]
(Reporter)

Updated

4 years ago
Flags: needinfo?(wchang)
Hi Ran,

I think this is already under your radar?

Aiming for v1.2 here.
Severity: blocker → normal
blocking-b2g: hd? → ---
Flags: needinfo?(wchang) → needinfo?(ran)
Hey Wayne, I was told that v1.1.0hd should no longer need attention.
This bug does not appear in master afaik.

So, is it still relevant?
Flags: needinfo?(ran)
(Reporter)

Updated

4 years ago
Flags: needinfo?(brg)
(Reporter)

Comment 3

4 years ago
Would that be acceptable if this bug is not fixed in v1.1.
Can you attach several screenshots of the issue?  To make an screenshot you must press home and power on key at the same time. Thanks.
Flags: needinfo?(brg) → needinfo?(lecky.wanglei)
(Reporter)

Comment 5

4 years ago
Created attachment 809676 [details]
2013-09-25-13-56-54.png
Flags: needinfo?(lecky.wanglei)
(Reporter)

Comment 6

4 years ago
Created attachment 809677 [details]
2013-09-25-13-57-25.png
(Reporter)

Comment 7

4 years ago
Created attachment 809678 [details]
2013-09-25-13-58-13.png
(Reporter)

Comment 8

4 years ago
Created attachment 809680 [details]
2013-09-25-13-58-28.png
(Reporter)

Updated

4 years ago
Priority: P2 → P1
(Reporter)

Updated

4 years ago
Priority: P1 → P2
This issue was fixed in master in Bug 910338
(Reporter)

Comment 10

4 years ago
hi ,I aleady privoid some screenshots,and still wait you reply ,do you have a result
Flags: needinfo?(brg)
(In reply to Ran Ben Aharon (Everything.me) from comment #9)
> This issue was fixed in master in Bug 910338
This is a bug for branch 1.1hd. We need a patch for this specific branch. I do not know if it is better to include your patch here or ask for hd+ in your current implementation for master(the bug you pointed 910338 had no patches included, there must be a mistake. What is the best way to proceed?
Flags: needinfo?(brg) → needinfo?(ran)
We aim to attach a patch by Oct 22nd.
Flags: needinfo?(ran)
Thanks Ran, nominating to hd accordingly
blocking-b2g: --- → hd?
Hi Ran,

Sorry I missed your comment on this til now. v1.1HD was resurrected and we need to have this corrected.
Would bug 905455 not fix this here?

Thanks.
blocking-b2g: hd? → hd+
Flags: needinfo?(ran)
(Assignee)

Updated

4 years ago
Assignee: nobody → evyatar
hi Wayne - unfortunately bug 905455 only handles master, which is at this point too far from 1.1.
I'm now preparing a patch specifically for 1.1.
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Flags: needinfo?(ran)
Created attachment 819443 [details]
Patch - redirect to github PR

Pretty small fixes. the issue was that we once used Canvas in the HTML. And we set the canvas' CSS width/height according to the device pixel ratio. BUT since then we moved on to use IMG tags instead of Canvas, and we left the width/height CSS on the canvas.

tl;dr - I put CSS width/height on the displayed images with the real size.
Attachment #819443 - Flags: review?(ran)
Comment on attachment 819443 [details]
Patch - redirect to github PR

Works great
Attachment #819443 - Flags: review?(ran) → review+
merged to v1.1.0hd
1b11c1e926d236b374f07a6ad7eddab89de228ce

https://github.com/mozilla-b2g/gaia/commit/1b11c1e926d236b374f07a6ad7eddab89de228ce
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Beatriz, we'd like to uplift this to v1.2 as well. Should we change the nom to koi?
Flags: needinfo?(brg)
Please uplift this fix in v1.2 as well.
status-b2g-v1.2: --- → affected
Flags: needinfo?(brg)
uplifted to 1.2
00d5964eabf95a6a8a632420dfa36fc76dcbc9b7

https://github.com/mozilla-b2g/gaia/commit/00d5964eabf95a6a8a632420dfa36fc76dcbc9b7

* Please note I had to add this change as well, since v1.2 is very different than v1.1 https://github.com/mozilla-b2g/gaia/commit/00d5964eabf95a6a8a632420dfa36fc76dcbc9b7#diff-0
Keywords: qawanted

Updated

4 years ago
QA Contact: atsai
(Assignee)

Updated

4 years ago
status-b2g-v1.2: affected → fixed
Note - for verifications, use verifyme if you need QA verification, not qawanted.
Keywords: qawanted → verifyme

Updated

4 years ago
status-b2g-v1.1hd: --- → affected

Updated

4 years ago
Blocks: 905455
Update v1.1 flag based on comment 21.

v1.1.0hd: 48d6065eaaad98edaa639a7c2dadf3a7e464e481
v1.1.0hd: 1b11c1e926d236b374f07a6ad7eddab89de228ce
status-b2g18: --- → fixed
status-b2g-v1.1hd: affected → fixed
(Reporter)

Comment 24

4 years ago
Created attachment 821424 [details]
white blank.rar
(Reporter)

Comment 25

4 years ago
Created attachment 821428 [details]
20131011055921baobo-进入设置显示白屏.7z
(Reporter)

Comment 26

4 years ago
Please ignore "Comment 24" and  "Comment 25", i miss-uploaded the log, they are for another bugreport.

Sorry for this.

Thanks!

Comment 27

4 years ago
Verified it.

* Test Build: (Mozilla Build)
 - Gaia:     63cd1d96b5a94e9b22ffc54dfde48ef6d3cf996b
 - Gecko:    http://hg.mozilla.org/releases/mozilla-b2g18_v1_1_0_hd/rev/7cd7f30328e1
 - BuildID   20131022042302
 - Version   18.0

Attaching the screenshot.
Status: RESOLVED → VERIFIED

Comment 28

4 years ago
Created attachment 821577 [details]
[E.ME] Main page

Updated

4 years ago
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.