QT movie is not painted correctly after scrolling browser window

RESOLVED INVALID

Status

()

P3
major
RESOLVED INVALID
17 years ago
7 years ago

People

(Reporter: chrispetersen, Unassigned)

Tracking

Trunk
Future
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PL2:NA][QT], URL)

(Reporter)

Description

17 years ago
Build: 2001071303
Platform : Mac OS X
Expected results: Qt movie should be repainted after scrolling occurs.
What I got: Artifacts of the movie are painted all over the window. Window is
not updated after scrolling is completed.

Steps to reproduce:

1) Go to url: http://www.apple.com/macosx/theater/dock.html

2) When movie starts to displays, vertical scroll the window.

3) Notice the QT movie is repainted after scrolling window.
(Reporter)

Comment 1

17 years ago
This problem isn't occuring under "Classic" mode with the Mac OS 9 build
(2001071303).
Summary: QT movie is not painted correctly when scrolling window → QT movie is not painted correctly after scrolling browser window
(Reporter)

Updated

17 years ago
Severity: normal → major
(Reporter)

Comment 2

17 years ago
Oops. Step 3 should have said:

Notice the QT movie is "not" repainted after scrolling the movie.

Comment 3

17 years ago
changing QA to OS X guy: Petersen :-)
QA Contact: shrir → petersen

Comment 4

17 years ago
Mac plugin bug---->peterl
Assignee: av → peterlubczynski

Comment 5

17 years ago
*** Bug 95925 has been marked as a duplicate of this bug. ***

Comment 6

17 years ago
This happens in IE 5.1 with Quicktime too which leads me to believe it's not
completely our fault (we do worse that IE). It looks like an update/slowness
issue and we don't correctly invalidate the dirty area left behind.
Status: NEW → ASSIGNED
Priority: -- → P3
Target Milestone: --- → mozilla1.0

Comment 7

17 years ago
Yeah, our carbon code doesn't correctly invalidate when scrolling. See also bug 
86729. I was lame, I need to make that code work for carbon. see 
nsWindow::ScrollBits();
smfr, i already rewrote scrollbits to use the os on osx and remove all our hacked 
code. i would assume you sr'd it ;)

Comment 9

17 years ago
I don't think the OS call deals with scrolling dirty regions as well. I'd be 
surprised if it did.

Updated

17 years ago
Blocks: 102998

Comment 10

17 years ago
Bugs targeted at mozilla1.0 without the mozilla1.0 keyword moved to mozilla1.0.1 
(you can query for this string to delete spam or retrieve the list of bugs I've 
moved)
Target Milestone: mozilla1.0 → mozilla1.0.1

Comment 11

17 years ago
*** Bug 121300 has been marked as a duplicate of this bug. ***

Comment 12

16 years ago
this still happens, but it happens on windows as well, this is not mac specific
OS: MacOS X → All
Hardware: Macintosh → All
Whiteboard: [QT]
Target Milestone: mozilla1.0.1 → mozilla1.1alpha

Comment 13

16 years ago
this is easy to reproduce -- I will show you Peter when you want to see this
Whiteboard: [QT] → [PL2:NA][QT]
Target Milestone: mozilla1.1alpha → mozilla1.0.2

Comment 14

16 years ago
*** Bug 91906 has been marked as a duplicate of this bug. ***

Updated

16 years ago
Target Milestone: mozilla1.0.2 → Future

Comment 15

16 years ago
*** Bug 160271 has been marked as a duplicate of this bug. ***

Comment 16

16 years ago
*** Bug 160271 has been marked as a duplicate of this bug. ***

Comment 17

16 years ago
Simon Fraser fixed a similiar problem in Chimera.  Perhaps his fix there should
be ported to the Mozilla tree?

Updated

16 years ago
Blocks: 180209

Updated

16 years ago
No longer blocks: 102998

Comment 18

16 years ago
See also bug 160435.

Comment 19

16 years ago
Just thought I'd comment that I tried the URL from the original description just
now and this is still happening in Moz 1.4b.

Comment 20

11 years ago
testcase URL no longer valid
Assignee: peterlubczynski-bugs → nobody
Status: ASSIGNED → NEW
QA Contact: chrispetersen → plugins

Comment 21

7 years ago
This bug has outlived it's usefulness.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID

Comment 22

7 years ago
I'm too embarrassed not to apologize for typing "it's" when I meant "its". Sorry for the spam!
You need to log in before you can comment on or make changes to this bug.