Crash @ android.database.CursorIndexOutOfBoundsException: Index 40 requested, with a size of 40

VERIFIED FIXED in Firefox 26

Status

()

--
critical
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: aaronmt, Assigned: Margaret)

Tracking

({crash, regression, reproducible})

26 Branch
Firefox 26
ARM
Android
crash, regression, reproducible
Points:
---

Firefox Tracking Flags

(firefox26 verified)

Details

(Whiteboard: [native-crash], crash signature)

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
E/GeckoAppShell(24867): >>> REPORTING UNCAUGHT EXCEPTION FROM THREAD 1 ("main")
E/GeckoAppShell(24867): android.database.CursorIndexOutOfBoundsException: Index 40 requested, with a size of 40
E/GeckoAppShell(24867): 	at android.database.AbstractCursor.checkPosition(AbstractCursor.java:424)
E/GeckoAppShell(24867): 	at android.database.AbstractWindowedCursor.checkPosition(AbstractWindowedCursor.java:136)
E/GeckoAppShell(24867): 	at android.database.AbstractWindowedCursor.getInt(AbstractWindowedCursor.java:68)
E/GeckoAppShell(24867): 	at android.database.CursorWrapper.getInt(CursorWrapper.java:102)
E/GeckoAppShell(24867): 	at android.database.CursorWrapper.getInt(CursorWrapper.java:102)
E/GeckoAppShell(24867): 	at org.mozilla.gecko.home.HomeListView$HomeContextMenuInfo.<init>(HomeListView.java:134)
E/GeckoAppShell(24867): 	at org.mozilla.gecko.home.HomeListView.onItemLongClick(HomeListView.java:88)
E/GeckoAppShell(24867): 	at android.widget.AbsListView.performLongPress(AbsListView.java:3234)
E/GeckoAppShell(24867): 	at android.widget.AbsListView$CheckForLongPress.run(AbsListView.java:3181)
E/GeckoAppShell(24867): 	at android.os.Handler.handleCallback(Handler.java:730)
E/GeckoAppShell(24867): 	at android.os.Handler.dispatchMessage(Handler.java:92)
E/GeckoAppShell(24867): 	at android.os.Looper.loop(Looper.java:137)
E/GeckoAppShell(24867): 	at android.app.ActivityThread.main(ActivityThread.java:5368)
E/GeckoAppShell(24867): 	at java.lang.reflect.Method.invokeNative(Native Method)
E/GeckoAppShell(24867): 	at java.lang.reflect.Method.invoke(Method.java:525)
E/GeckoAppShell(24867): 	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:1046)
E/GeckoAppShell(24867): 	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:862)
E/GeckoAppShell(24867): 	at dalvik.system.NativeStart.main(Native Method)

For whatever reason I get this crash long-tapping onto one of my synced bookmarks multiple levels deep and the last bookmark visible on the screen. 

bp-ca757863-5480-4aff-87fb-c7c3f2130822

--
Samsung Galaxy SIV (Android 4.3)
(Reporter)

Comment 1

6 years ago
Any folder deep (from Sync) and long-tapping the last bookmark does this for me. Mystery.
(Reporter)

Updated

6 years ago
tracking-fennec: --- → ?
(Assignee)

Comment 2

6 years ago
I can investigate.
Assignee: nobody → margaret.leibovic
(Assignee)

Comment 3

6 years ago
Created attachment 795724 [details] [diff] [review]
patch
Attachment #795724 - Flags: review?(sriram)
(Assignee)

Updated

6 years ago
Duplicate of this bug: 908656
Comment on attachment 795724 [details] [diff] [review]
patch

Review of attachment 795724 [details] [diff] [review]:
-----------------------------------------------------------------

::: mobile/android/base/home/BookmarksListView.java
@@ +150,5 @@
> +    @Override
> +    public boolean onItemLongClick(AdapterView<?> parent, View view, int position, long id) {
> +        // Adjust the item position to account for the parent folder row that is inserted
> +        // at the top of the list when viewing the contents of a folder.
> +        BookmarksListAdapter adapter = getBookmarksListAdapter();

make this final.
Attachment #795724 - Flags: review?(sriram) → review+
https://hg.mozilla.org/mozilla-central/rev/ed5ffec871a6
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 26
(Reporter)

Updated

6 years ago
Status: RESOLVED → VERIFIED
tracking-fennec: ? → ---
status-firefox26: --- → verified
You need to log in before you can comment on or make changes to this bug.