If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Long press a bookmark inside "Desktop Bookmarks" opens context menu for the wrong bookmark

RESOLVED DUPLICATE of bug 908423

Status

()

Firefox for Android
Awesomescreen
RESOLVED DUPLICATE of bug 908423
4 years ago
a year ago

People

(Reporter: havar.novik, Unassigned)

Tracking

26 Branch
ARM
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 794654 [details]
Showing wrong context menu displayed

steps to reproduce:

Open the "BOOKMARKS" tab on the Awesomescreen, go to "Desktop Bookmarks" (or possibly any folder, I don't have any other bookmark folders at the top level) and long press a bookmark.

actual results:

The context menu that opens is for the bookmark following the one that was long pressed. If the last bookmark is long pressed Firefox crashes (likely because it's trying to open a bookmark that's out of the bookmark list range).

As shown in the attachment, the bookmark for "Hacker News" is long pressed but the context menu for "Microsoft Powerpoint..." is displayed.

This happends on the new Awesomescreen in 26.0a1 (nightly), but not in the stable release, 23.0.

expected results:

Should open the context menu for the bookmark that was long pressed.
Sriram/Margaret, will this be fixed with bug 907988?
Blocks: 862793
Status: UNCONFIRMED → NEW
tracking-fennec: --- → ?
Ever confirmed: true

Comment 2

4 years ago
(In reply to Aaron Train [:aaronmt] from comment #1)
> Sriram/Margaret, will this be fixed with bug 907988?

More likely it will be fixed by bug 908423. Sounds like we're using the wrong cursor position for the context menu items.

Comment 3

4 years ago
This will be fixed by that patch in bug 908423.
Status: NEW → RESOLVED
tracking-fennec: ? → ---
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 908423
You need to log in before you can comment on or make changes to this bug.