[Buri][Data usage]The reset data usage function can't work.

RESOLVED DUPLICATE of bug 937247

Status

Firefox OS
Gaia::Cost Control
P2
normal
RESOLVED DUPLICATE of bug 937247
4 years ago
4 years ago

People

(Reporter: sync-1, Unassigned)

Tracking

unspecified

Firefox Tracking Flags

(blocking-b2g:1.3+)

Details

(Whiteboard: [comms-triaged])

Attachments

(2 attachments)

385.24 KB, application/x-zip-compressed
Details
1.14 MB, image/png
Details
(Reporter)

Description

4 years ago
Firefox os  v1.1
 Mozilla build ID:20130817041203
 
 Created an attachment (id=497520)
 PC-1
 
 DEFECT DESCRIPTION:
  Use wifi or mobile data usage ,you will find the reset function can work at first.After some days ,the reset function can't work.
 
  REPRODUCING PROCEDURES:
  1、use wifi or mobile data usage,turn on data usage APP,reset the data usage-->OK(can reset successfully)
  2、change system time and use wifi or mobile data usage ,you can try  reset function, it cant't reset after reset many times,and the function will not work successfully until you reset phone-->KO
 
  EXPECTED BEHAVIOUR:
  You can reset data usage everytime.
 
  ASSOCIATE SPECIFICATION:
 
  TEST PLAN REFERENCE:
 
  TOOLS AND PLATFORMS USED:
 
  USER IMPACT:Mid
 
  REPRODUCING RATE:6/10
 
  For FT PR, Please list reference mobile's behavior:
(Reporter)

Comment 1

4 years ago
Clone from brother
(Reporter)

Comment 2

4 years ago
Created attachment 794351 [details]
logcat log
(Reporter)

Comment 3

4 years ago
Clone from brother
(Reporter)

Comment 4

4 years ago
Created attachment 794352 [details]
PC-1
(Reporter)

Updated

4 years ago
blocking-b2g: --- → leo?

Updated

4 years ago
Duplicate of this bug: 905972

Comment 6

4 years ago
The proper STR for this bug is mentioned in Bug-905972 happens in Master V1.1.0 hd.

* Reproduction steps:
  1. Set up the cost control/Usage app
  2. Browser a webpage
  3. Using card view to close Usage app
  4. Changing the system date to any future date
  5. Browser a webpage
  6. Changing the system date to current time
  7. Open Usage app and tap reset button-->Reset operation will not work
  8. The Red and Green dots will not be shown(Bug-886276)

This bug happens changing the system time back and forth after configuring the Usage app.
Due to the BE state for 1.1 this is an expected behavior. The situation of changing big periods of time is very unlikely and when the situation is about changing for a short periods of time (around 1 day), the issue disappears as soon as present day surpasses the future date.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX

Updated

4 years ago
blocking-b2g: leo? → ---
(Reporter)

Comment 8

4 years ago
Dear Salvador, 

Check from code, it seemed when reset data usage, it doesn't clear  the data, only reset nextReset and lastDataReset value, so the usage data in future date will always be calculate. Is it right? 
If someone change the year number to next, and generate many usage data, he will unable to use this app correctly until next year. Is there any way can remedy it?
(Reporter)

Updated

4 years ago
Flags: needinfo?(salva)
(In reply to sync-1 from comment #8)
> Dear Salvador, 
> 
> Check from code, it seemed when reset data usage, it doesn't clear  the
> data, only reset nextReset and lastDataReset value, so the usage data in
> future date will always be calculate. Is it right? 

The BE reset wipes all the data so I can loose those samples related with another SIM. This is the reason I never call the real reset() method.

> If someone change the year number to next, and generate many usage data, he
> will unable to use this app correctly until next year. Is there any way can
> remedy it?

Yes, this is a problem. Thank you for spotting it. Let me check if there is a workaround for this and it there is not. I'll file another bug for this.

Thank you.
Flags: needinfo?(salva)
(Reporter)

Comment 10

4 years ago
Dear Salvador,

Ok, thank you for your response, if you file another bug, please tell me the PR number, thank you.

Comment 11

4 years ago
Dears, please also think about roaming case, if date/time of device sync with network, the statistic data usage may be inaccurate and confusing.

And I think user care about data usage when phone linked to 2g/3g network, we can't ignore the situation that phone with wrong date.

I reopen it so we can continue to discuss here.
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---

Updated

4 years ago
blocking-b2g: --- → koi?
(In reply to Jack Liu from comment #11)
> Dears, please also think about roaming case, if date/time of device sync
> with network, the statistic data usage may be inaccurate and confusing.

If you're synching with the network, the difference will be one day at most. For one day, results are mostly correct and intelligible.

> And I think user care about data usage when phone linked to 2g/3g network,
> we can't ignore the situation that phone with wrong date.

And we don't but not for v1.1 so I agree with you in nominating for koi.

> I reopen it so we can continue to discuss here.

Once 1.2 new API lands new bugs will be open to refactor parts of the Cost Control application to use the new features but if you think we need this to discuss... no problem at my side.
Flags: needinfo?(liuyongming)

Comment 13

4 years ago
Thanks for your response, I agree with you that it should be refactored in v1.2 according to better solution.

I appreciate your efforts and hope seeing it set koi+.
Flags: needinfo?(liuyongming)
ni? salva on 1.2 current status and whether this is already part of v1.2 or not
Flags: needinfo?(salva)
Whiteboard: [comms-triaged]
New Network Statistics API has been postponed for 1.3. :(
Flags: needinfo?(salva)
blocking-b2g: koi? → 1.3?
Per comment 15 blocking on that one for v1.3
blocking-b2g: 1.3? → 1.3+
Hi all, this was solved in bug 937247, marking as duplicated.
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 937247
You need to log in before you can comment on or make changes to this bug.