Closed Bug 908651 Opened 7 years ago Closed 7 years ago

The sidebar overlaps the chat window

Categories

(Firefox Graveyard :: SocialAPI, defect)

24 Branch
defect
Not set

Tracking

(firefox24+ verified, firefox25+ verified, firefox26+ verified)

VERIFIED FIXED
Firefox 26
Tracking Status
firefox24 + verified
firefox25 + verified
firefox26 + verified

People

(Reporter: adalucinet, Assigned: mixedpuppy)

References

Details

(Keywords: regression)

Attachments

(3 files)

Reproducible on:
the latest Firefox 24 Beta 5 (Build ID: 20130822154523): Mozilla/5.0 (Windows NT 6.1; rv:24.0) Gecko/20100101 Firefox/24.0
the latest Aurora (Build ID: 20130823004003): Mozilla/5.0 (Windows NT 6.1; rv:25.0) Gecko/20100101 Firefox/25.0
the latest Nightly (Build ID: 20130822030204): Mozilla/5.0 (Windows NT 6.1; rv:26.0) Gecko/20100101 Firefox/26.0

STR:
1. Launch Firefox.
2. Navigate to https://www.facebook.com/about/messenger-for-firefox and Turn on Messenger for Firefox.
3. Open minimum 7 chat windows.
4. Drag the sidebar to the left.

Expected results:
The sidebar doesn't overlap the chat window.

Actual results:
The sidebar overlaps the chat window.

Notes:
1. Reproducible also on Ubuntu and Mac OS X.
2. Screenshot attached showing this issue (cut it for privacy reasons).
3. This issue is not reproducible on Firefox 23.0.1 and 17.0.1.
This is also reproducible with the demo provider.
Thanks Bogdan, please find the regression range ASAP.
Flags: needinfo?(bogdan.maris)
QA Contact: anthony.s.hughes
Version: Trunk → 24 Branch
Here is the regression range:

Last good nightly: 2013-07-07
First bad nightly: 2013-07-08

Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=f8a08d0a1b2a&tochange=17a47dcef75d
Flags: needinfo?(bogdan.maris)
hmm, it may be this change for bug 860421, it look suspiciously suspect:

http://hg.mozilla.org/mozilla-central/rev/769c90e47963
Tracking it as its a regression but not a release blocker given the user has to open 7 chat windows and this may not be a very common scenario.

Shane, what do you think ? Should we expect a low risk patch upcoming here ?
definitely caused by bug 860421.  The issue there was that the resize handling was being called twice for for a single event (different event phases), which resulted in intermittent oranges.  I picked target for the phase as it is called much less often than bubbling and seemed to work fine, but didn't test resizing the panel itself.  The fix is just to change AT_TARGET to BUBBLING_PHASE.  This will still prevent the resize from happening twice on a single event, so the intermittent shouldn't return.
Assignee: nobody → mixedpuppy
Attachment #796842 - Flags: review?(mhammond)
Blocks: 860421
Attachment #796842 - Flags: review?(mhammond) → review+
Comment on attachment 796842 [details] [diff] [review]
fix chatbar resize handeling

[Approval Request Comment]
Bug caused by (feature/regressing bug #):  	860421
User impact if declined: minimal, some UI doesn't appear correctly if you have many open chat windows
Testing completed (on m-c, etc.): manual on m-c
Risk to taking this patch (and alternatives if risky): low
String or IDL/UUID changes made by this patch: none
Attachment #796842 - Flags: approval-mozilla-beta?
Attachment #796842 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/1b6726bb210b
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 26
Attachment #796842 - Flags: approval-mozilla-beta?
Attachment #796842 - Flags: approval-mozilla-beta+
Attachment #796842 - Flags: approval-mozilla-aurora?
Attachment #796842 - Flags: approval-mozilla-aurora+
Keywords: verifyme
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20100101 Firefox/24.0
Mozilla/5.0 (X11; Linux i686; rv:24.0) Gecko/20100101 Firefox/24.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:24.0) Gecko/20100101 Firefox/24.0

It works as expected on Windows with Firefox 24 beta 7 (Build ID: 20130829135643) with the demo provider.
On Mac OS X 10.8 and Ubuntu 12.04 x32 with Firefox 24 beta 7 and latest Nightly (Build ID: 20130830030205), I ran into this issue: http://oi43.tinypic.com/2mo60df.jpg - the X button is not completely shown; should I file another bug?
Flags: needinfo?(mixedpuppy)
(In reply to Alexandra Lucinet [QA] from comment #11)
> Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20100101 Firefox/24.0
> Mozilla/5.0 (X11; Linux i686; rv:24.0) Gecko/20100101 Firefox/24.0
> Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:24.0) Gecko/20100101
> Firefox/24.0
> 
> It works as expected on Windows with Firefox 24 beta 7 (Build ID:
> 20130829135643) with the demo provider.
> On Mac OS X 10.8 and Ubuntu 12.04 x32 with Firefox 24 beta 7 and latest
> Nightly (Build ID: 20130830030205), I ran into this issue:
> http://oi43.tinypic.com/2mo60df.jpg - the X button is not completely shown;
> should I file another bug?

If it is because your window is narrower than one chat window, then no, that is expected.  If it is something else, new but with STR.
Flags: needinfo?(mixedpuppy)
(In reply to Shane Caraveo (:mixedpuppy) from comment #12)
> If it is because your window is narrower than one chat window, then no, that
> is expected.  If it is something else, new but with STR.

I see that the content of the window is narrowed down, but all the right side of the window is hidden as in this screenshot http://oi42.tinypic.com/25gxtdy.jpg ; practically, this bug is not yet fixed; Do you still consider that a new bug should be filled?
Flags: needinfo?(mixedpuppy)
(In reply to Alexandra Lucinet [QA] from comment #13)
> (In reply to Shane Caraveo (:mixedpuppy) from comment #12)
> > If it is because your window is narrower than one chat window, then no, that
> > is expected.  If it is something else, new but with STR.
> 
> I see that the content of the window is narrowed down, but all the right
> side of the window is hidden as in this screenshot
> http://oi42.tinypic.com/25gxtdy.jpg ; practically, this bug is not yet
> fixed; Do you still consider that a new bug should be filled?

it is a different bug with a similar affect.  the patch on this bug fixed an issue where we did not collapse the chat windows (into the menubutton) when resizing the sidebar.  What appears to also be happening is that the scrollbar changed, and now overlaps the chat window rather than the chat window overlapping the scrollbar, and the width of the scrollbar area probably changed.   I don't think it is as severe as the issue fixed here.  Lets do a new bug on the overlapping scrollbar.
Flags: needinfo?(mixedpuppy)
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20100101 Firefox/24.0
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:26.0) Gecko/20100101 Firefox/26.0
Mozilla/5.0 (X11; Linux i686; rv:24.0) Gecko/20100101 Firefox/24.0
Mozilla/5.0 (X11; Linux i686; rv:26.0) Gecko/20100101 Firefox/26.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:24.0) Gecko/20100101 Firefox/24.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:26.0) Gecko/20100101 Firefox/26.0

Verified as fixed on Firefox 24 Beta 9 (Build ID: 20130905180733) and latest Nightly (2013-09-06).

Logged the Followup bug 913474 for the remaining work.
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:25.0) Gecko/20100101 Firefox/25.0 fixed
Mozilla/5.0 (X11; Linux i686; rv:25.0) Gecko/20100101 Firefox/25.0 fixed
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:25.0) Gecko/20100101 Firefox/25.0 

Verified as fixed with latest Aurora 25.0a2 (Build ID: 20130909004001).
Verified as fixed on latest Aurora (20131010004002)

Mozilla/5.0 (Windows NT 6.2; rv:26.0) Gecko/20100101 Firefox/26.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:26.0) Gecko/20100101 Firefox/26.0
Mozilla/5.0 (X11; Linux i686; rv:26.0) Gecko/20100101 Firefox/26.0
Status: RESOLVED → VERIFIED
Keywords: verifyme
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.