Closed Bug 908892 Opened 6 years ago Closed 6 years ago

[B2G][Buri][1.2][Marketplace] Packaged apps fail to install from the marketplace.

Categories

(Toolkit :: OS.File, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 909511

People

(Reporter: jzimbrick, Unassigned)

Details

(Keywords: regression, smoketest)

Attachments

(1 file)

Description:
Packaged apps do not install.  There is a placeholder icon added to the desktop, and the download is never completed.

Repro Steps:
1. Update Buri device to 1.2 moz build 20130823040202.
2. Open the Marketplace.
3. Choose a packaged app and attempt to install. (I used Terra)
4. Observe that a placeholder icon is added to the homescreen and the app's download never finishes, rendering the packaged app unusable.

Actual:
 Packaged apps do not install.

Expected:
 Packaged apps install correctly to the homescreen and are usable.

Environmental Variables
Build ID: 20130823040202
Gecko: http://hg.mozilla.org/mozilla-central/rev/fb2318875cd4
Gaia: 72d9989f759099632c3d3b8b5335b7d12d969d2f
Platform Version: 26.0a1
RIL Version: 01.01.00.019.198 

Notes:
Repro frequency: 100%
Note: This issue was produced on a Buri device using the 0808 basebuild.
I've tested it with same configuration but on 0823 base image and I'm not encountering the problem.
The log here has lots of genlock errors, but nothing specific to the apps API. We need a video of this reproducing.
Keywords: qawanted
Keywords: qawantedregression
The log here appears to indicate this is a graphics issue - there's genlock errors everywhere.
Component: Gaia → Graphics: Layers
Product: Boot2Gecko → Core
Version: unspecified → Trunk
QA Contact: nkot
(In reply to John Hammink from comment #2)
> I've tested it with same configuration but on 0823 base image and I'm not
> encountering the problem.

same here... this issues seems to be intermittent, I have 3/5 repro rate, 
I've also tested it on 8/22 build and the issue reproduced while the smoketest team (4 devices)didn't experience it while testing this build

For that reason I am unable to get a regression range. 

Jason, please let me know if I can help with anything else here.
(In reply to nkot from comment #6)
> (In reply to John Hammink from comment #2)
> > I've tested it with same configuration but on 0823 base image and I'm not
> > encountering the problem.
> 
> same here... this issues seems to be intermittent, I have 3/5 repro rate, 
> I've also tested it on 8/22 build and the issue reproduced while the
> smoketest team (4 devices)didn't experience it while testing this build
> 
> For that reason I am unable to get a regression range. 
> 
> Jason, please let me know if I can help with anything else here.

I need more information here - can we only reproduce on a 8/22 build? Are there other builds later than 8/22 we can reproduce with?
Keywords: qawanted
have tested this issue on 2013-08-21-04-02-18 and 2013-08-20-04-02-04 builds - did NOT reproduce (flashed three times to each build - 0/3 repro)

Reproduced it again on today's latest (repro rate - 2/2):
US_20130823
Build ID: 20130827040201
Gecko: http://hg.mozilla.org/mozilla-central/rev/e42dce3209da
Gaia: 599214a0f41eece076dc83cd85f5b27f8cfe67f2
Platform Version: 26.0a1
Keywords: qawanted
Looks like we know that:

- 8/20 - Does not reproduce
- 8/21 - Does not reproduce
- 8/22 - ?
- 8/23 - Does reproduce

Can someone try testing this on a 8/22 build? That will help determine the regression range here.
retested on 8/22 - reproduced (repro rate 2/2)
- 8/20 - Does not reproduce
- 8/21 - Does not reproduce
- 8/22 - Does reproduce
- 8/23 - Does reproduce

US_20130823
Build ID: 20130822040202
Gecko: http://hg.mozilla.org/mozilla-central/rev/2ab07dec6404
Gaia: abd81ff5e49bf0c9479cdc5c5eb6975cc776f632
Platform Version: 26.0a1
That's probably bug 909511. Having a regression window there is very helpful, thanks for that!
It looks like the genlock errors are unrelated. Moving to OS.File
No longer blocks: GFXB2G1.2
Component: Graphics: Layers → OS.File
Product: Core → Toolkit
(In reply to Jeff Muizelaar [:jrmuizel] from comment #12)
> It looks like the genlock errors are unrelated. Moving to OS.File

Ah. In that case, this sounds like this was fixed as part of bug 909511.

Fabrice - Is that right?
Flags: needinfo?(fabrice)
(In reply to Jason Smith [:jsmith] from comment #13)
> (In reply to Jeff Muizelaar [:jrmuizel] from comment #12)
> > It looks like the genlock errors are unrelated. Moving to OS.File
> 
> Ah. In that case, this sounds like this was fixed as part of bug 909511.
> 
> Fabrice - Is that right?

Absolutely. I should have linked both bugs, sorry about that.
Flags: needinfo?(fabrice)
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 909511
No longer blocks: b2g-central-dogfood
blocking-b2g: koi? → ---
You need to log in before you can comment on or make changes to this bug.