Closed Bug 908896 Opened 6 years ago Closed 2 years ago

Write an about:crashes app

Categories

(Firefox OS Graveyard :: Gaia, defect)

All
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:-)

RESOLVED WONTFIX
blocking-b2g -

People

(Reporter: fabrice, Unassigned, Mentored)

References

Details

(Keywords: feature)

That's the gaia side of the gecko patch that landed in bug 791380.
FYI, I have blogged my ideas for this in http://home.kairo.at/blog/2013-07/wanted_apps_about_crashes - including some thoughts about possible UI.
Bug 791380 was marked koi+ and it's not that useful without the bug here, so requesting that flag here as well.
blocking-b2g: --- → koi?
I would be super happy if we could just rewrite the existing about:crashes page to be this, and share the code between desktop and B2G.
Hey Ian, I know this is totally random but would you have time to work on this?
Flags: needinfo?(iliu)
Hi James,

The wanted Crashes App is pretty interesting for me. And it's very meaningful for improving stability of Firefox OS. I would like to take and implement it during some available time. 

For the user story, what's the expected layout of the crashes report? Everywhere I looked at some Firefox crashes reports. There are some displayed ways.

a). View the crash id via browser. Just type the config "about:crashes" in url link.
b). Integrate the report to mozilla crash reports(https://crash-stats.mozilla.com/report/index/cccd798b-bc70-48af-a694-7b4352130823)
c). Just having a view for displaying reports in the crashes app only.

I'm not sure which way is most convenient for a user/developer.
Should we need UX team for the scope? Looks like many ideas in here.:) (http://home.kairo.at/blog/2013-07/wanted_apps_about_crashes)
Flags: needinfo?(iliu)
Ian: the goal of this bug would be to write an app that displays the same information as about:crashes. The links in about:crashes link to crash reports on crash-stats.mozilla.org, which is fine, that's a separate webapp. Currently there's no way to access the list of submitted crashes on a non-rooted B2G phone.
What Ted says.

Also, here's the paragraph from my blog post where I speculated about a possible approach to UI:
[
What I personally envision is doing a list of the date/time of the crashes and next to those put a "share" button that allows people to send the crash ID to a larger-screen device via email, bluetooth or whatever. We could directly link the crash reports on https://crash-stats.mozilla.com/ in theory, but the pages there don't have a layout that looks useful on a small phone screen (right now). On future larger-screen Firefox OS devices like tablets, such a direct link will make more sense.
]
Duplicate of this bug: 890995
Its too late for gaia changes. Moving to 1.3? as a feature enhancement.
blocking-b2g: koi? → 1.3?
Keywords: feature
Not a committed feature for 1.3, so not blocking.
blocking-b2g: 1.3? → -
I know what to do here, so I'll look into this.
Assignee: nobody → jsmith
Status: NEW → ASSIGNED
Actually I just realized this is focusing on checking in Gaia changes, not just building a test app. There's already a test app in bug 791380 that would allow you to extract crashes from a non-rooted device, so we're technically unblocked here from the QA side.

This is just implementing support in the Gaia codebase directly.
Assignee: jsmith → nobody
Status: ASSIGNED → NEW
Mentor: fabrice
Firefox OS is not being worked on
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.