Spell checking language gets reset

RESOLVED FIXED in mozilla43

Status

()

Core
Spelling checker
RESOLVED FIXED
5 years ago
3 years ago

People

(Reporter: Mark Straver, Unassigned)

Tracking

(Blocks: 1 bug)

24 Branch
mozilla43
x86_64
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20100101 Firefox/24.0 (Beta/Release)
Build ID: 20130822154523

Steps to reproduce:

It seems Firefox does not remember the spell checking dictionary language across sessions.

STR:
1) Install a dictionary for a language different than the browser's language
2) In a text field, right-click and select the newly installed language
(optional) Verify that the pref is set correctly
3) Exit and restart the browser (may need 2 restarts)
4) Check the language setting in the context menu



Actual results:

The language for spell checking gets reset to the browser's locale


Expected results:

The language chosen should persist across browser restarts

Comment 1

4 years ago
This affects Linux FF 28, still.  I noticed this many many years ago and assumed that it would just get fixed, but it never did.

Comment 2

4 years ago
Hmm, okay, perhaps my case is slightly different.  I haven't installed any other languages and FF never gets reset to my locale, it always chooses the wrong language.  I'll open a new bug I guess.

Updated

4 years ago
Component: Untriaged → Spelling checker
Product: Firefox → Core

Updated

4 years ago
Blocks: 1073827

Comment 3

4 years ago
Would see that different.
FireFox, ThunderBird, and SeaMonkey do show same behaviour in this.

In all my installations (of all 3 candidates, on different machines, on XP and W8), a restart (not a reload for AddIns) sets English as spell checking language.
My local is German, some XPs are German recoveries, other do use a German SpeechPack - no differences to all this.

Since I've to deal with more than 2 languages, preferring an other one than English, this behaviour indeed is a problem.

And, to add this, I miss a button in menu line to quickly, even saving one click so often, switch between languages. «right click, move down, open sub menu, pick it» vs. «click button and click language» saves time an work.
(A button, changing it's outfit showing active language might be dream of my wishes. And if not, one quick click informs about used language, not moving into a sub menu as now.)

In an international world, this is to me urgent.

Comment 4

3 years ago
Still an issue in Fx 39 on Win8, with 2 spelling dictionaries involved. It always reverts back to the English dictionary.

Comment 5

3 years ago
(In reply to Eric March from comment #3)
As of bug 967494, landed on Thunderbird 38 and soon to land on SeaMonkey, these two programs have new behaviour: The spell check language in spellchecker.dictionary does not change if the user chooses to spell check in a different language. Each new message will start off with the dictionary defined in the preference.

So let's forget about Thunderbird and SeaMonkey, since this bug is about Firefox.

In Firefox the preference value changes as the user changes the language via the context (right click) menu explicitly or as websites are visited. Firefox tries to derive the language from the website visited, with varying success. I visited the following websites
https://bugzilla.mozilla.org/
http://www.fnac.com/
http://www.hostalpancheta.es/es/contactar.php
and my preference was set to en-US, fr-modern and es-ES in turn.

Currently the preference has absolutely no value, that's why it is not exposed on the user interface.

However, in meta-bug 1073827 there is an interesting discussion of whether this behaviour should change.

Updated

3 years ago
Depends on: 1200533

Comment 6

3 years ago
Closing this bug as per bug 1073827, comment #33.
If you want to reopen it, please present a reproducible test case.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla43
You need to log in before you can comment on or make changes to this bug.