Closed Bug 909080 Opened 7 years ago Closed 7 years ago

Losing connectivity after a few hours

Categories

(Firefox OS Graveyard :: General, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:leo+)

RESOLVED INVALID
blocking-b2g leo+

People

(Reporter: julienw, Assigned: jessica)

Details

May be related to bug 894831 or not.

When dogfooding my Unagi on a fairly recent 1.1 gecko, I noticed the following issue. After a few hours, I lose all outbound connectivity, but I still can receive calls and SMS. It happened twice in 2 days.

Therefore, when I say that I lose outbound connectivity, it means the phone _thinks_ it's not connected, and I have all the usual error messages happening in that case: offline page in the browser, no connectivity errors in the Sms app and the Dialer.

However I still had the "H" icon in the status bar, which does not happen in bug 894831.

I'm using the Mozilla RIL, and I know that Etienne got the same problem recently too.

Since I'm using a 1.1 phone, I'm asking leo on this bug, as this is fairly important, but it may or may not happening on the commercial RIL. And I don't have more precise STR, neither I got the time to get logs (which I'll do next time I get this problem).
Is this a dupe of bug 909688, Julien?
Flags: needinfo?(felash)
nope, that's what I say in bug 909688 comment 0 ;)

I've seen 2 different symptoms. Might be the same root cause though.
Flags: needinfo?(felash)
Ha!  And I even read comment 0 thoroughly here to ensure I wasn't being stupid :)

Ken, can someone on the RIL team investigate here similar to with bug 909688?  Thanks.
Flags: needinfo?(kchang)
Vicimo,

Please check if this is a RIL issue.
Flags: needinfo?(vyang)
Jessica, this issue seems to be similar with the bug which you are fixing. Please take this bug also. Thanks.
Assignee: nobody → jjong
Flags: needinfo?(kchang)
Flags: needinfo?(vyang)
Hi Julien,

Just wanted to make sure the difference between this bug and Bug 909688...
- In both bugs, you still see the "H" icon in the status bar when you lose connectivity.
- In both bugs, you can still send/receive sms and voice calls.
- In both bugs, when you try to open a webpage using the browser, you get an error message.

So which should be the 2 different symptoms? Sorry if I am missing anything..
Flags: needinfo?(felash)
Hey Jessica,

the main difference is :

* in this bug, I can receive SMS, calls, but I can't send SMS, calls. The error I get is exactly like I had no connectivity, but connectivity must be here, because I can actually receive SMS and calls. But unfortunately I didn't think of running netcfg or cat the routes.

* in bug 909688 I only lose data connectivity, and I can send SMS and pass calls.

I get bug 909688 quite easily (got it again this week end), but I get this one only once, and reported it only because Etienne told me about it 1 day before.

Does that make sense Jessica ?
Flags: needinfo?(felash)
Yes, it makes sense. Thank you for the clarification.
We will look into Bug 909688 first and see if we can reproduce this after fixing Bug 909688.
Julien

Is this reproducible on a shipping device? Please test on latest build as well.
Flags: needinfo?(felash)
Preeti> We'll see once bug 909688 is fixed, for now we can't say for sure.
Flags: needinfo?(felash)
QA Wanted - Can someone confirm that they can reproduce this on Buri or Leo 1.1 build?
Keywords: qawanted
Jessica - Would this issue filed here be device dependent or not?
Flags: needinfo?(jjong)
I'm not sure the root cause of this issue as we don't have enough information here.
But you will certainly run into similar outcomes if you don't have the fix in Bug 909688, and Bug 909688 is not device dependent, it may happen in any device when the network condition meets.
Flags: needinfo?(jjong)
The main problem in debugging this bug is that bug 909688 makes it difficult to see.

Maybe the fix in bug 909688 will fix this one too. I'll flash my dogfood device with a gecko containing the fix for bug 909688 and see.
Jessica, can you continue to investigate to see if this is something that can be resolved soon?   And if the risk is high for the fixes?  Triage is trying to evaluate if this is a leo+ bug, but we need to know the impact it is for regressions and touching other bugs like bug 917167.   Thanks
Flags: needinfo?(jjong)
We (including Tony) decided after Tony wrote comment 15 that this is important enough to hold the release.  Data connectivity has to be rock solid.
blocking-b2g: leo? → leo+
We need to find a way to reproduce this first...
I left my device idle during 5 days (with the fix in bug 909688) and data connection worked fine after coming back.

Julien, were you able to find anything after applying the fix in bug 909688? Thanks.
Flags: needinfo?(jjong)
Flags: needinfo?(felash)
I never found the symptoms that I described in comment 0 for several days.

Let's close this and I'll reopen if this reproduces.
Status: NEW → RESOLVED
Closed: 7 years ago
Flags: needinfo?(felash)
Resolution: --- → INVALID
Keywords: qawanted
You need to log in before you can comment on or make changes to this bug.