Closed Bug 909181 Opened 6 years ago Closed 6 years ago

[Gaia] Screen goes black after tapping the preview (card_view) of app

Categories

(Firefox OS Graveyard :: Gaia::System, defect)

x86
macOS
defect
Not set

Tracking

(blocking-b2g:koi+)

RESOLVED DUPLICATE of bug 920890
blocking-b2g koi+

People

(Reporter: gduan, Assigned: alive)

References

Details

(Keywords: regression, Whiteboard: [FT:System-Platform])

Attachments

(1 file)

This bug occurs in many apps, gallery ,market, and camera on m-c/master.

STR can refer to https://bugzilla.mozilla.org/show_bug.cgi?id=906606#c1 as below.

1. open gallery app or other apps with multiple images.
2. long press home button to show card view.
3. tap the app again. If not affected, redo it from 1.

And refer to https://bugzilla.mozilla.org/show_bug.cgi?id=906606#c3 ,
you may tap any place to have the fullscreen view of that item, and the screen is still black, too. After doing that, long pressing home button shows the correct screenshot on the card view.
Because gallery app is fullscreen app and the screenshot of it will be all back, I use marketplace app to reproduce this bug and take the screenshot.

Not, if this bug happens, all UI are still usable. User may blindly tap the correct place to open fullscreen view of a image. When user long presses the home button, the screenshot in card_view will be correct. This looks like repaint issue.
One more thing. I think I am wrong at first testing. This bug also happens to an app without any image on it, like test agent, UI tests.
(In reply to John Hu [:johnhu] from comment #1)
> Not, if this bug happens, all UI are still usable. User may blindly tap the
> correct place to open fullscreen view of a image. When user long presses the
> home button, the screenshot in card_view will be correct. This looks like
> repaint issue.
^^^^^^^^^^^^^^^^^^^^^^^^^
This seems page visibility is incorrect set. Not |repaint|.
(In reply to Alive Kuo [:alive] from comment #3)
> (In reply to John Hu [:johnhu] from comment #1)
> > Not, if this bug happens, all UI are still usable. User may blindly tap the
> > correct place to open fullscreen view of a image. When user long presses the
> > home button, the screenshot in card_view will be correct. This looks like
> > repaint issue.
> ^^^^^^^^^^^^^^^^^^^^^^^^^
> This seems page visibility is incorrect set. Not |repaint|.

Wow. I never found it is related to visibility issue. The symptom I met was I could still use the app to do something, such as tap an image in gallery app to open it. That's why I think it is about repaint.
Component: Gaia → Gaia::System
blocking-b2g: --- → koi?
QA Contact: laliaga
Tested as far back as 6/21 build and the issue still occurs. "Default storage location" option appears even though there is only one storage location.

- Issue occurs 6/21 1.2 -
Build ID: 20130621031231
Gecko: http://hg.mozilla.org/mozilla-central/rev/7ba8c86f1a56
Gaia: e2f19420fa6a26c4287588701efaec09a750dba1
Platform Version: 24.0a1
Does this reproduce on 1.1?
Keywords: qawanted
Commented on the wrong bug. Working on this one now.
Keywords: qawanted
I was able to repro this issue all the way back to Buri 1.2 Build ID: 20130730030200

Environmental Variables
Build ID: 20130730030200
Gecko: http://hg.mozilla.org/mozilla-central/rev/3d40d270c031
Gaia: ba5ff211fbf6a930326cc6a0d4a1205a7528630b
Platform Version: 25.0a1
RIL Version: 01.01.00.019.197 

Last working Buri 1.2 Build ID: 20130728030202

Environmental Variables
Build ID: 20130728030202
Gecko: http://hg.mozilla.org/mozilla-central/rev/73b69c146ca6
Gaia: ad923e915a38394497da682c3024ccc37390b52a
Platform Version: 25.0a1
RIL Version: 01.01.00.019.197 

This issue did not repro on Leo 1.1 Com or Moz RIL Build ID: 20130925041202

Environmental Variables
Build ID: 20130925041202
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/18175c7fdaa6
Gaia: 6d9eec501a209bea945c6f841400ec0a75fac11d
Platform Version: 18.1
Keywords: regression
Whiteboard: [FT:System-Platform]
Can this be a dup of bug 920890? Will this reproduce once bug 920890 lands?
blocking-b2g: koi? → koi+
Flags: needinfo?(alive)
Exactly dupe of 920890 I think.
Assignee: nobody → alive
Status: NEW → RESOLVED
Closed: 6 years ago
Flags: needinfo?(alive)
Resolution: --- → DUPLICATE
Duplicate of bug: 920890
You need to log in before you can comment on or make changes to this bug.