Closed Bug 909613 Opened 9 years ago Closed 9 years ago

Intermittent test_hc_nodeparentnode.html,browser_social_activation.js | Exited with code 1 during test run | application crashed [@ nsXPCWrappedJSClass::DelegatedQueryInterface(nsXPCWrappedJS*, nsID const&, void**)]

Categories

(Core :: XPConnect, defect)

x86_64
macOS
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 904474

People

(Reporter: RyanVM, Unassigned)

References

Details

(Keywords: crash, intermittent-failure)

https://tbpl.mozilla.org/php/getParsedLog.php?id=27027989&tree=Mozilla-Inbound

Rev4 MacOSX Snow Leopard 10.6 mozilla-inbound opt test mochitest-3 on 2013-08-26 16:05:56 PDT for push a559154a056c
slave: talos-r4-snow-042

16:21:54     INFO -  28322 INFO TEST-START | /tests/dom/tests/mochitest/dom-level1-core/test_hc_nodeparentnode.html
16:21:54     INFO -  Uh oh! DelegatedQueryInterface called off-main-thread!
16:21:54     INFO -  Name: nsIWebProgressListener
16:21:54     INFO -  Principal origin: [System Principal]
16:21:54     INFO -  Global's Location: jar:file:///Users/cltbld/talos-slave/test/build/application/FirefoxNightly.app/Contents/MacOS/omni.ja!/components/nsLoginManager.js
16:21:55  WARNING -  TEST-UNEXPECTED-FAIL | /tests/dom/tests/mochitest/dom-level1-core/test_hc_nodeparentnode.html | Exited with code 1 during test run
16:21:55     INFO -  INFO | automation.py | Application ran for: 0:13:52.667450
16:21:55     INFO -  INFO | zombiecheck | Reading PID log: /var/folders/Hs/HsDn6a9SG8idoIya6p9mtE+++TI/-Tmp-/tmpnTsJqcpidlog
16:21:55     INFO -  mozcrash INFO | Downloading symbols from: http://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/mozilla-inbound-macosx64/1377553304/firefox-26.0a1.en-US.mac.crashreporter-symbols.zip
16:22:32  WARNING -  PROCESS-CRASH | /tests/dom/tests/mochitest/dom-level1-core/test_hc_nodeparentnode.html | application crashed [@ nsXPCWrappedJSClass::DelegatedQueryInterface(nsXPCWrappedJS*, nsID const&, void**)]
16:22:32     INFO -  Crash dump filename: /var/folders/Hs/HsDn6a9SG8idoIya6p9mtE+++TI/-Tmp-/tmpABQ9SL/minidumps/6AAC98EE-4311-47F2-B796-C1D9E78BF007.dmp
16:22:32     INFO -  Operating system: Mac OS X
16:22:32     INFO -                    10.6.8 10K549
16:22:32     INFO -  CPU: amd64
16:22:32     INFO -       family 6 model 23 stepping 10
16:22:32     INFO -       2 CPUs
16:22:32     INFO -  Crash reason:  EXC_BAD_ACCESS / KERN_INVALID_ADDRESS
16:22:32     INFO -  Crash address: 0x0
16:22:32     INFO -  Thread 24 (crashed)
16:22:32     INFO -   0  XUL!nsXPCWrappedJSClass::DelegatedQueryInterface(nsXPCWrappedJS*, nsID const&, void**) [XPCWrappedJSClass.cpp:a559154a056c : 590 + 0x0]
16:22:32     INFO -      rbx = 0x000000013025b2f0   r12 = 0x000000011f103aa0
16:22:32     INFO -      r13 = 0x0000000103302a2c   r14 = 0x000000011f103ae8
16:22:32     INFO -      r15 = 0x0000000130229d80   rip = 0x0000000101c88eb3
16:22:32     INFO -      rsp = 0x000000011f1038f0   rbp = 0x000000011f103a70
16:22:32     INFO -      Found by: given as instruction pointer in context
16:22:32     INFO -   1  XUL!nsQueryReferent::operator()(nsID const&, void**) const [nsWeakReference.cpp:a559154a056c : 56 + 0x8]
16:22:32     INFO -      rbx = 0x000000011f103aa0   r12 = 0x000000012f9edc40
16:22:32     INFO -      r13 = 0x0000000000000001   r14 = 0x000000011f103ae8
16:22:32     INFO -      r15 = 0x0000000104986eb0   rip = 0x0000000102585574
16:22:32     INFO -      rsp = 0x000000011f103a80   rbp = 0x000000011f103a90
16:22:32     INFO -      Found by: call frame info
16:22:32     INFO -   2  XUL!nsCOMPtr_base::assign_from_helper(nsCOMPtr_helper const&, nsID const&) [nsCOMPtr.cpp:a559154a056c : 110 + 0x11]
16:22:32     INFO -      rbx = 0x000000011f103b00   r12 = 0x000000012f9edc40
16:22:32     INFO -      r13 = 0x0000000000000001   r14 = 0x0000000000000001
16:22:32     INFO -      r15 = 0x0000000104986eb0   rip = 0x000000010258250b
16:22:32     INFO -      rsp = 0x000000011f103aa0   rbp = 0x000000011f103ab0
16:22:32     INFO -      Found by: call frame info
16:22:32     INFO -   3  XUL!nsDocLoader::DoFireOnStateChange(nsIWebProgress*, nsIRequest*, int&, tag_nsresult) [nsCOMPtr.h:a559154a056c : 727 + 0xb]
16:22:32     INFO -      rbx = 0x0000000100345168   r12 = 0x000000012f9edc40
16:22:32     INFO -      r13 = 0x0000000000000001   r14 = 0x0000000000000001
16:22:32     INFO -      r15 = 0x0000000104986eb0   rip = 0x0000000101cea547
16:22:32     INFO -      rsp = 0x000000011f103ac0   rbp = 0x000000011f103b30
16:22:32     INFO -      Found by: call frame info
16:22:32     INFO -   4  XUL!nsDocLoader::FireOnStateChange(nsIWebProgress*, nsIRequest*, int, tag_nsresult) [nsDocLoader.cpp:a559154a056c : 1268 + 0x10]
16:22:32     INFO -      rbx = 0x0000000000000004   r12 = 0x0000000130aa9828
16:22:32     INFO -      r13 = 0x000000011f103b9c   r14 = 0x0000000000000000
16:22:32     INFO -      r15 = 0x0000000134567850   rip = 0x0000000101ce9f98
16:22:32     INFO -      rsp = 0x000000011f103b40   rbp = 0x000000011f103bd0
16:22:32     INFO -      Found by: call frame info
Ahah! This is the new crash after my diagnostics in bug 891891. Looks like the XPCWrappedJS that's being QIed is here: http://mxr.mozilla.org/mozilla-central/source/toolkit/components/passwordmgr/nsLoginManager.js#191
smaug, should nsDocLoader::DoFireOnStateChange be invoked off-main-thread? If so, is it supposed to be proxying its observers, or should nsIWebProgressListeners be threadsafe?
Flags: needinfo?(bugs)
It should be fired on the main thread.

Do we not have any better stack trace?
Flags: needinfo?(bugs)
(In reply to Olli Pettay [:smaug] from comment #3)
> It should be fired on the main thread.
> 
> Do we not have any better stack trace?

See https://tbpl.mozilla.org/php/getParsedLog.php?id=27027989&full=1&branch=mozilla-inbound#error2
Flags: needinfo?(bugs)
Jason, could you look at that stack.
Flags: needinfo?(bugs)
Flags: needinfo?(jduell.mcbugs)
Duplicate of this bug: 910514
Summary: Intermittent test_hc_nodeparentnode.html | Exited with code 1 during test run | application crashed [@ nsXPCWrappedJSClass::DelegatedQueryInterface(nsXPCWrappedJS*, nsID const&, void**)] → Intermittent test_hc_nodeparentnode.html,browser_social_activation.js | Exited with code 1 during test run | application crashed [@ nsXPCWrappedJSClass::DelegatedQueryInterface(nsXPCWrappedJS*, nsID const&, void**)]
This is the same stack trace as bug 904474.  Bug 497003 is the culprit.  Let's discuss in bug 497003 whether these intermittent failures are bad enough to be worth backing out bug 497003, which has made it to beta already.
Status: NEW → RESOLVED
Closed: 9 years ago
Flags: needinfo?(jduell.mcbugs)
Resolution: --- → DUPLICATE
Duplicate of bug: 904474
You need to log in before you can comment on or make changes to this bug.