[Buri][Unagi] Camera app hangs and doesn't start

VERIFIED FIXED in Firefox 26

Status

--
major
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: Bebe, Assigned: mikeh)

Tracking

({regression, smoketest})

unspecified
1.2 FC (16sep)
ARM
Gonk (Firefox OS)
regression, smoketest
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:koi+, firefox26 fixed)

Details

(Whiteboard: [fromAutomation][MEDIA_TRIAGED])

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

5 years ago
Created attachment 796017 [details]
logcat of the issue

STR:
1. Flash Unagi with latest build:
2. Start the camera app

Expected:
2. The camera app should start as usual

Actual:
2. A grey-ish interface is visibile


Reprodicibile on:
  Gecko  http://hg.mozilla.org/mozilla-central/rev/c0d1baa50a64
  Gaia  43cf923c3020d77a9fa962cc0c30fd27f647660d
  BuildID 20130826190748
  Version 26.0a1
(Reporter)

Updated

5 years ago
Summary: Camera app hangs and dosen't start on unagi → Camera app hangs and doesn't start on unagi
Seeing the same issue on Buri using the 8-27 build. Nominating for blocking since camera is unusable in this build for smoketest purposes.
blocking-b2g: --- → koi?
Keywords: regression, regressionwindow-wanted, smoketest
Summary: Camera app hangs and doesn't start on unagi → [Buri][Unagi] Camera app hangs and doesn't start on unagi
Summary: [Buri][Unagi] Camera app hangs and doesn't start on unagi → [Buri][Unagi] Camera app hangs and doesn't start
It seems will be fixed by Bug 907745.

Updated

5 years ago
Depends on: 907745

Updated

5 years ago
No longer depends on: 907745
At first, I thought it related to Bug 907745, but from attachment 796017 [details], I found following log and seems a different problem.

-------------------------------------------
[JavaScript Error: "Error: Permission denied for <app://camera.gaiamobile.org> to create wrapper for object of class UnnamedClass"]
Assignee: nobody → sotaro.ikeda.g
I tested by using master unagi ROM that I built by myself and got following error. I do not see the log in Comment 3.

----------------------------------
E GeckoConsole: [JavaScript Error: "ReferenceError: Filmstrip is not defined" {file: "app://camera.gaiamobile.org/js/camera.js" line: 445}]
Hema,

This is a regression for Aug-27. Please assign to a warm body.
Flags: needinfo?(hkoka)
(In reply to Sotaro Ikeda [:sotaro] from comment #3)
> At first, I thought it related to Bug 907745, but from attachment 796017 [details]
> [details], I found following log and seems a different problem.
> 
> -------------------------------------------
> [JavaScript Error: "Error: Permission denied for
> <app://camera.gaiamobile.org> to create wrapper for object of class
> UnnamedClass"]

I also see the log, when I tried to start camera app several times.
Assignee: sotaro.ikeda.g → nobody
I do not have a time to debug the gaia stuff, I un-assign from this bug.

Updated

5 years ago
Flags: needinfo?(hkoka)

Updated

5 years ago
Assignee: nobody → dflanagan
Regression window on Buri device:

Works using:
https://pvtbuilds.mozilla.org/pvt/mozilla.org/b2gotoro/nightly/mozilla-central-hamachi/2013/08/2013-08-26-16-32-55/

Gecko: sorry checkversion script is borked...
Gaia: 23343e6ea3cc59c3ab0ac9188aaa657bd11da4fd
BuildID 20130826163255

Broken:
https://pvtbuilds.mozilla.org/pvt/mozilla.org/b2gotoro/nightly/mozilla-central-hamachi/2013/08/2013-08-26-19-07-48/

Gecko  http://hg.mozilla.org/mozilla-central/rev/c0d1baa50a64
Gaia  43cf923c3020d77a9fa962cc0c30fd27f647660d
BuildID 20130826190748
Version 26.0a1
Keywords: regressionwindow-wanted
I see the log message Sotaro reports in comment 3, but not the one he reports in comment 4.

The message from comment 3 appears to be a Chrome javascript error from gecko, not a gaia error.

The message from comment 4 is from the camera app and appears to be a timing issue: we get a visibility change event or something before the filmstrip.js file has been lazily-loaded. I think it is benign, and if it is repeatable, we should file a separate bug to add some defensive checks to prevent it.

Mike: any idea about gecko changes that could have cause the message from comment 3?
And any interest in making the gaia patches to prevent the message in comment 4?

Feel free to take this bug from me!
Flags: needinfo?(mhabicher)
The error message is from gecko:

/dom/locales/en-US/chrome/security/caps.properties:111

On IRC, I learned this:

mrbkap: djf: Usually that means that someone didn't get their nsIClassInfo implementation quite right.
mrbkap: djf: or didn't hook up a new-style webidl binding properly.

Definitely unassigning myself from this one now.
Assignee: dflanagan → nobody
The message in comment 4 occurs if you start the camera, see the message in comment 3, then go to homescreen and tap the camera icon again. The error prevented the camera from loading fully in the first place.  So the error when you go back to it is because the visibility change handler can't run.  So I don't think we need to file a separate bug to fix that.
I'll do some digging.
Assignee: nobody → mhabicher
Status: NEW → ASSIGNED
Flags: needinfo?(mhabicher)
Severity: normal → major
Whiteboard: [fromAutomation]

Updated

5 years ago
Blocks: 884399
I suspect this changeset[1] which, according to bug 899210, landed on Aug. 26, 2013.

1. http://hg.mozilla.org/mozilla-central/rev/614052b6cbcc
Created attachment 796763 [details] [diff] [review]
path - call SetIsDOMBinding()

Add calling SetIsDOMBinding() in nsDOMCameraControl::nsDOMCameraControl(). By the patch the camera app works again on master unagi.

Updated

5 years ago
Attachment #796763 - Flags: review?(mhabicher)
(In reply to Mike Habicher [:mikeh] from comment #13)
> I suspect this changeset[1] which, according to bug 899210, landed on Aug.
> 26, 2013.
> 
> 1. http://hg.mozilla.org/mozilla-central/rev/614052b6cbcc

Yeah, it was regression from the change.
Comment on attachment 796763 [details] [diff] [review]
path - call SetIsDOMBinding()

This looks good to me, but I think Trevor should review it.
Attachment #796763 - Flags: review?(trev.saunders)
Attachment #796763 - Flags: review?(mhabicher)
Attachment #796763 - Flags: feedback+
Comment on attachment 796763 [details] [diff] [review]
path - call SetIsDOMBinding()

this is fine, but I'm really not sure what we should do  about the other impl of this constructor in FallbackCameraControl.cpp so r? someone whose actually a dom peer, sorry about the breakage
Attachment #796763 - Flags: review?(trev.saunders) → review?(bzbarsky)
Comment on attachment 796763 [details] [diff] [review]
path - call SetIsDOMBinding()

Yeah, you want this on both constructors.

Please add a blank line here before the big comment too.

r=me
Attachment #796763 - Flags: review?(bzbarsky) → review+
Created attachment 796846 [details] [diff] [review]
path v2 - call SetIsDOMBinding()

Apply the comment. Carry "bzbarsky: review+".
Attachment #796763 - Attachment is obsolete: true
Attachment #796846 - Flags: review+
blocking-b2g: koi? → koi+
Whiteboard: [fromAutomation] → [fromAutomation][MEDIA_TRIAGED]

Updated

5 years ago
Keywords: checkin-needed
following realpath is used in JB.
- /bionic/libc/upstream-freebsd/lib/libc/stdlib/realpath.c

In ICS, it was in 
- /bionic/libc/bionic/realpath.c

Updated

5 years ago
Blocks: 871364
https://hg.mozilla.org/mozilla-central/rev/9a8bdd632fbe
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Comment 24

5 years ago
Verified camera view finder no longer displays grayish screen and now takes pictures.

Verified
Buri v1.2 Mozilla RIL
Build ID: 20130830040204
Gecko: http://hg.mozilla.org/mozilla-central/rev/c7459bc8e449
Gaia: 407fbfb6a9de68ec4db2f0f3dc6c67463e293f47
Platform Version: 26.0a1
Base Image: 08/23
Verified in today's build:
Gecko  http://hg.mozilla.org/mozilla-central/rev/d54e0cce6c17
Gaia  c6d58088f207829d96e7bb33ddacf990e90752fb
BuildID 20130903040204
Version 26.0a1
Status: RESOLVED → VERIFIED

Updated

5 years ago
Keywords: checkin-needed
Where? This is koi+ and already in 1.2.
status-firefox26: --- → fixed
Keywords: checkin-needed
Target Milestone: --- → 1.2 FC (16sep)
(In reply to Ryan VanderMeulen [:RyanVM UTC-4] from comment #26)
> Where? This is koi+ and already in 1.2.

Sorry, it was my mistake. During setting flag to Bug 916220, I unintentionally set the flag :-(
(In reply to Ryan VanderMeulen [:RyanVM UTC-4] from comment #28)
> https://hg.mozilla.org/integration/b2g-inbound/rev/41f37e48b6e7

This was bug 916264 with the wrong bug # in the commit message.

Comment 30

5 years ago
Hema Koka deleted the linked story in Pivotal Tracker

Comment 31

5 years ago
Comment on attachment 796017 [details]
logcat of the issue

I am also getting the same issue like "Error: Permission denied for <app://camera.gaiamobile.org> to create wrapper for object of class UnnamedClass"]". Why this error is coming and  Any solution for this issue?
This error happens if untrusted script tries to touch a non-DOM (so only exposed to chrome scripts) object.

So you'll need to find which line of app://camera.gaiamobile.org is triggering the error for you and then see what exactly it's doing.
(In reply to srinivasvemula.mtech from comment #31)
> Comment on attachment 796017 [details]
> logcat of the issue
> 
> I am also getting the same issue like "Error: Permission denied for
> <app://camera.gaiamobile.org> to create wrapper for object of class
> UnnamedClass"]". Why this error is coming and  Any solution for this issue?

It seems different bug than this bug. Recently, there seems big changes around camera that might affect.
You need to log in before you can comment on or make changes to this bug.