Closed Bug 909857 Opened 8 years ago Closed 8 years ago

Off-by-one(?) error when selecting links on the new about:home screen

Categories

(Firefox for Android Graveyard :: Awesomescreen, defect)

ARM
Android
defect
Not set
blocker

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 909539

People

(Reporter: gcp, Unassigned)

References

Details

1) Start Firefox for Android
2) Click Awesomebar
3) Arrive at screen with on the left Most visited/Most recent/Tabs from last time
4) Click a block on the right (favicon+title+url)
5) See link being loaded that corresponds to the block that was one lower.

This obviously makes the new about:home quite...unusable.
I see this behavior on the search suggestions screen only (which requires typing into the url bar), rather than the "History" page.

Bug 908423 is a similar issue for the bookmarks list and may present a similar solution.
Additionally, this behavior only occurs after the search engines have loaded, meaning the Google search provider row is probably causing the history results to be offset by 1.
tracking-fennec: --- → ?
I'm unable to reproduce this Nightly 08/27.
>Additionally, this behavior only occurs after the search engines have loaded, meaning the Google search provider row is probably causing the history results to be offset by 1.

The about:home screen doesn't have search providers, though.
(In reply to Gian-Carlo Pascutto (:gcp) from comment #4)
> The about:home screen doesn't have search providers, though.

I was referring to comment 1 where I can only repo on the search suggestions screen.
This sounds like a dupe of bug 909539, but I'm having trouble reproducing that.
I'm gonna mark this as a dupe, let's continue the conversation over in that bug.
Status: NEW → RESOLVED
tracking-fennec: ? → ---
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 909539
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.