Add support for new canvas ellipse method.

RESOLVED FIXED in Firefox 48

Status

()

--
enhancement
RESOLVED FIXED
5 years ago
3 years ago

People

(Reporter: dongseong.hwang, Assigned: ethlin)

Tracking

(Blocks: 2 bugs, {dev-doc-complete})

Trunk
mozilla48
dev-doc-complete
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox48 fixed)

Details

(Whiteboard: [parity-blink][parity-edge])

Attachments

(3 attachments, 2 obsolete attachments)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/30.0.1599.14 Safari/537.36

Steps to reproduce:

Canvas v5 API adds a new path segment type: ellipse.
http://www.whatwg.org/specs/web-apps/current-work/multipage/the-canvas-element.html#dom-context-2d-ellipse


Actual results:

Firefox does not support canvas ellipse


Expected results:

Firefox should support canvas ellipse
(Reporter)

Comment 1

5 years ago
Recently, Blink supports canvas ellipse. https://code.google.com/p/chromium/issues/detail?id=130260

WebKit works in progress about it. https://bugs.webkit.org/show_bug.cgi?id=82791

Updated

5 years ago
Component: Untriaged → Canvas: 2D
OS: Linux → All
Product: Firefox → Core

Updated

5 years ago
Severity: normal → enhancement
Assignee: nobody → sanctity.tawdriest.stephen

Updated

4 years ago
Duplicate of this bug: 1067039
Status: UNCONFIRMED → NEW
Ever confirmed: true
Docs in need of updating when this gets fixed: https://developer.mozilla.org/en-US/docs/Web/API/CanvasRenderingContext2D.ellipse

Also removing assignee as there has been no activity in one year.
Assignee: sanctity.tawdriest.stephen → nobody
Keywords: dev-doc-needed
Hardware: x86_64 → All
Whiteboard: [parity-blink]
Whiteboard: [parity-blink] → [parity-blink][parity-edge]
(Assignee)

Updated

3 years ago
Assignee: nobody → ethlin
(Assignee)

Comment 4

3 years ago
Created attachment 8692275 [details] [diff] [review]
Part1. Implement canvas ellipse

Implement the ellipse method for canvas.
Attachment #8692275 - Flags: review?(roc)
(Assignee)

Comment 5

3 years ago
Created attachment 8692276 [details] [diff] [review]
Part2. Add test case for ellipse

Add test cases for ellipse.
Attachment #8692276 - Flags: review?(roc)
Comment on attachment 8692275 [details] [diff] [review]
Part1. Implement canvas ellipse

Review of attachment 8692275 [details] [diff] [review]:
-----------------------------------------------------------------

Needs DOM peer review for WebIDL change (though it's trivial)
Attachment #8692275 - Flags: review?(roc)
Attachment #8692275 - Flags: review?(bugs)
Attachment #8692275 - Flags: review+
Comment on attachment 8692276 [details] [diff] [review]
Part2. Add test case for ellipse

Review of attachment 8692276 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks!
Attachment #8692276 - Flags: review?(roc) → review+
Comment on attachment 8692275 [details] [diff] [review]
Part1. Implement canvas ellipse

The spec has
void ellipse(unrestricted double x, unrestricted double y, unrestricted double radiusX, unrestricted double radiusY, unrestricted double rotation, unrestricted double startAngle, unrestricted double endAngle, optional boolean anticlockwise = false)

But I guess since we don't have unrestricted in other cases either this is fine for now.
Attachment #8692275 - Flags: review?(bugs) → review+
(Assignee)

Comment 9

3 years ago
Created attachment 8730586 [details] [diff] [review]
Part1. Implement canvas ellipse (carry r+: roc, bugs)

Rebase to master.
Attachment #8692275 - Attachment is obsolete: true
(Assignee)

Comment 10

3 years ago
Created attachment 8730587 [details] [diff] [review]
Part2. Add test case for ellipse (carry r+: roc)

Rebase to master.
Attachment #8692276 - Attachment is obsolete: true
(Assignee)

Updated

3 years ago
Keywords: checkin-needed

Comment 15

3 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/1a5af4e551d4
https://hg.mozilla.org/mozilla-central/rev/0a779ce8d970
https://hg.mozilla.org/mozilla-central/rev/f9b65538a2e6
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-firefox48: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla48
You need to log in before you can comment on or make changes to this bug.