Convert ObjectActor to use protocol.js

RESOLVED DUPLICATE of bug 1037992

Status

()

Firefox
Developer Tools: Debugger
P3
normal
RESOLVED DUPLICATE of bug 1037992
5 years ago
4 years ago

People

(Reporter: benvie, Unassigned)

Tracking

(Blocks: 1 bug)

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
Converting ObjectActor to use protocol.js would allow ObjectActors to be easily used with anything else that uses protocol.js. This is the first step toward converting other existing actors to protocol.js, since most of them return ObjectActors for some of their API.
(Reporter)

Updated

5 years ago
Depends on: 909211
(Reporter)

Updated

5 years ago
Blocks: 909211
No longer depends on: 909211
(Reporter)

Comment 1

5 years ago
I think it might be worth implementing this separately from converting existing usage. There is a massive amount of usage of the existing ObjectActor/ObjectClient stuff. The new version using protocol.js can live in "objects.js" by itself or something.

Comment 2

5 years ago
Yeah, I'd use this bug for implementing the server side with protocol.js, existing clients shouldn't have to change at all.
Priority: -- → P3
This has been subsumed by bug 1037992.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1037992
You need to log in before you can comment on or make changes to this bug.