Saxon-CE documentation and demonstrations hang Firefox

RESOLVED WORKSFORME

Status

()

--
major
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: william, Unassigned)

Tracking

23 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

5 years ago
Launch the URI http://www.saxonica.com/ce/user-doc/1.1/index.html … the page begins to display, then Firefox hangs. True both on Windows and Mac OS. See also https://saxonica.plan.io/boards/1/topics/5762?r=5769
(Reporter)

Comment 1

5 years ago
(Not appropriate to use Saxon-CE to run XSLT 2.0 in Firefox until Firefox can run Saxon-CE!)
Blocks: 849556
(Reporter)

Comment 2

5 years ago
Note that, on Windows at least, this bug is a regression from Firefox 20, as per Michael Kay's comment at https://saxonica.plan.io/boards/1/topics/5762?r=5767#message-5767 .
(Reporter)

Comment 3

5 years ago
(Also fails on Android)
Hardware: x86_64 → All

Comment 4

5 years ago
This page doesn't hang in FF24+. Could you test with Firefox beta, please.
http://www.mozilla.org/en-US/firefox/all-beta.html

Working range:
bad=2013-05-23
good=2013-05-24
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=00b264c7cced&tochange=df526497d949
Flags: needinfo?(william)
(Reporter)

Comment 5

5 years ago
Works for me using Firefox 24 beta on Mac OS 10.7. There's a pause (where the blue whirly thing stops moving) during page load, but it recovers after about a second, continues to load the page and completes successfully.
Flags: needinfo?(william)

Comment 6

5 years ago
Same as previous versions of Firefox.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.