strict mode triggered by commented-out doctype inside <head>

RESOLVED DUPLICATE of bug 55264

Status

()

RESOLVED DUPLICATE of bug 55264
18 years ago
17 years ago

People

(Reporter: armccurdy, Assigned: dbaron)

Tracking

Trunk
Future
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Build   : 2001071604
Platform: Win2k

<html>
<head>
<!--
Bug 1: Why does a commented out doctype effect Bug 2 below ??
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"
"http://www.w3.org/TR/html4/loose.dtd">
-->
</head>
<body>
<!-- --<> Bug 2: This text shouldn't be seen ?? -->
</body>
</html>


This html brings up 2 issues (please could whoever does first level pass of
'UNCONFIRMED' bugs sanity check and issue seperate bug reports if required).

Bug 1) A commented out doctype in the wrong place seems to change commenting
behaviour.

Bug 2) '--<>' seems to end comments (as does '--<anything you like>') when the
doctype is present.
Bug 2 is not a bug.  -- starts and ends comments according to the SGML spec
(which HTML should adhere to and which we adhere to in strict mode).  So:

<!-- Comment -- not comment but part of SGML markup < (nonsensical here) > now
part of regular page since ">" ended the sgml markup.

Changing summary to the real issue here.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 2000 → All
Hardware: PC → All
Summary: '--<>' ends comments in strict mode ? → strict mode triggered by commented-out doctype inside <head>
(Reporter)

Comment 2

18 years ago
Thanks for the clarification.
I was slightly confused about the extent of comments by Bug 91045.

Comment 3

18 years ago
Any idea how many pages out there are affected by this? Anyway, it's definitely
a bug but not a very high priority.

This bug has been marked "future" because the original netscape engineer working 
on this is over-burdened. If you feel this is an error, that you or another
known resource will be working on this bug,or if it blocks your work in some way 
-- please attach your concern to the bug for reconsideration ----

Status: NEW → ASSIGNED
Target Milestone: --- → Future

Comment 4

18 years ago
*** Bug 91042 has been marked as a duplicate of this bug. ***

Updated

17 years ago
QA Contact: bsharma → moied
dbaron: you fixed this, no?
Assignee: harishd → dbaron
Status: ASSIGNED → NEW
This is fixed for me in current builds.... can't find the bug dbaron's fix was
in at the moment, though.

*** This bug has been marked as a duplicate of 55264 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.