Closed Bug 910741 Opened 6 years ago Closed 6 years ago

clicking on links in share panel does not open pages in tabs

Categories

(Firefox Graveyard :: SocialAPI, defect)

26 Branch
x86
macOS
defect
Not set

Tracking

(firefox23 wontfix, firefox24 verified, firefox25 verified, firefox26 verified)

VERIFIED FIXED
Firefox 26
Tracking Status
firefox23 --- wontfix
firefox24 --- verified
firefox25 --- verified
firefox26 --- verified

People

(Reporter: mixedpuppy, Assigned: mixedpuppy)

Details

Attachments

(1 file, 2 obsolete files)

Links in the share panel will not open browser tabs, unlike all other social panels.
Attached patch fix link handling in share panel (obsolete) — Splinter Review
Assignee: nobody → mixedpuppy
Attachment #797315 - Flags: review?(felipc)
STR for qa

- install demo provider at http://mixedpuppy.github.io/socialapi-demo/ (updated for this bug, reinstall if using existing profile)
- open a tab to any page
- open share panel
- share panel should have serveral clickable links at the bottom, try them

expected:

new tabs will open, one link has a target and will reload in the tab for that target

what happens:

only the last link that uses window.open will work, all others fail to open tabs
Attached patch fix link handling in share panel (obsolete) — Splinter Review
feedback implemented per conversation with felipe
Attachment #797315 - Attachment is obsolete: true
Attachment #797315 - Flags: review?(felipc)
Attachment #797377 - Flags: review?(felipc)
Attachment #797377 - Flags: review?(felipc) → review+
Shane, can you please provide better steps to reproduce? I can't discover a way to get clickable links to appear in the Demo Provider's share panel. It just shows the "Sharing" and "Data" text boxes and a share button. Clicking the share button adds the URL to the "Shared" section in the sidebar but this too is just a textbox.
(In reply to Anthony Hughes, Mozilla QA (:ashughes) from comment #4)
> Shane, can you please provide better steps to reproduce? I can't discover a
> way to get clickable links to appear in the Demo Provider's share panel. It
> just shows the "Sharing" and "Data" text boxes and a share button. Clicking
> the share button adds the URL to the "Shared" section in the sidebar but
> this too is just a textbox.

Try reactivating now, I didn't add some changes to my last commit.  The github pages are now properly updated.
It works now, thanks.
Backed out for breaking m-bc tests:

https://hg.mozilla.org/integration/fx-team/rev/d5dbccdf39fe

TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/base/content/test/social/browser_social_flyout.js | flyout should be closed - Got open, expected closed
https://hg.mozilla.org/mozilla-central/rev/c489910a28c3
Status: NEW → RESOLVED
Closed: 6 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → Firefox 26
Comment on attachment 797913 [details] [diff] [review]
fix link handling in share panel

[Approval Request Comment]
Bug caused by (feature/regressing bug #): share
User impact if declined: clicking on links (meant to open pages in browser tabs) in share panel has no affect
Testing completed (on m-c, etc.): on m-c
Risk to taking this patch (and alternatives if risky): low
String or IDL/UUID changes made by this patch: none
Attachment #797913 - Flags: approval-mozilla-beta?
Attachment #797913 - Flags: approval-mozilla-aurora?
Comment on attachment 797913 [details] [diff] [review]
fix link handling in share panel

low risk patch for a recent feature where the share panel does not open links in tabs as expected.

Adding qawanted to help with verification here.
Attachment #797913 - Flags: approval-mozilla-beta?
Attachment #797913 - Flags: approval-mozilla-beta+
Attachment #797913 - Flags: approval-mozilla-aurora?
Attachment #797913 - Flags: approval-mozilla-aurora+
Keywords: qawanted
(In reply to bhavana bajaj [:bajaj] from comment #12)
> Adding qawanted to help with verification here.

Please use the verifyme keyword in this case, thank you.
Keywords: qawantedverifyme
Verified fixed in Firefox Nightly 26.0a1 2013-09-04. Will wait for the next Aurora and Beta to verify for Firefox 25 and 24, respectively.
Status: RESOLVED → VERIFIED
Verified fixed in Firefox 25.0a2 2013-09-06.
Verified fixed in Firefox 24.0b8.
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.