Closed Bug 911108 Opened 9 years ago Closed 8 years ago

[B2G][Helix][music][yangshiqi]it has some posibilities that the icon of music lists was no resposon when press it and the num of music should greater than 130 .

Categories

(Firefox OS Graveyard :: Gaia::Music, defect, P2)

defect

Tracking

(blocking-b2g:hd+, b2g-v1.1hd fixed, b2g-v1.2 fixed)

VERIFIED FIXED
blocking-b2g hd+
Tracking Status
b2g-v1.1hd --- fixed
b2g-v1.2 --- fixed

People

(Reporter: lecky.wanglei, Assigned: dkuo)

References

Details

Attachments

(3 files)

Attached file 20130830174019279.rar
User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; .NET4.0C; .NET4.0E)

Steps to reproduce:

【Detail Description*】:it has some posibilities that the icon of music lists was no resposon when press it and the num of music should greater than 130 .
【Repro Steps*】:1.push a lot of music into mobile.(the number of music should greater than 130.)
                  2.open music ->the system lanch music list automaticlly->press musiclist icon at the right bottom of screen
【Expect Result*】:enter into music list
【Real Result*】:it has some posibilities than it was no response.  
【Test Count*】:1
【Found Count*】:5
【Gaia commit ID*】:c0ea0a4943dc8d3751b07f5b5c5d3abe06364a14  
【Gecko commit ID*】: 170f9e477571127cd40997fa2abe262ed43f0e4d 
【Log*】:20130830174019279
【Network environment】:
【Resume operation】:
【Carrier】:
blocking-b2g: --- → hd?
Priority: -- → P1
Severity: normal → blocker
Priority: P1 → P2
blocking-b2g: hd? → ---
I found the way to reproduce this bug.
1. Put 100 songs in sdcard.
2. touch the icon to switch to music list page.
3 .staying at music list page and pull out the sdcard so it will jump to the first page.
4. wait a while and insert sdcard again
5. touch the icon of mucic list ,it will no response.
Flags: needinfo?(wchang)
qawanted


Dominic, the STR maybe a bit brutal but perhaps we should consider some ways to handle this more gracefully?
Flags: needinfo?(whsu)
Flags: needinfo?(wchang)
Flags: needinfo?(dkuo)
Keywords: qawanted
I can reproduce this bug.
My test result is music app jump to the first page but the icon still highlight the music list icon.

Please refer the the following online video to see my test result.
- https://dc1.safesync.com/LMrHwTtl/WP_20131031_010.mp4?a=IwJ2-bMWHwE

* Test Build:
 + Mozilla Build:
  - Gaia:     366cb29c3ca9a25efcb95ed35d4395e613e099a5
  - Gecko:    http://hg.mozilla.org/releases/mozilla-b2g18_v1_1_0_hd/rev/369468c97d16
  - BuildID   20131029042204
  - Version   18.0
Flags: needinfo?(whsu)
Keywords: qawanted
Thanks Wayne and William, I think this issue is because when music is trying to update its db and ui, the highlight of tab did not sync with the actual result, and I think this issue should only happen on the devices like helix because it has internal and external storages.
Flags: needinfo?(dkuo)
Flags: needinfo?(dkuo)
(In reply to Dominic Kuo [:dkuo] from comment #4)
> Thanks Wayne and William, I think this issue is because when music is trying
> to update its db and ui, the highlight of tab did not sync with the actual
> result, and I think this issue should only happen on the devices like helix
> because it has internal and external storages.
hi,
I found the gracefully way to reproduce this bug.
1.just put some music in internal or external storages.
2.enter into music ,tap to music listview.
3.come to setting->media storege,choose to share the storage with you PC.
4.go back to music app,it will show a overlay.
5.come to setting->media storege again,disconnecting the sharing storage with you PC.
6.go back to music app again.
It will be reproduced and seems not only happen on the devices like ours'.
Hi Dominic, as discussed please help here.
Thanks.
blocking-b2g: --- → hd+
Change the status
Status: UNCONFIRMED → NEW
Ever confirmed: true
;)
Assignee: nobody → dkuo
Jim,

This issue is noticeable(please see steps in comment 5) but fortunately the patch is simple with just one line added, the root cause is music app did not change the hash to mix page when the player is reset which we wanted to prevent it from crash, so I manually change it to "#mix" and force the css pseudo-class to be applied, would you please review this? thanks.
Attachment #8337560 - Flags: review?(squibblyflabbetydoo)
Flags: needinfo?(dkuo)
Comment on attachment 8337560 [details] [review]
change the hash to mix page when the player is reset by the storages

This seems reasonable; rs=me.
Attachment #8337560 - Flags: review?(squibblyflabbetydoo) → review+
Thanks Jim.

Landed on master: f830cdeb9931abf487a535085701137fb2e9892e
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Hi ,dkuo, I try you patch,it still has a problem, but I think it almost fix this bug , you just need to add another code to the function stopPlayingAndReset().

function stopPlayingAndReset(){
   ...
    window.location.hash = '#mix';
    TabBar.option = 'mix';
   ...
}
otherwise it will return ,because same option equals in tabbar.

if (this.option === target.dataset.option) {
          return;}  
I test it ,it was ok.
please check it and see if this will lead to any bugs.thank you very much.
Status: RESOLVED → REOPENED
Flags: needinfo?(dkuo)
Resolution: FIXED → ---
Thanks lecky, I also found it after I merged it so that's why I didn't uplift it to v1.1.0hd, I have reverted the patch and will send a new patch for it.

Reverted on master: ceba76b0b2fd4d8ca6d29ad6d7993ac4d646b494
Flags: needinfo?(dkuo)
Attached file New patch
Jim,

Sorry for not noticing the issue that lecky mentioned in comment 12, we should also set TabBar.option to mix page to sync with the highlighted tab, can you please review it again? thanks.
Attachment #8338616 - Flags: review?(squibblyflabbetydoo)
Comment on attachment 8338616 [details] [review]
New patch

John,

Since this is a hd+ bug so I am transferring the review to you first in case our partner is blocked by this issue, I already got r+ from Jim but the previous patch has one line lack and the new patch has fixed it, would you please review it? thanks.
Attachment #8338616 - Flags: review?(squibblyflabbetydoo) → review?(johu)
Comment on attachment 8338616 [details] [review]
New patch

nice patch. r=me.
Attachment #8338616 - Flags: review?(johu) → review+
Thanks, John!

Landed on master: 2758561ca39d2d2c30a4425f087515284b6c095f
Status: REOPENED → RESOLVED
Closed: 8 years ago8 years ago
Resolution: --- → FIXED
v1.1.0hd: db9dd61b0a0e7ea9e3821dbae9775d90349578b0
v1.2: 3926f87b0b1e16ad004b6174013e8ec4cb38211b
Duplicate of this bug: 899406
Hi, Dominic,

Thanks a lot! I verified it.
I cannot reproduce this bug on V1.1.0hd

* The test build:
 - Gaia:     2d79d8c461262b4d819fba17a0e8cbc03b36b6b1
 - Gecko:    http://hg.mozilla.org/releases/mozilla-b2g18_v1_1_0_hd/rev/7245241c6c8f
 - BuildID   20131217042202
 - Version   18.0
Status: RESOLVED → VERIFIED
Depends on: 943750
You need to log in before you can comment on or make changes to this bug.