[fugu][hamachi]Music app will not show files in pick mode if device is shared using USB and then unplugged

RESOLVED FIXED in Firefox OS v1.3

Status

Firefox OS
Gaia::Music
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: cheng.luo, Assigned: squib)

Tracking

({regression})

unspecified
1.3 C3/1.4 S3(31jan)
regression
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(blocking-b2g:1.3+, b2g-v1.3 fixed, b2g-v1.3T fixed, b2g-v1.4 fixed)

Details

(URL)

Attachments

(1 attachment)

46 bytes, text/x-github-pull-request
dkuo
: review+
Details | Review | Splinter Review
(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/535.19 (KHTML, like Gecko) Ubuntu/11.04 Chromium/18.0.1025.168 Chrome/18.0.1025.168 Safari/535.19

Steps to reproduce:

bug 899866 is ok now.But I found the other steps could reproduce it on v1.2.
Reproduce Steps:
1、Connect to PC with SD storage share using USB enabled;
2、press “homescreen” to IDLE, press "message" icon,launch message app;
3、"new message" --> "add attachment",select "music" type,prompt "Unplug the phone to play music";
4、Unplug USB;


Actual results:

the music list is empty; 


Expected results:

Songs(or list) can be displayed.
This bug can be reproduced by follow the reporduse steps 1~4, but it can be easily recovered by re-selected "music" after step 4.
The state of SD card should be right but music app might not refresh list of songs after unplug USB cable.

Updated

4 years ago
Flags: needinfo?(dkuo)

Updated

4 years ago
blocking-b2g: --- → fugu+

Comment 2

4 years ago
I can also reproduce this and looks like music app did not handle well in the picker mode, taking this.
Assignee: nobody → dkuo
Flags: needinfo?(dkuo)
After discussed with our partner, it will not block fugu.
blocking-b2g: fugu+ → ---
This is still reproducible on following build:
Buri V1.3
Gaia      522779225e86b7a4d1bf759036678dc321a1486e                         
Gecko     http://hg.mozilla.org/releases/mozilla-aurora/rev/2287f2839256   
BuildID   20140108004001                                                   
Version   28.0a2                                                           
ro.build.version.incremental=eng.archermind.20131114.105818                
ro.build.date=Thu Nov 14 10:58:33 CST 2013
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

4 years ago
blocking-b2g: --- → 1.3?
QA

Please help with regression window.
blocking-b2g: 1.3? → 1.3+
Keywords: regressionwindow-wanted

Updated

4 years ago
QA Contact: sparsons

Comment 6

4 years ago
This issue reproduces on all 1.2 builds starting at the Buri 1.2 Build ID: 20130621031231

Gaia   e2f19420fa6a26c4287588701efaec09a750dba1
SourceStamp 7ba8c86f1a56
BuildID 20130621031231
Version 24.0a1


I was not able to repro this issue on 1.1.
QA Contact: sparsons

Updated

4 years ago
Keywords: regressionwindow-wanted → regression

Updated

4 years ago
Component: General → Gaia::Music

Comment 7

4 years ago
PM triaged this bug and believes that it should be a blocker.

Updated

4 years ago
Target Milestone: --- → 1.3 C3/1.4 S3(31jan)

Comment 8

4 years ago
Dominic, please provide an update on this fix.
Flags: needinfo?(dkuo)
(Assignee)

Comment 9

4 years ago
I could take this, since Dominic looks like he's pretty busy with other bugs.
(Assignee)

Comment 10

4 years ago
Taking this per discussion with Hema. Sorry if I'm stepping on your toes, Dominic!
Assignee: dkuo → squibblyflabbetydoo

Comment 11

4 years ago
No problem Jim, thanks for taking this cause my plate is kind of full, feel free to ping me if you need any info from me!
Flags: needinfo?(dkuo)
(Assignee)

Comment 12

4 years ago
Ok, I'm pretty sure bug 911108 regressed this. Updating deps. Patch forthcoming momentarily.
Blocks: 911108
(Assignee)

Updated

4 years ago
Summary: [fugu][hamachi]Music app will not re-scan files in microSD if SD card is ever shared using USB. → [fugu][hamachi]Music app will not show files in pick mode if device is shared using USB and then unplugged
(Assignee)

Comment 13

4 years ago
Created attachment 8364825 [details] [review]
Fix it

Ok, this should fix it. No tests because we have no integration test infrastructure for music yet. :(
Attachment #8364825 - Flags: review?(dkuo)

Comment 14

4 years ago
Comment on attachment 8364825 [details] [review]
Fix it

Thanks Jim, the patch looks good to me and it did fixed the issue!
Attachment #8364825 - Flags: review?(dkuo) → review+
(Assignee)

Comment 15

4 years ago
Landed: https://github.com/mozilla-b2g/gaia/commit/79346c6ad8d29c1aa338845f9e56466364c33343
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Uplifted 79346c6ad8d29c1aa338845f9e56466364c33343 to:
v1.3: 4dd113626f8ffd2206e6e9d6adbb08ab0580572a
status-b2g-v1.3: --- → fixed

Updated

4 years ago
Flags: in-moztrap?
status-b2g-v1.3T: --- → fixed
status-b2g-v1.4: --- → fixed
Flags: in-moztrap? → in-moztrap+
You need to log in before you can comment on or make changes to this bug.