Closed Bug 911210 Opened 11 years ago Closed 11 years ago

Do not remove download notification popup on Windows Classic

Categories

(Toolkit :: Downloads API, defect)

26 Branch
x86_64
All
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 588314

People

(Reporter: alice0775, Unassigned)

References

Details

(Keywords: qawanted, regression)

Build Identifier:
http://hg.mozilla.org/mozilla-central/rev/c7459bc8e449
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0 ID:20130830030205

Steps To Reproduce:
1. Download something
   Ex. http://ftp.mozilla.org/pub/mozilla.org/seamonkey/nightly/latest-comm-central-trunk/jsshell-win32.zip
   --- Observe the bottom right(on windows) of the screen.

Actual Results:
Nothing happens

Expected Results:
An alert panel should pop up at the bottom right(on windows) of the screen briefly

Regression window(m-c)
Good:
http://hg.mozilla.org/mozilla-central/rev/764ac2c7cb0a
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0 ID:20130820015126
Bad:
http://hg.mozilla.org/mozilla-central/rev/d8b7195b63c9
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0 ID:20130820015423
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=764ac2c7cb0a&tochange=d8b7195b63c9


Regression window(fx)
Good:
http://hg.mozilla.org/integration/fx-team/rev/b7f636fada9f
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0 ID:20130819140640
Bad:
http://hg.mozilla.org/integration/fx-team/rev/c2b4444ad9fd
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0 ID:20130819144040
Pushlog:
http://hg.mozilla.org/integration/fx-team/pushloghtml?fromchange=b7f636fada9f&tochange=c2b4444ad9fd

Regressed by: Bug 847863
No longer blocks: 847863
Depends on: 588314
As per Bug 588314 Comment 16 and Bug 588314 Comment 17,  this regression should be fixed on Windows Classic visual style at least.
What, if anything, is still affected here as a regression?  If I'm reading bug 588314 correctly, supporting this on additional platforms (mac/linux) is an enhancement so unless this is regressed on other windows OSes there's nothing I can see deserving tracking here.
Keywords: qawanted
The fact that the preference doesn't work is expected in the new Downloads API.

Implementing a system-level notification on operating systems that doesn't provide a taskbar indicator is a possible enhancement discussed in bug 588314. To avoid tracking the same thing in two different bugs, I'll close this one and keep the other one open.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → WONTFIX
(In reply to :Paolo Amadini from comment #3)
> The fact that the preference doesn't work is expected in the new Downloads
> API.
> 
> Implementing a system-level notification on operating systems that doesn't
> provide a taskbar indicator is a possible enhancement discussed in bug
> 588314. To avoid tracking the same thing in two different bugs, I'll close
> this one and keep the other one open.

This is not same of the bug.
Bug 588314 Comment 17 said 
> Per comment 0, this bug is only for platforms that 
> "provide a standard mechanism for applications to draw 
> the user's attention".

Because Windows7 classic does not have any "standard mechanism"
bug 588314 is not include Windows7 classic.
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
Summary: browser.download.manager.showAlertOnComplete = true (default) does not work → Do not remove download notification popup on Windows Classic
(In reply to Alice0775 White from comment #4)
> Because Windows7 classic does not have any "standard mechanism"
> bug 588314 is not include Windows7 classic.

Sounds good, I've morphed bug 588314 to take this into account.
Status: REOPENED → RESOLVED
Closed: 11 years ago11 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.