Closed Bug 911241 Opened 8 years ago Closed 8 years ago

Can't close tabs when open 2 instances of Firefox simultaneously

Categories

(Firefox :: Tabbed Browser, defect)

26 Branch
x86_64
Windows 8
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox24 --- unaffected
firefox25 - ---
firefox26 - ---

People

(Reporter: davispuh, Unassigned)

References

Details

(Keywords: regression)

User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0 (Beta/Release)
Build ID: 20130830030205

Steps to reproduce:

Firefox is closed (to be precise Nightly) then I quickly click on shortcut opening to 2 instances/windows.
Then in both windows I open some tabs and try to close them in each of windows.


Actual results:

In one of windows tab's can't be closed. Close tab (x) button just doesn't work. While in other window it will close them.


Expected results:

It should be possible to close tabs in both windows.
When I click close button, an error in the error console:
Error: uncaught exception: 2147942487

Regression window(m-c)
Good:
http://hg.mozilla.org/mozilla-central/rev/af4e3ce8c487
Mozilla/5.0 (Windows NT 5.1; rv:25.0) Gecko/20130718 Firefox/25.0 ID:20130718115206
Bad:
http://hg.mozilla.org/mozilla-central/rev/0d0263a58f06
Mozilla/5.0 (Windows NT 5.1; rv:25.0) Gecko/20130718 Firefox/25.0 ID:20130718173618
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=af4e3ce8c487&tochange=0d0263a58f06

Regression window(m-i)
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/353d7b3d98ef
Mozilla/5.0 (Windows NT 5.1; rv:25.0) Gecko/20130717 Firefox/25.0 ID:20130717190148
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/b94553178dfe
Mozilla/5.0 (Windows NT 5.1; rv:25.0) Gecko/20130717 Firefox/25.0 ID:20130717202448
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=353d7b3d98ef&tochange=b94553178dfe

Regressed by:
b94553178dfe	Jared Wein — Bug 887515 - Replace multiple tab closing prompt with a menuitem to restore multiple tabs. r=ttaubert
Blocks: 887515
Status: UNCONFIRMED → NEW
Component: Untriaged → Tabbed Browser
Ever confirmed: true
Keywords: regression
This is pre-release only, so we won't track for release. That being said, we'd take an uplift to support our devs and testers.
Assignee: nobody → jaws
I can't reproduce this.

I opened multiple windows (using Ctrl+N) and then duplicated tabs. I am able to close the tabs in each window.

I also tried creating a shortcut to my local build and double-clicking on it really fast to try to get two windows to appear but I kept getting the "Firefox is already running" dialog.
(In reply to Jared Wein [:jaws] from comment #3)
> I can't reproduce this.
> 
> I opened multiple windows (using Ctrl+N) and then duplicated tabs. I am able
> to close the tabs in each window.
> 
> I also tried creating a shortcut to my local build and double-clicking on it
> really fast to try to get two windows to appear but I kept getting the
> "Firefox is already running" dialog.

You misunderstand "shortcut".
In this case, shortcut should URL short cut.

STR
1. Make Firefox default browser
2. Create two web page shortcuts
3. Close all instance of Firefox
3. Double click these shortcuts quickly
Flags: needinfo?(jaws)
this bug caused by bug 900910
> Since bug 881049 and bug 898308 SessionStore.init run only after
> gBrowserInit._delayedStartup finished for the first window in the session.
> 
> SessionStore.onLoad for new windows after the first one relay on observing
> "domwindowopened"
> 
> If more windows are opened before SessionStore.init runs, all windows except
> the first one will be unknown to SessionStore.

the reason you can't closed tabs is that gBrowser.removeTab call
> SessionStore.setNumberOfTabsClosedLast(window, 1);

that fails if the window isn't initialized in SessionStore
Depends on: 900910
It doesn't matter if that shortcut is to URL or to Firefox.exe itself. I actually used FF which is pinned to taskbar.

And it affects only 1 window, if you open new windows after Firefox launched, you'll be able to close tabs for all those. Thus you can't reproduce it with Ctrl+N but only when new 2nd instance of FF is launched quickly after 1st. And I haven't seen "Firefox is already running" for ages. I think there have been some improvements as that message was quite annoying. I'm now on 26.0a1 (2013-09-06)
Flags: needinfo?(jaws)
Unassigning as it looks like fixing bug 900910 will fix this bug.
Assignee: jaws → nobody
Nice, seems it's fixed :) Works for me with Nightly 27.0a1 (2013-10-18)
WFM per comment 8
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.