mach fails to incrementally rebuild specified directories (config/makefiles/mozconfig.mk:33:0:2:1:Fix above errors before continuing.)

RESOLVED FIXED in mozilla26

Status

defect
RESOLVED FIXED
6 years ago
Last year

People

(Reporter: markh, Assigned: glandium)

Tracking

Trunk
mozilla26
All
Windows 7
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

Reporter

Description

6 years ago
After a full rebuild, the following commands fail:
./mach build browser/base
./mach build toolkit/components/thumbnails
(and I assume many other directories fail in the same way - these are just the 2 I tried)

The output in both cases is:

 0:00.17 C:/mozilla-build/msys/bin/sh.exe -c c:/mozilla-build/python/python.exe o:/src/mozilla-git/central/build/pymake/make.py -C browser/base -j8 -s
 0:00.58 evaluation from o:\src\mozilla-git\central\config\makefiles\mozconfig.mk:33:0:2:1:Fix above errors before continuing.
2

I'm guessing this was caused by bug 903118.  Note that a normal "./mach build" works fine.
Reporter

Comment 1

6 years ago
FTR, locally backing out https://hg.mozilla.org/mozilla-central/rev/6fe5a446b775 (from bug 903118) solves the problem for me.
Assignee

Comment 2

6 years ago
Kind of ironically, a year ago, I was removing $(topsrcdir)/.mozconfig.mk (which was, then, only used in client.mk). This kind of brings it back, but in the objdir.
Attachment #798719 - Flags: review?(ted)
Assignee

Updated

6 years ago
Assignee: nobody → mh+mozilla
Status: NEW → ASSIGNED
Assignee

Comment 3

6 years ago
Also note this essentially backs out bug 903118.
Assignee

Updated

6 years ago
Hardware: x86_64 → All
Comment on attachment 798719 [details] [diff] [review]
Create a .mozconfig.mk in the objdir when starting a build, and include it from config.mk

Review of attachment 798719 [details] [diff] [review]:
-----------------------------------------------------------------

I feel I should review this since I reviewed the bug that regressed this.

I hate backing out another bug and replacing the solution like this. But, if it's necessary, then oh well.

Any chance you can submit a patch against the backed out source instead of lumping everything together?
Attachment #798719 - Flags: review?(ted) → review?(gps)
Assignee

Comment 5

6 years ago
Same patch, against a backout of bug 903118, and with an additional filter to only output export lines to .mozconfig.mk
Attachment #799176 - Flags: review?(gps)
Assignee

Updated

6 years ago
Attachment #798719 - Attachment is obsolete: true
Attachment #798719 - Flags: review?(gps)
Summary: mach fails to incrementally rebuild specified directories → mach fails to incrementally rebuild specified directories (config/makefiles/mozconfig.mk:33:0:2:1:Fix above errors before continuing.)
Comment on attachment 799176 [details] [diff] [review]
Create a .mozconfig.mk in the objdir when starting a build, and include it from config.mk

Review of attachment 799176 [details] [diff] [review]:
-----------------------------------------------------------------

::: client.mk
@@ +203,5 @@
> +# For now, only output "export" lines from mozconfig2client-mk output.
> +$(OBJDIR)/.mozconfig.mk: $(FOUND_MOZCONFIG) $(call mkdir_deps,$(OBJDIR))
> +	( $(foreach line,$(filter export||%,$(MOZCONFIG_OUT_LINES)), echo "$(subst ||, ,$(line))";) ) > $@
> +
> +# Include that makefile so that it is created. This should not actually change

Clever.
Attachment #799176 - Flags: review?(gps) → review+
Assignee

Updated

6 years ago
Duplicate of this bug: 903118
https://hg.mozilla.org/mozilla-central/rev/34ca46861c28
https://hg.mozilla.org/mozilla-central/rev/0016284ded20
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla26
Blocks: 913246
Assignee

Updated

5 years ago
Depends on: 990848

Updated

Last year
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.