Closed Bug 911696 Opened 6 years ago Closed 6 years ago

[Dialer] [Flatfish] hide dialer app in homescreen if no telephony support

Categories

(Firefox OS Graveyard :: Gaia::Dialer, defect)

Other
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:koi+, b2g-v1.2 fixed)

RESOLVED FIXED
blocking-b2g koi+
Tracking Status
b2g-v1.2 --- fixed

People

(Reporter: gasolin, Assigned: gasolin)

References

Details

Attachments

(2 files)

some device did not have telephony support.

We'd hide dialer app in homescreen and settings/permission list if no telephony support
blocking-b2g: --- → koi?
@crdlc do you know how FTU hide itself from homescreen? maybe we can do something like that for dialer when telephony is not available.
Flags: needinfo?(crdlc)
blocking-b2g: koi? → koi+
Some apps are not rendered for the homescreen depending on role

https://github.com/mozilla-b2g/gaia/blob/master/apps/homescreen/js/grid.js#L15

Good question, why does not homescreen paint FTU app?

I didn't that but looking an answer -> https://github.com/mozilla-b2g/gaia/blob/master/apps/homescreen/js/grid.js#L1004

Entry points without icons defined in the manifest are hidden :)
blocking-b2g: koi+ → koi?
Flags: needinfo?(crdlc)
Sorry, did I change the koi flag? how?
blocking-b2g: koi? → koi+
Depends on: 911689
@crdlc, per discussion with george, do you mean add a blacklist in config options(customization) to filter out dialer?
Flags: needinfo?(crdlc)
I gonna add to Vivien here because he was following the last change about roles. I agree that entry points without icons have to be hidden is a hack and I don't like that but I prefer that Vivien'll expose his opinion. With Vivien's opinion, you should continue with this hack or adding a blacklist
Flags: needinfo?(crdlc) → needinfo?(21)
Summary: [Dialer] hide dialer app in homescreen and settings/permission list if no telephony support → [Dialer] [Flatfish] hide dialer app in homescreen and settings/permission list if no telephony support
(In reply to Cristian Rodriguez (:crdlc) from comment #5)
> I gonna add to Vivien here because he was following the last change about
> roles. I agree that entry points without icons have to be hidden is a hack
> and I don't like that but I prefer that Vivien'll expose his opinion. With
> Vivien's opinion, you should continue with this hack or adding a blacklist

Both ways are wrong imo but we need to do something for now so pick what you like  (i personally prefer not showing the icon on the homescreen if the entry point does not have an icon) :)

The longer term plan is to get rid of entry points if possible so that will be resolve but there are probably a few months of work to achieve this.
Flags: needinfo?(21)
I really think so, the simpler the better right now
+10000 to remove entry points

;)
add `app.launch_path.blacklist` settings attribute to filter out entrypoint from homescreen

will add another PR to hide icon in settings/permission list
Attachment #805142 - Flags: review?(crdlc)
Assignee: nobody → gasolin
In settings/app permissions there's no communication apps, so the last PR is sufficient
Summary: [Dialer] [Flatfish] hide dialer app in homescreen and settings/permission list if no telephony support → [Dialer] [Flatfish] hide dialer app in homescreen if no telephony support
Comment on attachment 805142 [details]
pull request redirect to github

Please Vivien review it because I prefer that this kind of decisions will be taken by you. IMHO you have more knowledge about settings... Thanks
Attachment #805142 - Flags: review?(crdlc) → review?(21)
Comment on attachment 805142 [details]
pull request redirect to github

Hey Cristian, even if I don't like the way it is done here there is not any other possibilities right now. The way to solve that is a long term plan that will allow us to get rid of |entry_points| entirely.

So the feature in this patch, even if it is a hack, is fine.
Attachment #805142 - Flags: review?(21) → review?(crdlc)
Please review my comment on Github
Status: NEW → ASSIGNED
I've revised the PR. Please kindly review it again, thanks.
Comment on attachment 805142 [details]
pull request redirect to github

I have just a question in Github, good work as usual!. Although we don't have best approach thought, I don't like to wait for mozSettings in order to paint the grid. But your implementation is totally perfect

Thanks a lot Fred
Attachment #805142 - Flags: review?(crdlc) → review+
merged to gaia-master https://github.com/mozilla-b2g/gaia/commit/2c3dc472094a278da97d43e7cfe0b6d2a075b24c thanks!
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Fred, we had to back this out due to contact app launching breaking. Please add a unit test for this case if possible. Reopening this bug.

Backed out of master: https://github.com/mozilla-b2g/gaia/commit/53f63e4a5e1ca6a650b9b1dce8039c79741b72a7
Backed out of v1.2: https://github.com/mozilla-b2g/gaia/commit/c932c482c6944fa32724ce7af9e5423c4c2bcccd
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Kevin, I found the cause and will add unit test for entrypoints, thanks
Attached file 2nd pull request
the root cause is I miss used 'return' instead of 'continue' in loop, which skip the following entrypoint process (that effect all entrypoint path but not only contacts app)

Sad I can't find a good way to write testcase for it.
Attachment #808477 - Flags: review?(crdlc)
Blocks: flatfish
@crdlc I've updated the source, please kindly review it again, thanks
Comment on attachment 808477 [details]
2nd pull request

Good job! Please address my last two comments in Github and merge it. Thanks a lot
Attachment #808477 - Flags: review?(crdlc) → review+
merged in gaia-master https://github.com/mozilla-b2g/gaia/commit/1c6db3efc258b3afdf3cf25079a6799d06c0adba
uplift v1.2 https://github.com/mozilla-b2g/gaia/commit/54c0b89a1ac81e8f1e40ff76aefe9dbb722a1b3b

Thanks!
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → FIXED
viral, 

per offline discussion, in this bug we use blacklist filter instead of feature detection with mozTelephony API, so we could hide dialer even if some devices comes with only DATA plan but without phone feature.

Is this what you and Bruce concern about?
Flags: needinfo?(vwang)
I think it's ok to use blacklist in this case to hide dialer.
For data access only but without phone feature, it won't need dialer also!

what we worried about is the cases like 'no sim card' (the items in settings), is that proper to use blacklist to filter also?
Flags: needinfo?(vwang)
viral, for 'no sim card' case, we'd hide them via feature detection if mozConnection API is not exist.
see bug 911676
You need to log in before you can comment on or make changes to this bug.