[wasabi] Signal level bar is gray when data connection is set to evdo only

RESOLVED FIXED in Firefox 28, Firefox OS v1.2

Status

Firefox OS
Gaia::System
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: Peipei Cheng (needinfo if you need my action), Assigned: arthurcc)

Tracking

unspecified
1.2 C5(Nov22)
Other
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:koi+, firefox28 fixed, b2g-v1.2 fixed)

Details

(Whiteboard: [FT:system-platform])

Attachments

(2 attachments, 2 obsolete attachments)

Build info:
Gaia:     15bdabeddd1b9356ff296a6550691c1427bf2589
  B-D     2013-08-30 16:14:54
Gecko:   c3e6d00ad8f63ed64ad334b55954da36b49d16d4
BuildID   20130830172300
Version   26.0a1

This bug is tested under China Telecom.

Reproduce steps:
1. Start FxOS
2. Enable "Data Connection" and set "Network Operator"->"Network Type" to "evdo'
   You will see "EV" appears on the signal level bar.
   [issue] Signal level bar shows empty signal.

Updated

4 years ago
Component: Gaia → Gaia::System

Updated

4 years ago
Whiteboard: [FT:RIL]

Comment 1

4 years ago
Can you provide RIL logs? Thank you!
blocking-b2g: koi? → koi+
Flags: needinfo?(pcheng)
Created attachment 809740 [details]
911701.log

The log start from line 2310 in attached log file. I guess this should be similar reason as bug 911691.
Flags: needinfo?(pcheng)
Component: Gaia::System → RIL
Peter,

Any update of this bug?
Flags: needinfo?(pcheng)

Comment 4

4 years ago
Hi Preeti, Peipei is the reporter, I will have Ken to help to find correct owner for your question. 

Hi Ken,

Could you help to assign a developer to check Peipei's log?

Thanks.
Assignee: pcheng → nobody
Flags: needinfo?(pcheng) → needinfo?(kchang)

Comment 5

4 years ago
Hi Preeti,

Were you trying to needinfo Peter(pchang@mozilla.com)? I replied because you needinfo pcheng@mozilla.com. So feel free to change it again or please ask for Ken's help to have developer check the log, thanks.
Flags: needinfo?(kchang) → needinfo?(praghunath)

Comment 6

4 years ago
Ken, can you find someone to check this bug? 
Thanks.
Flags: needinfo?(kchang)

Comment 7

4 years ago
From log, RIL get a null signal information and the type is evdoa first.
I/Gecko   (  575): -*- RILContentHelper: Received message 'RIL:DataInfoChanged': {"clientId":0,"data":{"connected":true,"emergencyCallsOnly":false,"roaming":false,"network":{"longName":null,"shortName":null,"mcc":null,"mnc":null},"cell":{"gsmLocationAreaCode":-1,"gsmCellId":-1},"type":"evdoa","signalStrength":null,"relSignalStrength":null,"state":"registered","apn":"ctnet"}}

Then we get the date signal, but there isn't voice signal in the parcel. 
{"gsmSignalStrength":99,"gsmBitErrorRate":0,"cdmaDBM":-1,"cdmaECIO":-1,"evdoDBM":63,"evdoECIO":55,"evdoSNR":3,"lteSignalStrength":99,"lteRSRP":2147483647,"lteRSRQ":2147483647,"lteRSSNR":2147483647,"lteCQI":2147483647}
I/Gecko   (  201): RIL Worker[0]: Next parcel size unknown, going to sleep.
I/Gecko   (  201): -*- RadioInterface[0]: Received message from worker: {"voice":{"signalStrength":null,"relSignalStrength":null},"data":{"signalStrength":-63,"relSignalStrength":100},"rilMessageType":"signalstrengthchange"}

This seems a modem issue. Since the network with evdoa doesn't support voice and data at the same time, 
the modem only sends the data signal to Gecko.

Edgar, please take this issue. Thanks.
Assignee: nobody → echen
Flags: needinfo?(kchang)

Updated

4 years ago
Attachment #809740 - Attachment mime type: text/x-log → text/plain

Comment 8

4 years ago
===============================
I/Gecko   (  690): -*- RILContentHelper: Received message 'RIL:VoiceInfoChanged': {"clientId":0,"data":{"connected":false,"emergencyCallsOnly":true,"roaming":false,"network":null,"cell":null,"type":null,"signalStrength":null,"relSignalStrength":null, *"state":"searching"* }}
===============================

From the log, after switching to evdo only, the voice service is not registered. I think it is because evdo is a data only service. And those status is reported by modem, we need modem side help to clarify. For now there is nothing we can do in gecko side. Thanks.

Comment 9

4 years ago
Hi Neo,

As I talked to you today, we need UX team's help to define what the signal bar level should act for case like this - EVDO only, no voice call (unable to answer MT call). Unlike Android version of reference phone which have 2 signal bars for both CDMA and EVDO, we would like to know what is current single signal bar FxOS has for? If it's for CDMA, then this will not be a bug; if it's not, then please let us know how it should work and then both dev and QA would know how to test it. 

Android OS behavior for EVDO only mode:
* EV has signal bar level, 1x has no signal bar level.
* When MO call, two bar become only one 1x bar with levels.
* After call is ended, back to 2 bars and only EV's has levels.

FxOS behavior for EVDO only mode:
* Only one bar, EV icon is next to no level signal bar.
* When MO call, EV icon still exists, signal bar has levels.
* After call is ended, EV icon is next to no level signal bar.

Thanks.
Flags: needinfo?(praghunath) → needinfo?(nhsieh)

Comment 10

4 years ago
Hi Enpei, 
As we discussed with Ken, The rule of signal bar will be there:
If the system in EVDO only or in EVDO+1X and runs in EVDO mode, then status bar shows EV. Other situations will shows 1X signal level.

Any questions please let us discuss with Ken again. Thank you.
Flags: needinfo?(nhsieh) → needinfo?(kchang)

Comment 11

4 years ago
(In reply to Neo Hsieh from comment #10)
> Hi Enpei, 
> As we discussed with Ken, The rule of signal bar will be there:
> If the system in EVDO only or in EVDO+1X and runs in EVDO mode, then status
> bar shows EV. Other situations will shows 1X signal level.
Yes, it is right.
Flags: needinfo?(kchang)

Updated

4 years ago
Duplicate of this bug: 911691

Updated

4 years ago
Target Milestone: --- → 1.2 C5(Nov22)

Comment 13

4 years ago
(In reply to Ken Chang from comment #11)
> (In reply to Neo Hsieh from comment #10)
> > Hi Enpei, 
> > As we discussed with Ken, The rule of signal bar will be there:
> > If the system in EVDO only or in EVDO+1X and runs in EVDO mode, then status
> > bar shows EV. Other situations will shows 1X signal level.
> Yes, it is right.
Need Gaia's developer handle this.
Hi Arthur, can you take this bug?
Assignee: echen → nobody
Flags: needinfo?(arthur.chen)
Assignee: nobody → arthur.chen
Flags: needinfo?(arthur.chen)

Comment 14

4 years ago
(In reply to Ken Chang from comment #13)
> (In reply to Ken Chang from comment #11)
> > (In reply to Neo Hsieh from comment #10)
> > > Hi Enpei, 
> > > As we discussed with Ken, The rule of signal bar will be there:
> > > If the system in EVDO only or in EVDO+1X and runs in EVDO mode, then status
> > > bar shows EV. Other situations will shows 1X signal level.
> > Yes, it is right.
> Need Gaia's developer handle this.
> Hi Arthur, can you take this bug?

To be more clear,

let dataInfo = mobileConnection.data;
if (dataInfo &&
    dataInfo.connected &&
    dataInfo.type.startWith("evdo")) {
  // If the data call is established and the type is evdo related technology, ex, evdo0, evdoa ...
  // Use dataInfo.relSignalStrength
} else {
  // Use voiceInfo.relSignalStrength
}

Please let me know if the above logic isn't correct, thanks.
Component: RIL → Gaia::System
Created attachment 823759 [details]
li
Created attachment 823830 [details]
Link to https://github.com/mozilla-b2g/gaia/pull/13158

Alive, could you help review the patch? Thanks.
Attachment #823759 - Attachment is obsolete: true
Attachment #823830 - Flags: review?(alive)
Comment on attachment 823830 [details]
Link to https://github.com/mozilla-b2g/gaia/pull/13158

r=me
Attachment #823830 - Flags: review?(alive) → review+
Thanks!

master: 974eb062c9ca51d770de51bb2e9c9cce1c4ed5f2
Status: NEW → RESOLVED
Last Resolved: 4 years ago
status-b2g-v1.2: --- → affected
status-firefox28: --- → fixed
Resolution: --- → FIXED
Uplifted 974eb062c9ca51d770de51bb2e9c9cce1c4ed5f2 to:
v1.2: a309c93dcef94552cded8a183740ce44d6c1fc7e
status-b2g-v1.2: affected → fixed

Comment 20

4 years ago
Hi Peipei, I've uploaded 2013110110125.zip on box.com, need your help to verify the bug, thank you.

Comment 21

4 years ago
Hi Peipei, I've uploaded 20131104031537.zip on box.com, please help to verify the bug again, thank you.
This problem still exists. Test build:
Gaia: cb981e2f47bc644b4d178d54378c3676c946facf
Gecko: 0770a5a5f305b23896d7805f6b2637e3a2919cee
BuildID 20131104031537
Version 26.0"
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Whiteboard: [FT:RIL] → [FT:system-platform]
Backout per comment 22.
master: 2e3d0feeaa39bbdf7692288860dfeffca7b075c9
v1.2: 509e5a3295ea5cabfaa5988a765e37f48bf2189a
status-b2g-v1.2: fixed → affected
status-firefox28: fixed → affected
Created attachment 827271 [details]
link to https://github.com/mozilla-b2g/gaia/pull/13375

Alive, could you help review it again? The original patch did not solve the problem as when using EVDO network, mozMobileConnection.voice.connected is still true even though users are not able to make voice calls at this time.

So that we need to check |data && data.connected && data.type.startsWith('evdo')| before checking voice connection, or the status bar shows the signal strength of the voice call.
Attachment #823830 - Attachment is obsolete: true
Attachment #827271 - Flags: review?(alive)
Attachment #827271 - Flags: review?(alive) → review+
master: c83556b20bf42aea6e80b1987a91a631e401f1b8
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
status-firefox28: affected → fixed
Resolution: --- → FIXED
v1.2: 2140c987fdde1c99097018f7e93b0bbd43d2125d
status-b2g-v1.2: affected → fixed

Comment 27

4 years ago
Hi Peipei,

New build has been uploaded to box.com, please help on verifying the bug again and also check the RSSI icon between network type switch, see if there is any regression or not, thank you.
You need to log in before you can comment on or make changes to this bug.