Closed Bug 911777 Opened 7 years ago Closed 6 years ago

Intermittent webaudio/test/test_maxChannelCount.html | We can query the maximum number of channels

Categories

(Core :: Web Audio, defect)

x86_64
Linux
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla26
Tracking Status
firefox24 --- unaffected
firefox25 --- fixed
firefox26 --- fixed
firefox-esr24 --- unaffected

People

(Reporter: emorley, Assigned: karlt)

References

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

Ubuntu VM 12.04 x64 mozilla-inbound pgo test mochitest-1 on 2013-09-02 02:48:55 PDT for push 66991961691d

slave: tst-linux64-ec2-001

https://tbpl.mozilla.org/php/getParsedLog.php?id=27290655&tree=Mozilla-Inbound

{
03:14:22     INFO -  154416 INFO TEST-START | /tests/content/media/webaudio/test/test_gainNodeInLoop.html
03:14:22     INFO -  154417 INFO TEST-PASS | /tests/content/media/webaudio/test/test_gainNodeInLoop.html | Correct number of channels for expected buffer 0
03:14:22     INFO -  154418 INFO TEST-PASS | /tests/content/media/webaudio/test/test_gainNodeInLoop.html | Correct number of expected frames
03:14:22     INFO -  154419 INFO TEST-PASS | /tests/content/media/webaudio/test/test_gainNodeInLoop.html | Correct number of input buffer channels
03:14:22     INFO -  154420 INFO TEST-PASS | /tests/content/media/webaudio/test/test_gainNodeInLoop.html | Buffers must have the same length
03:14:22     INFO -  154421 INFO TEST-PASS | /tests/content/media/webaudio/test/test_gainNodeInLoop.html | Found 0 different samples, maxDifference: 0, first bad index: -1 with source offset 0 and destination offset 0
03:14:22     INFO -  154422 INFO TEST-PASS | /tests/content/media/webaudio/test/test_gainNodeInLoop.html | Correct number of channels for expected buffer 0
03:14:22     INFO -  154423 INFO TEST-PASS | /tests/content/media/webaudio/test/test_gainNodeInLoop.html | Correct number of expected frames
03:14:22     INFO -  154424 INFO TEST-PASS | /tests/content/media/webaudio/test/test_gainNodeInLoop.html | Correct number of input buffer channels
03:14:22     INFO -  154425 INFO TEST-PASS | /tests/content/media/webaudio/test/test_gainNodeInLoop.html | Found 0 different samples, maxDifference: 0, first bad index: -1 with source offset 0 and destination offset 0
03:14:22     INFO -  154426 INFO TEST-PASS | /tests/content/media/webaudio/test/test_gainNodeInLoop.html | Correct number of channels for expected buffer 0
03:14:22     INFO -  154427 INFO TEST-PASS | /tests/content/media/webaudio/test/test_gainNodeInLoop.html | Correct number of expected frames
03:14:22     INFO -  154428 INFO TEST-PASS | /tests/content/media/webaudio/test/test_gainNodeInLoop.html | Correct number of input buffer channels
03:14:22     INFO -  154429 INFO TEST-PASS | /tests/content/media/webaudio/test/test_gainNodeInLoop.html | Found 0 different samples, maxDifference: 0, first bad index: -1 with source offset 0 and destination offset 0
03:14:22     INFO -  154430 INFO TEST-END | /tests/content/media/webaudio/test/test_gainNodeInLoop.html | finished in 238ms
03:14:22     INFO -  154431 INFO TEST-START | /tests/content/media/webaudio/test/test_maxChannelCount.html
03:14:23     INFO -  154432 ERROR TEST-UNEXPECTED-FAIL | /tests/content/media/webaudio/test/test_maxChannelCount.html | We can query the maximum number of channels
}
This is looking like it will soon be a top orange - has started very recently (believe today) but occurred 7 times already. Any ideas? :-)
Flags: needinfo?(ehsan)
This is only on Ubuntu, on the EC2 machines. Is there some known configuration change (os upgrade, update, anything?), or a way for me to ssh into such box and diagnose? This can be caused by an alsa misconfiguration, or the non-presence of alsa, or a pulse bug, or maybe gremlins.

This is kind of a direct call into ALSA, was working fine, and suddenly stopped working. If there is no way to skip a test based on the slave, feel free to disable it on Linux.

Maybe I'll add some logging tomorrow to check what the return value is (0 or -1 or something else maybe), I don't have a tree handy.
Assignee: nobody → paul
Flags: needinfo?(ehsan)
(In reply to Paul Adenot (:padenot) from comment #9)
> This is only on Ubuntu, on the EC2 machines. Is there some known
> configuration change (os upgrade, update, anything?), or a way for me to ssh
> into such box and diagnose? 

301 #releng
No failures in 24 runs at
https://tbpl.mozilla.org/?tree=Mozilla-Inbound&rev=85ca556d2bcf

but 11 failures in 20 runs at
https://tbpl.mozilla.org/?tree=Mozilla-Inbound&rev=66991961691d

Most likely candidate is http://hg.mozilla.org/mozilla-central/rev/91197b606141
I wonder whether there's a chance that could be throwing cubeb/pulse/alsa into
a bad state somehow.  I wonder whether we have any other tests with diverge
and converge style graphs.

These are PGO builds, so who knows, but I'll try disabling that on opt Linux desktop.
Blocks: 891254
This is the aurora equivalent of 56d4d6be7442, which actually accidentally disabled a different test to the one in 91197b606141, but exactly which test is disabled is not so important because the number of tests between test_audioBufferSourceNodeNeutered.html and test_maxChannelCount.html is what is most relevant.

https://hg.mozilla.org/releases/mozilla-aurora/rev/f88e5c1c9499

https://tbpl.mozilla.org/?tree=Try&rev=b416190b151d shows that we are hitting CUBEB_STREAM_MAX in cubeb_alsa.

I'll find a good place to GC for now, but we may need to investigate why we are hitting this limit and why it is lower in cubeb_alsa than in cubeb_winmm.
Assignee: paul → karlt
https://tbpl.mozilla.org/php/getParsedLog.php?id=27417582&tree=Try&full=1 demonstrates this being effective.  There are race conditions involved before the stream is released on the MSG thread I assume, but we need only one stream to be released for the test to pass.

We need to work out why we have so many streams, or why there is a limit, but this change enables us to continue to add more tests and run them on opt Linux desktop.
Attachment #800000 - Flags: review?(paul)
Attachment #800000 - Flags: review?(paul) → review+
Whiteboard: [leave open] → [test disabled on Linux][leave open]
Depends on: 915515
https://hg.mozilla.org/mozilla-central/rev/a587982db74f
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla26
You need to log in before you can comment on or make changes to this bug.