Closed Bug 912100 Opened 6 years ago Closed 6 years ago

[B2G] [Buri] [1.2] [Contacts] Blank contact import page is seen after logging in to Facebook

Categories

(Firefox OS Graveyard :: Gaia::Contacts, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: ckreinbring, Unassigned)

References

Details

(Keywords: regression, smoketest)

Attachments

(2 files)

Description:
The import contacts page seen after logging in to Facebook through the Contacts app is blank, preventing the user from importing contacts.

Repro Steps:
1) Update Buri to Build ID: 20130903040204
2) Launch the Contacts app.
3) Tap the gear icon in the upper right corner to access the settings.
4) Tap the Sync Friends switch in the Facebook section.
5) Once the Facebook login page loads, login with valid credentials for an account with friends.
6) Observe the import page once the user has logged in.

Actual:
The import page is blank even though the account has users to add.

Expected:
A list of all available contacts to add is shown.

Environmental Variables
Occurs on Buri 1.2 mozilla RIL
Build ID: 20130903040204
Gecko: http://hg.mozilla.org/mozilla-central/rev/d54e0cce6c17
Gaia: c6d58088f207829d96e7bb33ddacf990e90752fb
Platform Version: 26.0a1

Notes:
Repro frequency: 100%
See attached screenshot and logcat logs
Also seen when attempting to import Gmail and Outlook contacts.
escalation requested, user is blocked from importing contacts.
blocking-b2g: --- → koi?
Keywords: regression
QA Contact: nkot
QA Contact: nkot → laliaga
Tested on Buri Device build 1.2. Was able to populate Facebook friends on 8/30 build. Stopped populating on the 8/31 build.

- Works -
Environmental Variables
Build ID: 20130830040204
Gecko: http://hg.mozilla.org/mozilla-central/rev/c7459bc8e449
Gaia: 407fbfb6a9de68ec4db2f0f3dc6c67463e293f47
Platform Version: 26.0a1
RIL Version: 01.01.00.019.211 

- Broken -
Environmental Variables
Build ID: 20130831040212
Gecko: http://hg.mozilla.org/mozilla-central/rev/4ba8dda1ee31
Gaia: 8b6a2452cbf0c3458581d929d4ebf77a53ea0b07
Platform Version: 26.0a1
RIL Version: 01.01.00.019.211
This was regressed either by bug 887663 or bug 906756.
This was caused by a regression introduced by bug 906756. It has been fixed by backing out that bug. 


https://github.com/mozilla-b2g/gaia/commit/50be16fea5d816442e9f238c22a32ce800bfb5ce
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
blocking-b2g: koi? → ---
Fix verified on Buri 1.2 mozilla RIL.  User can now see their Facebook contacts after logging in through the Contacts app.

Environmental Variables
Build ID: 20130904040205
Gecko: http://hg.mozilla.org/mozilla-central/rev/7ff96bd19c1c
Gaia: b6c5bf1d24230bfed4a8f680e625fa2175001f82
Platform Version: 26.0a1
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.