Closed Bug 912147 Opened 6 years ago Closed 6 years ago

[B2G][Email]User is unable to log in to email account.

Categories

(Firefox OS Graveyard :: Gaia::E-Mail, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:koi+)

VERIFIED FIXED
1.2 FC (16sep)
blocking-b2g koi+

People

(Reporter: ndavidson, Assigned: asuth)

References

Details

(Keywords: regression, smoketest)

Attachments

(2 files)

Description:
User us unable to log in to any email account after filling up correct credentials. Device showing "Setting up account" with spinning indicator.

Repro Steps:
1) Updated Buri to Build ID: 20130903040204
2) From Home screen tap on Email icon
3) On new account screen fill in all the fields with correct information
4) Tap on "Next" button on a top right.
5) Observe what happens

Actual:
Devise showing white screen with message "Setting up account" and spinning indicator.

Expected:
Message "Setting up account" and spinning indicator goes away and user is able to see emails in his account

Environmental Variables
Build ID: 20130903040204
Gecko: http://hg.mozilla.org/mozilla-central/rev/d54e0cce6c17
Gaia: c6d58088f207829d96e7bb33ddacf990e90752fb
Platform Version: 26.0a1
RIL Version: 01.01.00.019.206 

Notes:
Repro frequency: (3/3, 100%)
See attached: screenshot, logcat, 
Optional extra notes: It reproducing with Hotmail/outlook and gmail email accounts
error from a log read this: 09-03 11:09:08.830: E/QCALOG(199): [MessageQ] ProcessNewMessage: [XT-CS] unknown deliver target [OS-Agent]
blocking-b2g: --- → koi?
Duplicate of this bug: 912160
Unagi too:
Gecko  http://hg.mozilla.org/mozilla-central/rev/d54e0cce6c17
Gaia  c6d58088f207829d96e7bb33ddacf990e90752fb
BuildID 20130903040204
Version 26.0a1
QA Contact: mozillamarcia.knous
So, this is a somewhat complicated scenario, but it's been addressed.

The root cause was 2 things:

- Bug 784816 landed changing how mozTCPSocket conveyed desire to use SSL last night.  E-mail not regressing dependend on e-mail having changed its calls.  This was landed last Tuesday (see https://bugzilla.mozilla.org/show_bug.cgi?id=784816#c41)

- Unfortunately, on Friday, the landing of the fix for bug 901926 accidentally backed out various e-mail fixes from earlier in the week, including that required fix.  The regressing landing got backed out by 08ddaceb395a832d51cc24a56fcf55ece68c3141 earlier today and was then properly re-landed.

Please re-test on a gaia build from after 10:44a Pacific Time today.
Status: NEW → RESOLVED
blocking-b2g: koi? → ---
Closed: 6 years ago
Resolution: --- → FIXED
It seems the problem might be more complex than my initial analysis suggested.  I wasted a lot of time fighting apparently bricked Leo and Inari/Ikura devices, but I managed to get my Unagi "happy" again and it's showing the same problems.

Current hypothesis is that it might be a multi-process Gecko issue since Firefox Nightly seems fine, but I'm looking into it.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
I was able to set up Hotmail / Outlook (Active sync) email and send emails to and from it, but still unable to set up Gmail (IMAP) - same issue.

Device Buri v1.2 moz ril
Build ID: 20130904040205
Gecko: http://hg.mozilla.org/mozilla-central/rev/7ff96bd19c1c
Gaia: b6c5bf1d24230bfed4a8f680e625fa2175001f82
Platform Version: 26.0a1
RIL Version: 01.01.00.019.206
Assignee: nobody → bugmail
blocking-b2g: --- → koi+
Target Milestone: --- → 1.2 FC (16sep)
Depends on: 784816
This was caused by 466524 breaking multi-process SSL connection establishment in mozTCPSocket.  Single-process still works.
(In reply to Andrew Sutherland (:asuth) from comment #7)
> This was caused by 466524 breaking multi-process SSL connection
> establishment in mozTCPSocket.  Single-process still works.

clipboard user error.  Rather, but 784816 which implemented startTLS support is at fault.  (Bug 466524 is the bug that if fixed would allow xpcshell unit tests that could have detected the regression.)
Marking as fixed since the backout of bug 784816 should now be present in all nightly builds.
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → FIXED
Verified Fixed: User is able to log into email accounts successfully.

Environmental Variables
Device: Buri v1.2 COM RIL
Build ID: 20131106004004
Gecko: http://hg.mozilla.org/releases/mozilla-b2g26_v1_2/rev/6a831fcb96f4
Gaia: 2140c987fdde1c99097018f7e93b0bbd43d2125d
Platform Version: 26.0
RIL Version: 01.01.00.019.281 
Firmware Version: US_20131015
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.