Show CSS value autocomplete without waiting for first character

RESOLVED FIXED in Firefox 30

Status

()

Firefox
Developer Tools: Inspector
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: jryans, Assigned: Optimizer)

Tracking

Trunk
Firefox 31
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox30 fixed, firefox31 fixed)

Details

Attachments

(1 attachment, 1 obsolete attachment)

Currently, we have great autocompletion of CSS values in the rule view of the inspector.

However, it requires that you first enter a character, and then shows values starting with that character.

We should be able to show *all* possible values for a given property right when you tab to / click an empty value input.  This is a big help if you can't remember the possible values for the property.
(Assignee)

Comment 1

5 years ago
Currently, we anyways truncate the number of entries in the suggestion list to 10. so *all* will as of now only mean the top 10 lexical entries.

This scenario will improve after bug 896969 is experimented upon.
Blocks: 706094
(Assignee)

Comment 2

4 years ago
Created attachment 8391958 [details] [diff] [review]
patch
Attachment #8391958 - Flags: review?(mratcliffe)
(Assignee)

Comment 3

4 years ago
[uggh, early enter press . dunno how]

(In reply to Girish Sharma [:Optimizer] from comment #2)
> Created attachment 8391958 [details] [diff] [review]
> patch

This patch fixes the issue in inplace-editor, so both rule view and markup view work.

To see it in action:
 - add a new attribute in markup view to any node and type "style='color:" now as soon as you press : , you should get a list of suggestions.
 - Add a new "color" property in rule view and hit TAB. In this case, the suggestions list will appear, but nothing will be entered or selected, as rule view is live, while markup view is not. We don't want to have unintentional (by user) styles applied.

try push : https://tbpl.mozilla.org/?tree=Try&rev=8efdba5b21e9
(Assignee)

Updated

4 years ago
Assignee: nobody → scrapmachines
Status: NEW → ASSIGNED
Comment on attachment 8391958 [details] [diff] [review]
patch

Review of attachment 8391958 [details] [diff] [review]:
-----------------------------------------------------------------

I have wanted to fix this for a long time but just didn't get around to it.

Great job, r+.
Attachment #8391958 - Flags: review?(mratcliffe) → review+
(Assignee)

Comment 5

4 years ago
landed in fx-team : https://hg.mozilla.org/integration/fx-team/rev/7621dd6d9091
Whiteboard: [fixed-in-fx-team]
(Assignee)

Comment 6

4 years ago
Created attachment 8396429 [details] [diff] [review]
patch that landed

rebased on latest fx-team
Attachment #8391958 - Attachment is obsolete: true
Attachment #8396429 - Flags: review+
Blocks: 987870
Blocks: 988001
https://hg.mozilla.org/mozilla-central/rev/7621dd6d9091
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 31
(Assignee)

Updated

4 years ago
No longer blocks: 988001
Can we get this on Aurora30 as well?
Flags: needinfo?(scrapmachines)
(Assignee)

Comment 9

4 years ago
Comment on attachment 8396429 [details] [diff] [review]
patch that landed

[Approval Request Comment]
Bug caused by (feature/regressing bug #): none. new feature
User impact if declined: none. This patch is needed as a part of a bigger queue so as to uplift the chunks-by-dir feature of tests to aurora. see https://tbpl.mozilla.org/?tree=Try&rev=bfee331a418c
Testing completed (on m-c, etc.): mc
Risk to taking this patch (and alternatives if risky): none
String or IDL/UUID changes made by this patch: none
Attachment #8396429 - Flags: approval-mozilla-aurora?
Flags: needinfo?(scrapmachines)
Attachment #8396429 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
status-firefox30: --- → fixed
status-firefox31: --- → fixed
Looks like this landed with tests. Please correct if I am mistaken.
Flags: in-testsuite+
You need to log in before you can comment on or make changes to this bug.