Closed Bug 912213 Opened 6 years ago Closed 6 years ago

Webapps getAppActor doesn't work with non-oop apps

Categories

(DevTools :: WebIDE, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
Firefox 26

People

(Reporter: ochameau, Assigned: ochameau)

References

Details

(Whiteboard: [needs-coverage])

Attachments

(1 file)

For some unknown reason Webapps actor `getAppActor` request never respond without dispatching any exception. The message manager code most likely fail silently because frame are not OOP.

This bug disallows connecting a toolbox to any non-oop app like system app, browser or keyboard.
Duplicate of this bug: 913215
Blocks: appmgr_v1
Paul noted in my dupe (bug 913215) that he was able to get:

* Settings
* Built-in Keyboard

to work.

Settings seems to work intermittently for me, but I have never gotten Built-in Keyboard to debug.

Paul, you are still able to debug the keyboard?  I am currently running the 2013-09-09 Keon nightly unmodified, which seems to generally work, but maybe something extra is needed to get it working like you were able to.
Settings is a regular OOP app, so I'm excepting it to work just fine.
With my custom builds using master, I get a consistent behavior where settings do work and keyboard doesn't.
This bug is specific to non-oop apps.

Let's move this discussion back to bug 913215.
Duplicate of this bug: 913215
Non working apps:

- system app
- browser
- keyboard
I can tell, for sure, that this used to work.
It ends up failing because of a conflict between ContentTabActor being defined here:
http://mxr.mozilla.org/mozilla-central/source/b2g/chrome/content/dbg-browser-actors.js#102

and the expected one defined here:
http://mxr.mozilla.org/mozilla-central/source/toolkit/devtools/server/actors/childtab.js#23

I think that would be simplier to choose two distinct names for now,
and may be later merge these two classes, once we start offering actors for browser tabs...
Attachment #802968 - Flags: review?(paul)
Comment on attachment 802968 [details] [diff] [review]
Fix conflicts between two ContentTabActor classes r=paul

_o/ \o/ \o_
Attachment #802968 - Flags: review?(paul) → review+
Whiteboard: [land-in-fx-team]
https://hg.mozilla.org/integration/fx-team/rev/e19b14609e52
Whiteboard: [land-in-fx-team] → [fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/e19b14609e52
Assignee: nobody → poirot.alex
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 26
Whiteboard: [needs-coverage]
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.