Closed Bug 912249 Opened 7 years ago Closed 6 years ago

Schedule JB emulator builds and tests on cedar

Categories

(Release Engineering :: General, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 973063

People

(Reporter: jgriffin, Assigned: kmoir)

References

Details

Attachments

(1 file)

We now have JB emulator builds on b2g-inbound.  We should schedule these builds on cedar, and schedule all the existing tests that we run against ICS emulators on the JB emulators, so we can begin the task of figuring out what works and what doesn't on this new platform.
Assignee: nobody → kmoir
I'm have a patch in progress for this, will work on it some more once I have finished with some mozharness issues in bug 829211
It's easy to enable the builds on cedar.  For enabling the tests I'm a bit unsure.  Are they to be run on a new platform called emulator-jb? That has the same class of slaves as emulator? Like they are defined for emulator ?

BRANCHES['cedar']['platforms']['emulator']['fedora-b2g-emulator']['opt_unittest_suites'] += JSREFTEST
BRANCHES['cedar']['platforms']['emulator']['ubuntu64_vm-b2g-emulator']['opt_unittest_suites'] = ALL_UNITTESTS[:] + JSREFTEST
BRANCHES['cedar']['platforms']['emulator']['ubuntu64_vm-b2g-emulator']['debug_unittest_suites'] = ALL_UNITTESTS[:]
BRANCHES['cedar']['platforms']['emulator']['enable_debug_unittests'] = True
jgriffin if you could help with the question2 in comment 2 it would be appreciated
Flags: needinfo?(jgriffin)
(In reply to Kim Moir [:kmoir] from comment #3)
> jgriffin if you could help with the question2 in comment 2 it would be
> appreciated

Jgriffin is on PTO this week. But yes, you are correct on all three accounts. We want the exact same configuration as we have for emulators (except the platform is now called emulator-jb). Generally on Cedar we just run everything we can, even if it isn't strictly required yet.
Flags: needinfo?(jgriffin)
So with my current patches I get this error message

builder b2g_emulator_jb cedar opt test reftest-1 reuses builddir cedar_fedora-b2g-emulator_test-reftest-1

Catlee: so I have to define a new definition for the slave platform that is the exact same as the plain emulator but differs in name only?  I'm kind of stuck on how to proceed because none of the patches I have tried seem to work.
Flags: needinfo?(catlee)
For reference here is the WIP patch I'm using now + I enable the new platform master/master_config.json.  I'm just not sure of the right approach to enable test for a set of builds on the same hardware slave class that already exists without running into duplicate builder names.
Flags: needinfo?(catlee)
releng is pretty busy right now, and per chat with :jgriffin his team is not presently blocked on this bug. So we will tackle in mid-to-late January.
Duplicate of this bug: 972733
I believe this is a duplicate of bug 973063 which I'm working on (even though that other one is more about the mochitest-1 specifically).
Do additional tests need to be enabled or are the m-1 tests (implemented in bug 973063) running on cedar sufficient at this time?
Well I imagine we'll want to run more on this platform in the future, though there aren't any current plans. We can either turn this into a tracking bug or close and file a new one when that happens.
Okay, I'll close it until we need to run more.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 973063
Component: General Automation → General
You need to log in before you can comment on or make changes to this bug.