[flatfish] Use a "Tablet" UA string

RESOLVED DUPLICATE of bug 906538

Status

RESOLVED DUPLICATE of bug 906538
5 years ago
5 years ago

People

(Reporter: fabrice, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
We use the "Tablet" keyword on Android tablets (see https://mxr.mozilla.org/mozilla-central/source/netwerk/protocol/http/nsHttpHandler.cpp#687) but not on gonk.

This is needed to not get mobile-optimized sites on larger screens.

The implementation should be added around https://mxr.mozilla.org/mozilla-central/source/xpcom/base/nsSystemInfo.cpp#157 (the android implementation is at https://mxr.mozilla.org/mozilla-central/source/mobile/android/base/util/HardwareUtils.java#35) and could probably use device dpi and screen resolution to decide that anything >= 7 inches is a tablet.

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 906538
You need to log in before you can comment on or make changes to this bug.