Header covers content on large font size or narrow browser window

RESOLVED FIXED

Status

()

bugzilla.mozilla.org
Sandstone/Mozilla Skin
P4
minor
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: Kyli, Assigned: glob)

Tracking

Production

Details

Attachments

(3 attachments)

(Reporter)

Description

4 years ago
Created attachment 799447 [details]
Bugzilla when using a "Very Large" default  font

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/29.0.1547.57 Safari/537.36

Steps to reproduce:

Increase browser default font size


Actual results:

The top bar, which is sized automatically by its content, becomes taller, obscuring the content below it, which is offset exactly 80 pixels from the top


Expected results:

The content moves down proportionately because it is offset from the top by ems or pts, which scale with the user's font preference
(Reporter)

Updated

4 years ago
Severity: normal → minor
Priority: -- → P4
(Reporter)

Updated

4 years ago
Version: 4.2 → 4.2.6

Updated

4 years ago
Assignee: ui → nobody
Component: User Interface → User Interface
Product: Bugzilla → bugzilla.mozilla.org
QA Contact: default-qa
Version: 4.2.6 → Production
(Assignee)

Updated

4 years ago
Component: User Interface → Sandstone/Mozilla Skin
Summary: Top bar covers content on large font size → Header covers content on large font size
(Assignee)

Updated

4 years ago
See Also: → bug 908371
Bram. When you have a spare cycle, can you take a look at this and also bug 908371. Seems like it would just be a CSS change needed but your CSS-fu is stronger.

dkl
Flags: needinfo?(bram)
(Assignee)

Updated

4 years ago
Summary: Header covers content on large font size → Header covers content on large font size or narrow browser window
(Assignee)

Updated

4 years ago
Duplicate of this bug: 908371
(Assignee)

Updated

4 years ago
Duplicate of this bug: 913963
(Assignee)

Comment 4

4 years ago
Created attachment 801366 [details] [diff] [review]
912460_1.patch
Assignee: nobody → glob
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #801366 - Flags: review?(dkl)
Flags: needinfo?(bram)
Comment on attachment 801366 [details] [diff] [review]
912460_1.patch

Review of attachment 801366 [details] [diff] [review]:
-----------------------------------------------------------------

Good. r=dkl
Attachment #801366 - Flags: review?(dkl) → review+
(Assignee)

Comment 6

4 years ago
Committing to: bzr+ssh://bjones%40mozilla.com@bzr.mozilla.org/bmo/4.2/
modified skins/contrib/Mozilla/global.css
Committed revision 8996.
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Reporter)

Comment 7

4 years ago
Not fixed... dunno why it was RESOLVED FIXED.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 8

4 years ago
It's marked fixed because it was committed to the source repo.  However deployments to bugzilla.mozilla.org only happen approximately once a week, and this just missed the last one.  Follow glob's blog (http://globau.wordpress.com/) if you'd like to see when things are deployed.
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → FIXED
(Reporter)

Comment 9

4 years ago
Created attachment 803203 [details]
Bugzilla overflow still exists.png

Illustrating problem still exists
Yes, as I say, we are fully aware that this still exists on bugzilla.mozilla.org.  At our next update (probably next Thursday), the fix will be deployed, and the problem will go away.

Comment 11

4 years ago
I am aware of this bug and was planning on working on it tomorrow after our user research session is done. But it sounds like a fix is already deployed.

@glob, does the fix fully resolves the problem? If so, I think I’ll have to skip on this bug. Sorry!
(Assignee)

Comment 12

4 years ago
(In reply to Bram Pitoyo [:bram] from comment #11)
> @glob, does the fix fully resolves the problem? If so, I think I’ll have to
> skip on this bug. Sorry!

yes, i believe we're good here :)
(Assignee)

Comment 13

4 years ago
this fix is now live.
You need to log in before you can comment on or make changes to this bug.