Integrate Marketplace App Developer signup with Exact Target

VERIFIED FIXED in 2013-10-28

Status

Marketplace
Developer Pages
P2
normal
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: Jessilyn Davis (Maternity Leave), Assigned: ashort)

Tracking

Avenir
2013-10-28
x86
Mac OS X
Points:
---

Details

(URL)

(Reporter)

Description

4 years ago
We need to integrate the Marketplace App Developer Program signup form with the Apps & Hacks newsletter in Exact Target.

Form can be found here:
https://marketplace.firefox.com/developers/submit/

If someone checks the opt-in box here they need to be added to Exact Target with the following field info:

APPS_DEV_FLG = Y
APPS_DEV_DATE = date and time of submission
SOURCE URL = URL of where they signed up
EMAIL_ADDRESS_
TOKEN (generated in Basket as passed into Exact Target)
EMAIL_FORMAT* = H

*Need to make sure that legal's okay with passing through H as the default.


If someone does NOT check the checkbox - or if they do - they still need to be added to the marketplace database in case there are future transactional emails that need to be sent**

**Jess needs to work on spec with Wil on how this integration should work for transactional emails - ie if we should make this a different integration with Exact Target or continue to work with our own database and socketlabs (Bug 909519)
(Reporter)

Comment 1

4 years ago
Hey Dan - can you check to see if the checkbox + form on https://marketplace.firefox.com/developers/submit/  is integrated with basket + ET?
Assignee: nobody → dpoirier
(Reporter)

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 809133

Comment 3

4 years ago
If both this bug and bug 809133 are closed, is there another one to address the integration of the Marketplace Developers DB with ET so future emails to that group can be sent with the proper opt-outs?
This wasn't a dupe because it wasn't the same form or list.  Sounds like it should be though so I'll reopen.  Jess: if this is the same thing as the other form we probably just need to do this on the dev side, right?
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
I think this needs to go to Marketplace (not a mozilla.org site).
Assignee: dpoirier → nobody
Component: Newsletters → Consumer Pages
Product: www.mozilla.org → Marketplace
Version: unspecified → Avenir
Component: Consumer Pages → Developer Pages
Allen - this is the same thing you did for bug 809133 except on this page.  Jess says she's getting the proper token and will put it in this bug shortly.  (It's not the same list as the other bug).
Assignee: nobody → ashort
(Reporter)

Comment 7

4 years ago
The ID for the Apps & Hacks newsletter is: app-dev

Fields passed into Exact Target:
APPS_DEV_FLG = Y
APPS_DEV_DATE = date and time of submission
SOURCE URL = URL of where they signed up
EMAIL_ADDRESS_
TOKEN (generated in Basket as passed into Exact Target)


This means that their language is EN and their email format = H by default.
Depends on: 916304

Comment 8

4 years ago
Once signed up in Exact Target, there's presumably a way for the developer to unsubscribe?
Yep.  ET provides a dashboard, and it's in the footer of all the emails
Priority: -- → P3

Comment 10

4 years ago
what's the ETA on this? Not allowing devs to unsubscribe from email is not very Mozilla-like.
(Reporter)

Comment 11

4 years ago
The newsletter checkbox on the form is for a subscription to a newsletter. You can unsubscribe from this newsletter.

If you do NOT check the checkbox, you will be added to a separate mailing list so that you can be contacted if anything transactional in nature occurs to your Marketplace account (ie your app is broken, paid apps are now available, there will be an update on x date that unless you do y thing, your app will not work and will be taken down from the marketplace, receipts from paid applications, etc.).  These kinds of emails that you cannot unsubscribe from will be used very RARELY, and only for app critical information.
(In reply to Jessilyn Davis from comment #11)
> The newsletter checkbox on the form is for a subscription to a newsletter.
> You can unsubscribe from this newsletter.
> 
> If you do NOT check the checkbox, you will be added to a separate mailing

To clarify, it's not actually a separate mailing list and it happens regardless of checking or not checking the box.  It simply falls under the category of, "you have an app in our system, we may contact you from time to time about that app."

But yeah, let's get this bug closed.
Priority: P3 → P2
(Assignee)

Comment 13

4 years ago
https://github.com/mozilla/zamboni/commit/45d36325e
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → FIXED
(Assignee)

Updated

4 years ago
Target Milestone: --- → 2013-10-28
(Reporter)

Comment 14

4 years ago
Thanks Allen! Can you let us know when this is on a dev or staging site to test? 

Please note: this cannot go to prod until we have clearance from Privacy/Legal (Bug 916304)


Rebecca - can you QA?

To test:

Scenario 1:
1) Go to https://marketplace.firefox.com/developers/submit/
2) Check the newsletter box and hit submit
3) Make sure you get the welcome email for Apps & Hacks newsletter (ie you're in Master_Subscribers with APPS_DEV_FLG = Y)
4) Ask Allen/Wil if your info is in their database (for Socketlabs transactional emails)

Scenario 2:
1) Go to https://marketplace.firefox.com/developers/submit/
2) Do NOT check the newsletter box and hit submit
3) Make sure you DO NOT get the welcome email for Apps & Hacks newsletter
4) Double check that you are NOT in Master_Subscribers with APPS_DEV_FLG = Y
5) Ask Allen/Wil if your info is in their database (for Socketlabs transactional emails)
Those scenarios are valid, but each scenario should drop the last step.  We don't store anything in our database around this mailing list.


Jess - regarding the privacy/legal bug, is that actually a blocker here?  This isn't changing any functionality as far as the end user is concerned, right?
(Reporter)

Comment 16

4 years ago
(In reply to Wil Clouser [:clouserw] from comment #15)
> Those scenarios are valid, but each scenario should drop the last step.  We
> don't store anything in our database around this mailing list.

Wil - how would you have these folks's email address to send the Transactional emails if they aren't added to a database somewhere?  Isn't there a way you can pull people who have submitted apps (whether or not they checked the box) - ie the list I got in Bug 909519?


> 
> Jess - regarding the privacy/legal bug, is that actually a blocker here? 
> This isn't changing any functionality as far as the end user is concerned,
> right?

Ah yes, you're right. The main part of the legal/privacy bug is to clear the transactional email infrastructure piece that *might* need to make an amend to the terms & conditions of submitting the app form.

The newsletter checkbox can move forward. Before we send a transactional email to ALL app dev submitters via Socketlabs, that has to be cleared by legal/privacy (Bug 916304)

Please let us know when/where this is ready to test and when it will go live.
(In reply to Jessilyn Davis from comment #16)
> (In reply to Wil Clouser [:clouserw] from comment #15)
> > Those scenarios are valid, but each scenario should drop the last step.  We
> > don't store anything in our database around this mailing list.
> 
> Wil - how would you have these folks's email address to send the
> Transactional emails if they aren't added to a database somewhere?  Isn't
> there a way you can pull people who have submitted apps (whether or not they
> checked the box) - ie the list I got in Bug 909519?

Yes, but I think that is just confusing the issue here.  We need to have emails in our db because that's how people sign in, but that is unrelated to the App Developer mailing list which is what I'm trying to keep this bug focused on.  

> > Jess - regarding the privacy/legal bug, is that actually a blocker here? 
> > This isn't changing any functionality as far as the end user is concerned,
> > right?
> 
> Ah yes, you're right. The main part of the legal/privacy bug is to clear the
> transactional email infrastructure piece that *might* need to make an amend
> to the terms & conditions of submitting the app form.
> 
> The newsletter checkbox can move forward. Before we send a transactional
> email to ALL app dev submitters via Socketlabs, that has to be cleared by
> legal/privacy (Bug 916304)
> 
> Please let us know when/where this is ready to test and when it will go live.

This is already on marketplace-dev.allizom.org and will be going live on Tuesday.
(Reporter)

Comment 18

4 years ago
Rebecca - can you QA on marketplace-dev.allizom.org? It's scheduled to go live on Tuesday.

To test:

Scenario 1:
1) Go to https://marketplace.firefox.com/developers/submit/
2) Check the newsletter box and hit submit
3) Make sure you get the welcome email for Apps & Hacks newsletter (ie you're in Master_Subscribers with APPS_DEV_FLG = Y)

Scenario 2:
1) Go to https://marketplace.firefox.com/developers/submit/
2) Do NOT check the newsletter box and hit submit
3) Make sure you DO NOT get the welcome email for Apps & Hacks newsletter
4) Double check that you are NOT in Master_Subscribers with APPS_DEV_FLG = Y
Flags: needinfo?(rbillings)
Scenario 1: tested on dev, user is in Master Subscribers with APPS_DEV_FLG = Y [webqabrowserid@aol.com], but did not receive the email after 40+ min.

Scenario 2: Test on dev, verified.
Status: RESOLVED → REOPENED
Flags: needinfo?(rbillings)
Resolution: FIXED → ---
If they are in the Master Subscribers list this bug is verified.  Not receiving the email would be something to investigate within Exact Target (or, more likely, it's in the spam folder).

I'm going to re-close this since we're semi-close to pushing and there isn't a marketplace reason to leave this bug open.  Thanks.
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → FIXED
(Reporter)

Comment 21

4 years ago
Thanks Rebecca and Wil!

I went digging in ET and found webqabrowserid@aol.com was sent the welcome at 10/24/2013 1:13 PM. So that part means that the form + basket trigger API is working. It is indeed an ET/deliverabilty issue that the welcome email didn't make it to your inbox, which is a separate issue from this bug.

We're good to push!  Please let us know when this is live so it can be verified.


Thanks all!

Comment 22

4 years ago
dev doesn't send out emails which would explain why Rebecca didn't see the email.
(Reporter)

Comment 23

4 years ago
Just verified that checking the box for email newsletter adds you to the Apps & Hacks newsletter list.

Got the welcome email and everything.

Thanks team!
Status: RESOLVED → VERIFIED
(Reporter)

Comment 24

4 years ago
Hey team, I just found a new snag - the App Submission page is localized, as is the email opt-in form, but the newsletter itself is only available in EN. 

This means that a user can check the box for the newsletter in their language, but will get an EN welcome email and an EN newsletter (ie - https://marketplace.firefox.com/developers/submit/?lang=es). This is not a good user experience and can cause some deliverability problems as people may mark our EN newsletters as spam (since they cannot read the newsletter, nor navigate to the unsubscribe link & process).


3 possible solutions:


1) Hide the newsletter checkbox for all non-EN pages (https://marketplace.firefox.com/developers/submit/)


2) Show the newsletter checkbox for everyone and add "(English only)" to the newsletter checkbox.


3) Pass through the lang=x parameter in the URL to the "LANGUAGE_ISO2" field in Exact Target and we'll segment the newsletter send based on this information to the locales we support with the newsletter.



At the very least, Options 1 or 2 should be implemented as soon as possible to avoid bad user experience and deliverability problems. We will want to implement #3 in the near future.


Please let me know if you have any questions. Thanks!
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
Please don't reopen old verified bugs.  I filed bug 951446 for this.  Please note we're within the no-push window so this will land in early January.
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
(Reporter)

Comment 26

4 years ago
10-4  thanks!
You need to log in before you can comment on or make changes to this bug.