Closed Bug 912782 Opened 7 years ago Closed 5 years ago

Folder pane and address book empty on start-up. Component returned failure code: 0xc1f30001 [nsIMsgFolder.compareSortKeys] ... folderPane.js Line 2426

Categories

(Thunderbird :: Mail Window Front End, defect, major)

17 Branch
x86
macOS
defect
Not set
major

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: clang777, Unassigned)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_6_8) AppleWebKit/534.59.8 (KHTML, like Gecko) Version/5.1.9 Safari/534.59.8

Steps to reproduce:

When I launch the app, my folder pane is completely empty and my address book doesn't show any data either.  But, I do see the data there in the folders.  I'm using MAC OS vs. 10.6.8 and tried uninstalling the most current version of TB (Vs 17.0.8) and even went back to several versions older (17.0.6), but still having the same symptoms.  See the attached image - right side - to see what the screen looks like after the app launches...completely blank.

OS - MAC 10.6.8
TB Vs - 17.0.8


Actual results:

The error console shows the following error:

Error: NS_ERROR_NOT_INITIALIZED: Component returned failure code: 0xc1f30001 [nsIMsgFolder.compareSortKeys]
Source File: chrome://messenger/content/folderPane.js  Line 2426


Expected results:

I have 14 total folders (email boxes).  ALL are IMAP.  11 are Google mail, and 3 are hosted on a different server.  There are thousands of messages, more than 5,000.  I'm still able to use TB on my laptop and my Android phone is still getting messages like normal, so I'm sure it's not an issue where I have too many boxes or emails yet to overwhelm TB.
Have you ever run a newer TB version (18+) on this profile and then reverted back to TB 17.0.x ?

Do you know when this started to happen? Did it just suddenly appear and is broken since then?

Also try TB safe mode: Help->restart with addons disabled.
This just started over the weekend.  Been using TB for years without any problems.  Perhaps it was force closed during a process it was doing at the time I needed to re-boot the system (sometimes I have to force close apps to reboot when film editing).  I did try safe mode several times, and it didn't work...clicked "addons disabled" and "continue" and it didn't do anything in safe mode.  Didn't know there was a vs. 18+ available for MAC.
Versions 18+ (we are now at 23) were not publicly released as stable for any platform. But it is easy to download betas or nightly builds so I asked if you maybe tried those. It is OK if not.

So OK, if this started suddenly without even updating TB then it really looks like a file corruption.

What folder view are you using (View->Folders-> ?). Try the "All" view.
(In reply to :aceman from comment #3)
> Versions 18+ (we are now at 23) were not publicly released as stable for any
> platform. But it is easy to download betas or nightly builds so I asked if
> you maybe tried those. It is OK if not.
> 
> So OK, if this started suddenly without even updating TB then it really
> looks like a file corruption.
> 
> What folder view are you using (View->Folders-> ?). Try the "All" view.

Chris?
Severity: normal → major
Flags: needinfo?(clang777)
Chris seems to be gone, so we no longer have the "testcase".
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Flags: needinfo?(clang777)
Resolution: --- → INCOMPLETE
Summary: Folder pane and address book empty on start-up → Folder pane and address book empty on start-up. Component returned failure code: 0xc1f30001 [nsIMsgFolder.compareSortKeys] ... folderPane.js Line 2426
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: INCOMPLETE → ---
Thunderbird 21.3.0 on Mac OS 10.9.5:

After starting, the left (folder) pane is blank, the right pane shows a menu (Email, Accounts, Advanced Features)
Settings in View › Layout: Classic View, Folder Pane

I can not read my mails -> SHOW STOPPER. This started around v21.x.

Actions that did not help: Starting with Add-Ons disabled, deleting localstore.rdf.

This is printed on the console, when starting from terminal / command line:

System JS : WARNING resource://gre/components/steelApplication.js:783 - mutating the [[Prototype]] of an object will cause your code to run very slowly; instead create the object with the correct initial [[Prototype]] value using Object.create
mimeVerify.jsm: module initialized
JavaScript strict warning: file:///Users/[REMOVED]/Library/Thunderbird/Profiles/[REMOVED].default/extensions/qfb-pivot@mozillamessaging.com/components/harness.js, line 168: assignment to undeclared variable name
JavaScript strict warning: resource://qfb-pivot-at-mozillamessaging-dot-com-api-utils-lib/securable-module.js, line 133: reference to undefined property options.principal
JavaScript strict warning: jar:file:///Users/[REMOVED]/Library/Thunderbird/Profiles/[REMOVED].default/extensions/%7B8845e3b3-e8fb-40e2-95e9-ec40294818c4%7D.xpi!/components/wzQuicktext.js, line 712: assignment to undeclared variable data
System JS : ERROR (null):0 - bad script XDR magic number
JavaScript strict warning: chrome://v_identity/content/bindings/vI_debugBox.xml, line 58: reference to undefined property this._content.inputField.scrollHeight
JavaScript error: chrome://spf/content/sve.js, line 168: GetFirstSelectedMessage is not defined
JavaScript strict warning: chrome://messenger/content/tabmail.xml, line 352: reference to undefined property aTabType.panelId
JavaScript error: chrome://messenger/content/folderPane.js, line 2647: NS_ERROR_FAILURE: Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIMsgFolder.compareSortKeys]
JavaScript strict warning: chrome://glodaquilla/content/glodaquillaOverlay.js, line 420: assignment to undeclared variable installedTbVersion
JavaScript strict warning: chrome://suncult/content/calculations.js, line 472: assignment to undeclared variable yearday
JavaScript strict warning: chrome://nightly/content/messenger.js, line 29: setting a property that has only a getter
JavaScript strict warning: resource://gre/modules/addons/XPIProvider.jsm -> jar:file:///Users/[REMOVED]/Library/Thunderbird/Profiles/[REMOVED].default/extensions/%7Bd10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d%7D.xpi!/bootstrap.js, line 74: "BUFFER_SIZE" is read-only
JavaScript error: chrome://compactheader/content/compactHeaderOverlay.js, line 367: coheOnLoadMsgHeaderPane is not defined
JavaScript error: chrome://messenger/content/specialTabs.js, line 1220: NS_ERROR_FAILURE: Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIObserverService.removeObserver]

So, this might be important:

JavaScript error: chrome://messenger/content/folderPane.js, line 2647: NS_ERROR_FAILURE: Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIMsgFolder.compareSortKeys]

It does somehow not show up on the Tools › Error Console list…

Maybe related (I'm not sure, it's top secret):
https://bugzilla.mozilla.org/show_bug.cgi?id=1045958

Thanks for fixing!
Flags: needinfo?(Pidgeot18)
Typo: The bug is in Thunderbird 31.2.0; it started around v31.x.

BTW: It’s fixed in EarlyBird (Thunderbird 35.0a2).
It looks to me you have a ton of addons installed. Can you try disabling those temporarily (Help->restart with addons disabled) and see if the problem still exists in TB31 ?
(In reply to Oliver Prygotzki from comment #6)
> Maybe related (I'm not sure, it's top secret):
> https://bugzilla.mozilla.org/show_bug.cgi?id=1045958

This looks like maybe bug 976183, which, on closer inspection and correlation with bug 1045958, appears to be caused in root by OS X 10.9 having a serious bug in its collation services.

I haven't followed that bug closely, so I don't know for certain what steps to reproduce would be needed. CC'ing someone else from that bug who appears to have been involved in narrowing it down to get you more information.
Flags: needinfo?(Pidgeot18) → needinfo?(arai_a)
As far as I know, the bug depends on OS X's System Locale (not Thunderbird's locale).
Oliver, would you tell me the locale you are using?
so I can test the locale :)
Flags: needinfo?(arai_a) → needinfo?(oliver-bugzilla)
My boss started having this issue since Thunderbird updated to the ja-JP 31.x branch. I can't confirm at the moment which version of Mac OS X she's using, but I believe it's the latest 10.7, running with Japanese language and region settings.

Tooru Fujisawa may be correct about the system locale playing a role in this bug's appearance. My own workstation is running with Belgium regional settings with English language and I've had no issue whatsoever with the en-US Thunderbird client.

On her machine, starting up Thunderbird showed the home screen and empty folders pane. I've tried fixing this by closing Thunderbird and deleting folderTree.json and session.json as recommended on the Mozilla help site, though this only occasionally solves the issue, which returns every time Thunderbird is closed and reopened. In fact, just closing and re-opening Thunderbird over and over sometimes gets the folder pane to display correctly until Thunderbird is next closed.

When the folder pane fails to display, the content of folderTree.json is simply:
{}

Based on Oliver Prygotzki's comment, I changed the update channel to "aurora" to get Thunderbird to update to the current EarlyBird build (36.0a2). The problem appears resolved on this version, as the folder pane was immediately displayed correctly on first launch post-update, and remains correctly displayed after several Thunderbird close/re-open and a system reboot.

I changed the update channel back to "release" afterwards, I assume that from this point on Thunderbird will resume updating from the release channel when the 36.x branch or above reaches that channel...

So far so good, if the problem resurfaces on this version, I'll post more details.
Luc: yes that is bug 1045958.
Flags: needinfo?(oliver-bugzilla)
So this is gone in version 31.4.0?
(Let's get this out of the black hole of Untriaged component)

Thank you all for your previous comments and offers to test.
Previously cited bug numbers are all closed.
So I'm going to close this WFM. (even though original reporter is gone)
If anyone sees differently when using version 38 pleaes reply with details.
And oliver, what is your locale?
Status: REOPENED → RESOLVED
Closed: 5 years ago5 years ago
Component: Untriaged → Mail Window Front End
Resolution: --- → WORKSFORME
I'm having this problem with the lastest Thunderbird (45.8.0) on MacOs X (El capitan). I tried completely uninstalling thunderbird and re-installing, and nothing. I have no plugins and add-ons installed.

In my console I have the following message: 

Horodatage : 2017-03-13 16:54:33
Erreur : NS_ERROR_NOT_INITIALIZED: Component returned failure code: 0xc1f30001 (NS_ERROR_NOT_INITIALIZED) [nsIMsgFolder.compareSortKeys]
Fichier source : chrome://messenger/content/folderPane.js
Ligne : 2773

My system information:


  Paramètres de base de l'application

    Nom: Thunderbird
    Version: 45.8.0
    Agent utilisateur: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:45.0) Gecko/20100101 Thunderbird/45.8.0
    Dossier de profil: Afficher dans le Finder
    Identifiant de compilation de l'application: 20170305125302
    Plugins activés: about:plugins
    Configuration de compilation: about:buildconfig
    Utilisation mémoire: about:memory

  Comptes courrier et groupes
    account1:
      INCOMING: account1, , (imap) imap.<compnay_address>:993, SSL, passwordCleartext
      OUTGOING: , smtp.<compnay_address>:587, alwaysSTARTTLS, passwordCleartext, true

    account2:
      INCOMING: account2, , (none) Local Folders, plain, passwordCleartext

  Rapports de plantage

  Extensions
    Lightning, 4.7.8, false, {e2fda1a4-762b-4020-b5ad-a41df1933103}

  Préférences modifiées importantes

    Nom: Valeur

      browser.cache.disk.capacity: 358400
      browser.cache.disk.filesystem_reported: 1
      browser.cache.disk.smart_size_cached_value: 358400
      browser.cache.disk.smart_size.first_run: false
      browser.cache.disk.smart_size.use_old_max: false
      extensions.lastAppVersion: 45.8.0
      gfx.blacklist.direct2d: 3
      gfx.crash-guard.glcontext.appVersion: 45.8.0
      gfx.crash-guard.glcontext.deviceID: 0x0166
      gfx.crash-guard.status.glcontext: 2
      mail.openMessageBehavior.version: 1
      mail.spotlight.enable: true
      mail.spotlight.firstRunDone: true
      mail.spotlight.global_reindex_time: 1489067878
      mailnews.database.global.datastore.id: e7a936cb-c2aa-5f42-bf95-66fb054721f
      network.cookie.prefsMigrated: true
      places.database.lastMaintenance: 1489071385
      places.history.expiration.transient_current_max_pages: 104858
      plugin.importedState: true

  Accélération graphique

      ID du vendeur: 0x8086
      ID du périphérique: 0x0166
      Rendu WebGL: Intel Inc. -- Intel HD Graphics 4000 OpenGL Engine -- 2.1 INTEL-10.14.73
      Fenêtres avec accélération graphique: 0

      AzureCanvasBackend: skia
      AzureSkiaAccelerated: 1
      AzureFallbackCanvasBackend: none
      AzureContentBackend: quartz

  JavaScript

  Ramasse-miettes incrémentiel: 1

  Accessibilité

    Activée: 0
    Empêcher l'accessibilité: 0

  Versions des bibliothèques

      Version minimale attendue
      Version utilisée

      NSPR
      4.12
      4.12

      NSS
      3.21.3 Basic ECC
      3.21.3 Basic ECC

      NSS Util
      3.21.3
      3.21.3

      NSS SSL
      3.21.3 Basic ECC
      3.21.3 Basic ECC

      NSS S/MIME
      3.21.3 Basic ECC
      3.21.3 Basic ECC
You need to log in before you can comment on or make changes to this bug.