Closed Bug 912869 Opened 6 years ago Closed 5 years ago

Rename key names, "Apps" and "FastFwd" to "MediaApps" and "MediaFastForward"

Categories

(Core :: DOM: Events, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla37

People

(Reporter: masayuki, Assigned: masayuki)

References

Details

Attachments

(1 file)

No description provided.
Summary: Rename key name "FastFwd" with "MediaFastForward" → Rename key names, "FastFwd" and "MediaTrackSkip" to "MediaFastForward" and "MediaSkip"
Summary: Rename key names, "FastFwd" and "MediaTrackSkip" to "MediaFastForward" and "MediaSkip" → Rename key names, "Apps", "FastFwd" and "MediaTrackSkip" to "MediaApps", "MediaFastForward" and "MediaSkip"
Summary: Rename key names, "Apps", "FastFwd" and "MediaTrackSkip" to "MediaApps", "MediaFastForward" and "MediaSkip" → Rename key names, "Apps" and "FastFwd" to "MediaApps" and "MediaFastForward"
Status: NEW → ASSIGNED
Attached patch PatchSplinter Review
This patch also comments out "MediaApps" since the Android's KEYCODE_APP_SWITCH is really different function from current D3E's definition.
Duplicate of this bug: 912865
Comment on attachment 8434798 [details] [diff] [review]
Patch

D3E defines the meaning of "MediaApps" more specific at renaming it from "Apps". So, we should not map it to KEYCODE_APP_SWITCH of Android anymore since the keycode means switching between launched applications.
Attachment #8434798 - Flags: review?(bugs)
https://hg.mozilla.org/mozilla-central/rev/20b4fe3c7dcc
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla37
You need to log in before you can comment on or make changes to this bug.