[stage][prod] Advanced Search: No results returned for 24.0b

VERIFIED FIXED in 65

Status

P1
normal
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: mbrandt, Assigned: adrian)

Tracking

unspecified
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [fromAutomation][stage][prod][qa+], URL)

(Reporter)

Description

5 years ago
The Firefox 24.0b product returns no results in the advanced search. Is this a malformed version number?

https://crash-stats.mozilla.com/query/?product=Firefox&version=Firefox%3A24.0b&range_value=1&range_unit=weeks&date=09%2F05%2F2013+17%3A00%3A00&query_search=signature&query_type=contains&query=&reason=&release_channels=&build_id=&process_type=any&hang_type=any

Steps to reproduce:
1. goto https://crash-stats.allizom.org/query/
2. Filter on Firefox > 24.0b

Expected:
results are returned

Actual:
No results are returned
(Reporter)

Updated

5 years ago
Whiteboard: [fromAutomation][stage][prod][regression] → [fromAutomation][stage][prod]

Comment 1

5 years ago
This is not malformed, it's the "rapid beta" version, and should return results from all Firefox 24 betas.
(Reporter)

Comment 2

5 years ago
It's worth noting that top crasher and top changer reports work as expected

Updated

5 years ago
Assignee: nobody → adrian
(Assignee)

Comment 3

5 years ago
I'm sorry, I had no time to work on that this week. Could someone maybe take a look? 

I would think this either comes from a database problem (but unlikely as tcbs works fine) or from socorro/external/postgresql/util.py (that file has a bit of logic regarding versions and release channels, it's probably the source as it has some explicit rules about Betas).
(Reporter)

Comment 4

5 years ago
Removing assignee as Adrian is PTO'd
Assignee: adrian → nobody
Flags: needinfo?(chris.lonnen)
Target Milestone: --- → 59

Comment 5

5 years ago
I have no cycles to spare.
Flags: needinfo?(chris.lonnen)

Comment 6

5 years ago
Brandon might have some time. I think he's wrapped up his Q goals.
Flags: needinfo?(bsavage)
I should be able to take a look at this, still working on my Q3 goals but they won't take all my cycles.
Assignee: nobody → bsavage
Flags: needinfo?(bsavage)

Updated

5 years ago
Duplicate of this bug: 915209
Target Milestone: 59 → 60
(Reporter)

Comment 9

5 years ago
WebappRuntime 24.0b also appears to be effected by this bug - https://crash-stats.mozilla.com/topcrasher/products/WebappRuntime/versions/24.0b?days=7
(In reply to Matt Brandt [:mbrandt] from comment #9)
> WebappRuntime 24.0b also appears to be effected by this bug -
> https://crash-stats.mozilla.com/topcrasher/products/WebappRuntime/versions/
> 24.0b?days=7

It looks like rapid beta support is not enabled for anything but B2G and Firefox, according to the Products table in prod.
(Reporter)

Comment 11

5 years ago
(In reply to Robert Helmer [:rhelmer] from comment #10)
> It looks like rapid beta support is not enabled for anything but B2G and
> Firefox, according to the Products table in prod.

Should I file a separate bug for topcrashers for WebappRuntime and Firefox?
- https://crash-stats.mozilla.com/topcrasher/products/Firefox/versions/24.0b?days=7
- https://crash-stats.mozilla.com/topcrasher/products/WebappRuntime/versions/24.0b?days=7
(In reply to Matt Brandt [:mbrandt] from comment #11)
> (In reply to Robert Helmer [:rhelmer] from comment #10)
> > It looks like rapid beta support is not enabled for anything but B2G and
> > Firefox, according to the Products table in prod.
> 
> Should I file a separate bug for topcrashers for WebappRuntime and Firefox?
> -
> https://crash-stats.mozilla.com/topcrasher/products/Firefox/versions/24.
> 0b?days=7
> -
> https://crash-stats.mozilla.com/topcrasher/products/WebappRuntime/versions/
> 24.0b?days=7

According to the Products table, rapid beta support is not enabled for WebappRuntime (only Firefox and B2G) so I wouldn't expect version numbers ending in "b" to work (these signify "rapid betas").
So, the issue with the topcrasher being broken was related to the fact that this rapid beta expired yesterday.

Still investigating the search issue.

Comment 14

5 years ago
(In reply to Robert Helmer [:rhelmer] from comment #10)
> (In reply to Matt Brandt [:mbrandt] from comment #9)
> > WebappRuntime 24.0b also appears to be effected by this bug -
> > https://crash-stats.mozilla.com/topcrasher/products/WebappRuntime/versions/
> > 24.0b?days=7
> 
> It looks like rapid beta support is not enabled for anything but B2G and
> Firefox, according to the Products table in prod.

WebappRuntime closely shadows Firefox (as it's part of Firefox installs), even on Socorro.

Comment 15

5 years ago
(In reply to Brandon Savage [:brandon] from comment #13)
> So, the issue with the topcrasher being broken was related to the fact that
> this rapid beta expired yesterday.

Umm, then there is a major bug there, rapid beta should not expire before some time after the next one was released, it should be active for at least 8-9 weeks.
Assignee: bsavage → adrian
(Reporter)

Updated

5 years ago
Duplicate of this bug: 917025
(Assignee)

Comment 17

5 years ago
From IRC:
> <adrian> KaiRo: when you search for Firefox:24.0b, 
> what do you expect to see? Results for all "24.0b*" Firefox versions? 
> <KaiRo> adrian: results for everything that is counted in the matviews for 24.0b as well - 
> I *think* the rule is all versions with a major version of 24.0 on the Beta channel that 
> were release within 2 weeks of the crash
> <KaiRo> adrian: I probably would have been OK with just "all 24.0 / Beta versions" but 
> selenamarie implemented the time constraint on the matviews as well, which I probably
> designed back in the days, and now it would be bad to be inconsistent
> <KaiRo> adrian: I'm not 100% sure which way the two week constraint is implemented in
> matviews but we should look that up and see how near to that we can get in search
(Assignee)

Updated

5 years ago
Target Milestone: 60 → 61
(Assignee)

Updated

5 years ago
Priority: -- → P1
(Assignee)

Updated

5 years ago
Target Milestone: 61 → 62
(Assignee)

Updated

5 years ago
Target Milestone: 62 → 63

Comment 19

5 years ago
Commit pushed to master at https://github.com/mozilla/socorro

https://github.com/mozilla/socorro/commit/df0827f93b78c419c8826c9e5c07ca21720a3bce
Fixes bug 913126, fixes bug 917025 - Made rapid betas work in all search-based systems. r=brandonsavage

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Reporter)

Updated

5 years ago
Whiteboard: [fromAutomation][stage][prod] → [fromAutomation][stage][prod][qa+]
(Assignee)

Updated

5 years ago
Duplicate of this bug: 925099

Comment 21

5 years ago
Commit pushed to master at https://github.com/mozilla/socorro

https://github.com/mozilla/socorro/commit/5aa396b314105a824b4b03d30b6963ec75ef8ac7
Revert df0827f93b78c419c8826c9e5c07ca21720a3bce

Reverts "Fixes bug 913126, fixes bug 917025 - Made rapid betas work in all search-based systems. r=brandonsavage"

Comment 22

5 years ago
reverted because it broke master
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Updated

5 years ago
Target Milestone: 63 → 64

Comment 23

5 years ago
Commit pushed to master at https://github.com/mozilla/socorro

https://github.com/mozilla/socorro/commit/f7937eda37350bbd677cb0a272aa79c9c28bb475
Fixes bug 913126, fixes bug 917025 - Made rapid betas work in all search-based systems. r=brandonsavage

Updated

5 years ago
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
Stage is busted. What I'm seeing is piles of the "WITH infos AS" queries backing up -- 500+ connections/queries open after 10-15 minutes.

Some analysis is needed on whether those queries are the right ones, and why they're running so often and why they are so slow.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 25

5 years ago
Commit pushed to master at https://github.com/mozilla/socorro

https://github.com/mozilla/socorro/commit/e4936ea38ecf70a07fdef379f99cb84ea0507ae9
Revert "Fixes bug 913126, fixes bug 917025 - Made rapid betas work in all search-based systems. r=brandonsavage"

This reverts commit df0827f93b78c419c8826c9e5c07ca21720a3bce.

Reopened bug 913126

Updated

5 years ago
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Updated

5 years ago
Blocks: 868344, 917025
(Assignee)

Updated

5 years ago
Target Milestone: 64 → 65
(Assignee)

Updated

5 years ago
Target Milestone: 65 → 66

Comment 27

5 years ago
Commits pushed to master at https://github.com/mozilla/socorro

https://github.com/mozilla/socorro/commit/5a8bcb4efa465dc67c83cddb0eb71c296ca9b2e4
Fixes bug 913126 - Rapid betas in search-based systems. r=selenamarie

https://github.com/mozilla/socorro/commit/8ee58ec7870b1aff7a121c0ab41fedf636e90de2
Merge pull request #1613 from AdrianGaudebert/913126-rapid-betas-in-search-3

Fixes bug 913126 - Rapid betas in search-based systems

Updated

5 years ago
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
(Assignee)

Updated

5 years ago
Target Milestone: 66 → 65
(Reporter)

Comment 28

5 years ago
Reopening for clarification - 

Querying on WebappRuntime returns zero results, is this expected? Comment 15 leads me to think there should be results.

https://crash-stats.allizom.org/query/?product=WebappRuntime&version=WebappRuntime%3A26.0b&range_value=3&range_unit=weeks&date=11%2F05%2F2013+18%3A00%3A00&query_search=signature&query_type=contains&query=&reason=&release_channels=&build_id=&process_type=any&hang_type=any
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 29

5 years ago
WebappRuntime barely has users on desktop and so often has no crashes to find, it's very much possible that an empty result is correct for this query at this time.
(Reporter)

Comment 30

5 years ago
(In reply to Robert Kaiser (:kairo@mozilla.com) from comment #29)
> WebappRuntime barely has users on desktop and so often has no crashes to
> find, it's very much possible that an empty result is correct for this query
> at this time.

Queries for Firefox xx.0b work great .. I wanted to ensure that queries work for products other than Firefox before marking this bug verified. Is there a simple way to do this?
(Assignee)

Comment 31

5 years ago
I actually think this is a good thing: you can verify that when the betas have no result, the rapid beta shortcut has none too! :)

(And more seriously, I don't know how to add data for WebAppRuntime, but I think it is not necessary to overdo testing here. That thing has a bunch of unit tests, and there should be no reason for it to work for Firefox and not for another product. )

Comment 32

5 years ago
I agree, if stuff works for Firefox, let's be OK with that and don't block for something like WebappRuntime where we have very little data, often none at all (this will hopefully change at some point, but not even this year for sure).
(Reporter)

Comment 33

5 years ago
Sounds great .. bumping to resolved/fixed per comment 31 and comment 32
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
(Reporter)

Comment 34

5 years ago
QA verified on stage - results for Firefox xx.0b look correct as well as the absence of results for WebappRuntime xx.0b
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.