[MP] Defect - Snapped displays cropped multi-column tiles after touch scroll

RESOLVED FIXED in Firefox 26

Status

defect
P2
normal
RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: rsilveira, Assigned: rsilveira)

Tracking

Trunk
Firefox 26
x86_64
Windows 8.1
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [preview] feature=defect c=browser_views u=metro_firefox_user p=2)

Attachments

(2 attachments)

Posted image snappedHoriz.png
If I touch scroll the start page then snap, the top sites are displayed full size and with multiple columns. They change back once you try to touch scroll which is crazy.
Hi Rodrigo, is this a new defect or is it related to an open story under development?
Flags: needinfo?(rsilveira)
It's a new defect.
Flags: needinfo?(rsilveira)
Is this a regression from part 1 of bug 891056?
No, I'm seeing this without your changes.
I have been seeing this too. If you just try to select one of the tiles it snaps to the correct single column arrangement. Doing that shouldn't trigger rearrangeItems, so I think somehow the layout isn't being updated. Accessing offsetWidth on the grid's bound node or something like that might trigger it?
Summary: Snapped displays cropped multi-column tiles after touch scroll → Defect - Snapped displays cropped multi-column tiles after touch scroll
Whiteboard: [preview-triage] feature=defect c=tbd u=tbd p=0
Posted patch 913229.patchSplinter Review
This was a tricky one. The layout was wrong because the media queries were not being triggered. They were not being triggered because the #browsers deck had a much larger width then the viewport (like ~ 1000px). The deck's width was large because #horizontal-scroller had a large width attribute.

The precise input broadcaster starts as precise, so our panning scrollers are initialized and a width/height set according to start page. When we touch, they're hidden by transitioning the opacity to 0 - they're still part of the layout though.

Fixed by unsetting width/height when hiding scrollbars.
Assignee: nobody → rsilveira
Status: NEW → ASSIGNED
Attachment #800999 - Flags: review?(mbrubeck)
Whiteboard: [preview-triage] feature=defect c=tbd u=tbd p=0 → [preview-triage] feature=defect c=tbd u=tbd p=2
Priority: -- → P2
QA Contact: jbecerra
Summary: Defect - Snapped displays cropped multi-column tiles after touch scroll → [MP] Defect - Snapped displays cropped multi-column tiles after touch scroll
Whiteboard: [preview-triage] feature=defect c=tbd u=tbd p=2 → [preview] feature=defect c=tbd u=tbd p=2
Blocks: metrov1it15
No longer blocks: metrov1it14
Attachment #800999 - Flags: review?(mbrubeck) → review+
https://hg.mozilla.org/mozilla-central/rev/92b84e142f38
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 26

Updated

6 years ago
Whiteboard: [preview] feature=defect c=tbd u=tbd p=2 → [preview] feature=defect c=browser_views u=metro_firefox_user p=2

Updated

6 years ago
Blocks: 831894
Went through the following "Defect" for iteration #15 without any issues. Used the following build:

http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2013-09-30-03-02-05-mozilla-central/

- Reproduced the original issue described from comment #0 with an older version of Nightly
- Ensured that the original issue described from comment #0 worked without any issues
- Ensured that sliding Firefox Metro into snapped view from filled view worked without any issues (both left and right sides of the screen)
- Ensured that all the other menu's appeared correctly when in snapped view (Top Sites, Bookmarks, Recent History)
- Loaded a lot of "Top Sites" and "Recent History" and ensured that columns are properly aligned once in snapped view
- Ensured that the columns are correctly returned when sliding Firefox Metro snapped view into filled view
OS: Windows 8 Metro → Windows 8.1
You need to log in before you can comment on or make changes to this bug.