The bookmark added notification toast doesn't disappear from the screen

VERIFIED FIXED in Firefox 25

Status

()

Firefox for Android
General
VERIFIED FIXED
4 years ago
a year ago

People

(Reporter: TeoVermesan, Assigned: wesj)

Tracking

({regression})

24 Branch
Firefox 27
ARM
Android
regression
Points:
---

Firefox Tracking Flags

(firefox24+ wontfix, firefox25+ verified, firefox26 verified, firefox27 verified, fennec25+)

Details

(Reporter)

Description

4 years ago
Build: Firefox for Android 24.0b8 (2013-09-05)
Device: LG Slider
OS: Android 2.3.4

Steps to Reproduce:
1. Go to google.com
2. Tap Menu -> Bookmark

Expected:
- A toast notification appears "Bookmark added" and after a few seconds it disappears

Actual:
- The toast notification doesn't disspear from the screen 
Please se attached video:http://www.youtube.com/watch?v=v5aQZl03fQ0

Note: 
-latest Nightly is not affected
Is it possible to get a regression window for the fix?
Keywords: regressionwindow-wanted
(Reporter)

Comment 2

4 years ago
Regression window-wanted:
not affected build: 24 beta 6
affected build: 24 beta 8
-pushlog:
http://hg.mozilla.org/releases/mozilla-beta/pushloghtml?fromchange=a1b8988d564a&tochange=1ad379ebe463

I've tryed with the nightly builds and couldn't find any affected ones ( for example 27/08 build when Bug 885717 was fixed, 05/09 build when Bug 899560 was fixed, or 14/06 build when Bug 872388 was integrated
Can you confirm if simply Android 2.3 or other small screen devices are affected? I don't see the significance of ARMv6 here at all.

From that range it looks like bug 899560 is the cause for a regression here.
tracking-fennec: --- → ?
tracking-firefox24: --- → ?
Keywords: regressionwindow-wanted → regression

Updated

4 years ago
Blocks: 899560
(Reporter)

Comment 4

4 years ago
I cannot reproduce it on Samsung Galaxy R (Android 2.3), Alcatel one touch(Android 2.3.6)  and we don't have other small screen devices.
(In reply to Teodora Vermesan (:TeoVermesan) from comment #0)
> Please se attached video:http://www.youtube.com/watch?v=v5aQZl03fQ0
> 
> Note: 
> -latest Nightly is not affected

Can you open the video up for public viewing?
I am tracking this as this is a recent regression.

:mfinkle, Aaron and I discussed this and given this may not happen on a lot of devices I am not recommending backout of the patch in https://bugzilla.mozilla.org/show_bug.cgi?id=899560 for our last beta going to build today.

Let us know if there is any other action needed here for Fx24, else given the timeline's likely a wontfix for that version.
Flags: needinfo?(mark.finkle)

Updated

4 years ago
status-firefox24: --- → affected
status-firefox25: --- → affected
tracking-firefox24: ? → +
tracking-firefox25: --- → +
(In reply to bhavana bajaj [:bajaj] from comment #6)
> I am tracking this as this is a recent regression.
> 
> :mfinkle, Aaron and I discussed this and given this may not happen on a lot
> of devices I am not recommending backout of the patch in
> https://bugzilla.mozilla.org/show_bug.cgi?id=899560 for our last beta going
> to build today.
> 
> Let us know if there is any other action needed here for Fx24, else given
> the timeline's likely a wontfix for that version.

This sounds fine to me.
Flags: needinfo?(mark.finkle)
(Assignee)

Comment 8

4 years ago
I can reproduce this on a wildfire s for beta (not for nightly).
Issue is reproducible on Firefox Mobile 24 beta 10 on the Samsung Galaxy R (Android 2.3.4 - ARMv7)
Summary: [ARMv6] The bookmark added notification toast doesn't disspear from the screen → The bookmark added notification toast doesn't disappear from the screen
Assignee: nobody → wjohnston
tracking-fennec: ? → 25+
(Assignee)

Comment 10

4 years ago
This is fixed with the alternative patch https://bugzilla.mozilla.org/attachment.cgi?id=792441. I remember seeing this somewhere else as well. I think we just killed animations on GB there?

Lucas, do you know why the PropertyAnimator has trouble with these alpha animations on some devices?
Flags: needinfo?(lucasr.at.mozilla)
(In reply to Wesley Johnston (:wesj) from comment #10)
> This is fixed with the alternative patch
> https://bugzilla.mozilla.org/attachment.cgi?id=792441. I remember seeing
> this somewhere else as well. I think we just killed animations on GB there?
> 
> Lucas, do you know why the PropertyAnimator has trouble with these alpha
> animations on some devices?

OnPreDrawObserver seems busted on pre-HC devices. I have a fix for this on bug 910191.
Assignee: wjohnston → lucasr.at.mozilla
Flags: needinfo?(lucasr.at.mozilla)
Pushed: https://hg.mozilla.org/integration/fx-team/rev/a0cad0d1d7fc
https://hg.mozilla.org/mozilla-central/rev/a0cad0d1d7fc
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 27
https://hg.mozilla.org/releases/mozilla-aurora/rev/51a7fba55698
status-firefox24: affected → wontfix
status-firefox26: --- → fixed
status-firefox27: --- → fixed
Nominate for approval when ready.
Flags: needinfo?(lucasr.at.mozilla)
(In reply to Alex Keybl [:akeybl] from comment #15)
> Nominate for approval when ready.

Interestingly, Beta does not have the code with the issue I fixed. Can this bug actually be reproduced in Beta?
Flags: needinfo?(lucasr.at.mozilla)
Keywords: qawanted

Comment 17

4 years ago
I was able to reproduce it with yesterday's beta build 25 Beta 2 build 1 on LG Slider. 
Steps to Reproduce:
1. Go to google.com (or any other page)
2. Tap Menu -> Bookmark
Keywords: qawanted
(In reply to Ioana Chiorean from comment #17)
> I was able to reproduce it with yesterday's beta build 25 Beta 2 build 1 on
> LG Slider. 
> Steps to Reproduce:
> 1. Go to google.com (or any other page)
> 2. Tap Menu -> Bookmark

That makes me wonder if my patch actually fixes the bug. Can you reproduce it in Nightly and/or Aurora?

Updated

4 years ago
Flags: needinfo?(ioana.chiorean)

Comment 19

4 years ago
Works fine on Aurora (the toast disappears after a few seconds.) Can't check on Nightly due to Bug 920558. After it gets fixed will try on Nightly too.
Flags: needinfo?(ioana.chiorean)
(In reply to Ioana Chiorean from comment #19)
> Works fine on Aurora (the toast disappears after a few seconds.) Can't check
> on Nightly due to Bug 920558. After it gets fixed will try on Nightly too.

Bug 920558 is now fixed. Could you try to reproduce this bug in Nightly?
Flags: needinfo?(ioana.chiorean)

Comment 21

4 years ago
Fennec 27.0a1 (09/30) using LG Slider 
Works fine on Nightly build too (the toast disappears after a few seconds.)
status-firefox26: fixed → verified
status-firefox27: fixed → verified
Flags: needinfo?(ioana.chiorean)

Updated

4 years ago
Status: RESOLVED → VERIFIED
Is 25 still affected here? Or was this fixed on Aurora before the merge?
Still an issue on Firefox Mobile 25 beta 4 on the LG Slider (Android 2.3)
Lucas, uplift to 25?
Flags: needinfo?(lucasr.at.mozilla)

Comment 25

4 years ago
Please uplift.

SuMo thread today with 3 Gingerbread users affected: https://support.mozilla.org/questions/973954

Any workarounds we can post in the thread?
(In reply to Aaron Train [:aaronmt] from comment #24)
> Lucas, uplift to 25?

From email, "Beta (Fx25) does not have the code that was causing the bug in Aurora and Nightly in the first place. I guess we'll need a Fx25-specific patch for bug 913402 as the issue seem to be different there."

Not sure what the chances are of getting a fix in today though, and I don't think we'd consider a fix for next week.

Updated

4 years ago
Flags: needinfo?(lucasr.at.mozilla)
(Assignee)

Comment 27

4 years ago
build here: http://people.mozilla.com/~wjohnston/toast.apk

Margaret, can you test it?
Flags: needinfo?(margaret.leibovic)

Comment 28

4 years ago
(In reply to Wesley Johnston (:wesj) from comment #27)
> build here: http://people.mozilla.com/~wjohnston/toast.apk
> 
> Margaret, can you test it?

Works for me on my Nexus S (2.3.6)
Flags: needinfo?(margaret.leibovic)
Assigning to Wes as he's working on a fix for Fx25.
Assignee: lucasr.at.mozilla → wjohnston
Does bug 924902 mean we can untrack this bug for FF25?
(In reply to Alex Keybl [:akeybl] from comment #30)
> Does bug 924902 mean we can untrack this bug for FF25?

The steps to reproduce and symptoms seem to be slightly different. I'd probably keep it tracking 25, just in case.
(Assignee)

Comment 32

4 years ago
I can't reproduce this on any devices I have. Aaron, can you test?
Flags: needinfo?(aaron.train)
I've never been able to, over to Teodora whom filed this
Flags: needinfo?(aaron.train)

Updated

4 years ago
Flags: needinfo?(teodora.vermesan)

Comment 34

4 years ago
Verified as FIXED on latest beta tinderbox build: http://ftp.mozilla.org/pub/mozilla.org/mobile/tinderbox-builds/mozilla-beta-android/1382146610/ , on Samsung Galaxy R (Android 2.3.4).

On Firefox 25 Beta 8 the issue is still reproducing.
Flags: needinfo?(teodora.vermesan)

Updated

4 years ago
status-firefox25: affected → fixed

Comment 35

4 years ago
Verified as fixed on Samsung Galaxy R(Android 2.3.4), on Firefox RC 25 build 3.
status-firefox25: fixed → verified
You need to log in before you can comment on or make changes to this bug.