Remove support for 'moz-webgl' context requests

RESOLVED FIXED in mozilla29

Status

()

Core
Canvas: WebGL
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: jgilbert, Assigned: emk)

Tracking

(Blocks: 2 bugs, {dev-doc-complete, site-compat})

unspecified
mozilla29
dev-doc-complete, site-compat
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 3 obsolete attachments)

(Reporter)

Description

4 years ago
We still maintain support for retrieving a webgl context from a canvas via 'moz-webgl'. We should deprecate and then remove this.
Assignee: nobody → dglastonbury
(Assignee)

Updated

4 years ago
Blocks: 775235
Created attachment 805984 [details] [diff] [review]
Remove support for obsolete 'moz-webgl' name for creation of WebGL contexts.
Attachment #805984 - Attachment is obsolete: true
Created attachment 806004 [details] [diff] [review]
fix-913597.patch
Attachment #806004 - Flags: review?(jgilbert)
Attachment #806004 - Flags: review?(bjacob)
(Reporter)

Comment 3

4 years ago
Comment on attachment 806004 [details] [diff] [review]
fix-913597.patch

Review of attachment 806004 [details] [diff] [review]:
-----------------------------------------------------------------

Awesome, thanks. bjacob can review if he wants, but it really only needs one of us.
Attachment #806004 - Flags: review?(jgilbert)
Attachment #806004 - Flags: review?(bjacob)
Attachment #806004 - Flags: review+
Nope, that's fine :-)
Keywords: checkin-needed
https://hg.mozilla.org/integration/mozilla-inbound/rev/505e8f8480d2
Flags: in-testsuite+
Keywords: checkin-needed
Backed out in https://hg.mozilla.org/integration/mozilla-inbound/rev/ae31c55333b3 - from the looks of it, we must only support experimental-webgl, and not webgl, on Android, but the test was running there, so https://tbpl.mozilla.org/php/getParsedLog.php?id=28010372&tree=Mozilla-Inbound
Oh, and b2g, which supports neither, https://tbpl.mozilla.org/php/getParsedLog.php?id=28013847&tree=Mozilla-Inbound
(Reporter)

Comment 8

4 years ago
Yep, this is true.
Restrict the test to just 'moz-webgl' and 'experimental-webgl', since we already have a test that checks 'webgl'.
(Reporter)

Comment 9

4 years ago
Actually, probably just test that if 'experimental-webgl' succeeds, then 'moz-webgl' fails.
I'm not actively working on this.
Assignee: dglastonbury → nobody
(Assignee)

Comment 11

4 years ago
Created attachment 8362520 [details] [diff] [review]
fix-913597.patch

Unbitrotted and removed the test for the unprefixed context name.
Assignee: nobody → VYV03354
Attachment #806004 - Attachment is obsolete: true
Status: NEW → ASSIGNED
Attachment #8362520 - Flags: review?(jgilbert)
(Reporter)

Updated

4 years ago
Attachment #8362520 - Flags: review?(jgilbert) → review+
(Assignee)

Comment 12

4 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/07e5bf2cb7c8
Keywords: dev-doc-needed
Still failing. Backed out.
https://hg.mozilla.org/integration/mozilla-inbound/rev/5cf670407fac

https://tbpl.mozilla.org/php/getParsedLog.php?id=33402846&tree=Mozilla-Inbound
And regular B2G.
https://tbpl.mozilla.org/php/getParsedLog.php?id=33405111&tree=Mozilla-Inbound
(Assignee)

Comment 15

4 years ago
Is WebGL totally unavailable on B2G?
WebGL is totally _available_ on B2G and even used in the Gallery application :-)
(Assignee)

Comment 17

4 years ago
Then there should be a test preventing it from regression.
Blocks: 909903
(Reporter)

Comment 18

4 years ago
(In reply to Benoit Jacob [:bjacob] from comment #16)
> WebGL is totally _available_ on B2G and even used in the Gallery application
> :-)

Yeah, but we have awful coverage on try. I don't remember if we successfully run any webgl on B2G at the moment.
(Assignee)

Comment 19

4 years ago
According to bug 909903, WebGL context creation was possible until bug 900201 was fixed.
(Assignee)

Comment 20

4 years ago
The workaround written in bug 900201 comment #19 did not work anymore.
https://tbpl.mozilla.org/?tree=Try&rev=7c9f1b59daca
We will have to disable the test on B2G atm.
(Assignee)

Comment 21

4 years ago
Created attachment 8365627 [details] [diff] [review]
fix-913597.patch

Added SpecialPowers.pushPrevEnv to force-enable WebGL on B2G desktop build, and B2G check for exemption. (force-enable had no effect on B2G emulator.)

Try run: https://tbpl.mozilla.org/?tree=Try&rev=06babe90c8bc
Attachment #8362520 - Attachment is obsolete: true
Attachment #8365627 - Flags: review?(jgilbert)
(Reporter)

Updated

4 years ago
Attachment #8365627 - Flags: review?(jgilbert) → review+
(Assignee)

Comment 22

4 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/e9c39aa248f3
https://hg.mozilla.org/mozilla-central/rev/e9c39aa248f3
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla29
https://developer.mozilla.org/en-US/Firefox/Releases/29/Site_Compatibility
Keywords: dev-doc-needed → dev-doc-complete, site-compat
You need to log in before you can comment on or make changes to this bug.