Closed Bug 913614 Opened 6 years ago Closed 6 years ago

For lines and rectangles, skip the work when the input is invalid

Categories

(Core :: Graphics, defect)

25 Branch
x86
macOS
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla26
Tracking Status
firefox25 --- fixed
firefox26 --- fixed
firefox-esr17 --- fixed
firefox-esr24 --- fixed

People

(Reporter: milan, Assigned: milan)

References

Details

(Whiteboard: [qa-])

Attachments

(1 file)

Do a quick exit when the rectangle/line input is invalid.
No Try link, no problem.
https://hg.mozilla.org/integration/mozilla-inbound/rev/03dbb211fd6b
Assignee: nobody → milan
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/03dbb211fd6b
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla26
Comment on attachment 800923 [details] [diff] [review]
Avoid work for input values that would not give us a useful result anyway. r=jmuizelaar

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
n/a
User impact if declined:
Some scenarios are wasting time.
Testing completed (on m-c, etc.):
Yes.
Risk to taking this patch (and alternatives if risky): 
Low.
String or IDL/UUID changes made by this patch:
None.
Attachment #800923 - Flags: approval-mozilla-aurora?
Attachment #800923 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
This depends on bug 903526 which doesn't have approval to land (nor was it ever requested?). Backed out.
https://hg.mozilla.org/releases/mozilla-aurora/rev/97e0d6a03696

Also, I assume that bug 905219 also needs uplifting if bug 903526 is?
Indeed.  Just requested uplift of bug 903526.  I will tag this as checkin-needed once the other one is taken care of.
Assuming no verification needed here. Please add the verifyme keyword and remove the [qa-] whiteboard tag to request verification.
Whiteboard: [qa-]
You need to log in before you can comment on or make changes to this bug.