Print preview shows only the 1st page of frame

RESOLVED DUPLICATE of bug 130589

Status

()

Core
Print Preview
--
major
RESOLVED DUPLICATE of bug 130589
5 years ago
3 months ago

People

(Reporter: Andy Kohn, Unassigned)

Tracking

28 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:23.0) Gecko/20100101 Firefox/23.0 (Beta/Release)
Build ID: 20130814063812

Steps to reproduce:

Systems: Win 7 64-bit and Win XP Prof with FF 23.0.1.

Here is a german sample website: http://www.deutscher-hockey-bund.de/VVI-web/default.asp?lokal=DHB
1. Click above "Sport" >
2. left "Ergebnisdienst Feld" >
3. right "1. BL Herren" >
4. right "Gesamter Spielplan"
5. In the frame, mark down anything and
6. now enable/activate the print preview.


Actual results:

Result = only the first page shown.
Test in "safe mode" no change on both Systems.
View the current frame in a new tab does not work.


Expected results:

Does anyone have a solution?
Unless, please correct.
(Reporter)

Updated

5 years ago
Severity: normal → major
Priority: -- → P1

Updated

5 years ago
Severity: major → normal
Priority: P1 → --

Updated

5 years ago
Component: Untriaged → Print Preview
Product: Firefox → Core
Summary: Print preview shows only the 1st page → Print preview shows only the 1st page of frame
(Reporter)

Comment 1

5 years ago
This error also exists in these versions:

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) /20130911 Firefox/24.0b10
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:25.0) /20130913 Firefox/25.0a2
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:26.0) /20130913 Firefox/26.0a1
(Reporter)

Comment 2

5 years ago
With Version 24.0 the error persists
(Reporter)

Comment 3

4 years ago
With Version 28.0 the error persists
(Reporter)

Updated

4 years ago
Version: 23 Branch → 28 Branch
(Reporter)

Updated

4 years ago
Severity: normal → major

Comment 5

4 years ago
This issue is due to use of frame-sets in the webpage.
To print the entire content of the page , right-click in the content section of the page and select "This Frame > Print This Frame"

Comment 6

4 years ago
Created attachment 8399505 [details]
frame.zip

TestCase: 

1.open frame.html from frames folder in Firefox browser
2.go to Print Preview of the page 

Result = only the first page shown.

Comment 7

4 years ago
I got the same error. When used print option only half of the page displays this might because the website has a scroll bar.

Comment 8

4 years ago
I also got the same error
(Reporter)

Comment 9

4 years ago
This error also exists in these versions:

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:31.0) Gecko/20100101 Firefox/31.0

Comment 10

4 years ago
This is most critical of raft of print bugs with migration to Adobe functionality.  Print is one of those things that needs to "just work" and for a long time it did until it was "improved" by using Adobe collaboration.  With that, now I'd say 1/3 of my print attempts fail, and fail in ugly and incomprehensible ways. 

As a result of this bug, can only "print" the first of indeterminate number of pages from U.S. Federal Court PACER web pages, which have a very conventional legacy HTML flavor and have not changed significantly in years.  Only workaround is to save complete HTML, open in IE.  Don't know politics behind Adobe move, but as end-user has only resulted in major regressions and loss of functionality and credibility.

Windows 7/Firefox 31.0

Updated

3 months ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 130589
You need to log in before you can comment on or make changes to this bug.