[Bluetooth] Unable to send a file using bluetooth transfer

RESOLVED DUPLICATE of bug 910140

Status

Firefox OS
Gaia::Bluetooth
P1
critical
RESOLVED DUPLICATE of bug 910140
4 years ago
4 years ago

People

(Reporter: arcturus, Unassigned)

Tracking

unspecified
x86
Mac OS X

Firefox Tracking Flags

(blocking-b2g:koi+)

Details

With current gaia master, when we try to use the bluetooth transfer, from the gallery or from the contacts export (under development), we get stuck in the |Select Bluetooth Device| screen.

We have the following javascript error when pression in the |ok| button:

E/GeckoConsole( 1882): [JavaScript Error: "TypeError: Argument 1 of BluetoothAdapter.connect is not an object." {file: "app://bluetooth.gaiamobile.org/js/transfer.js" line: 270}]
Blocks: 887534
Severity: normal → critical
blocking-b2g: --- → koi?
Priority: -- → P1

Comment 1

4 years ago
Gecko just update their API last Friday on bug 906305. We need to update corresponding code in gaia.
Thanks for the heads up Evelyn!
I'll handle this in bug 910140.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 910140
No longer blocks: 887534
blocking-b2g: koi? → koi+
You need to log in before you can comment on or make changes to this bug.